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About This Guide



2. Conventions

1. Introduction to the Ubuntu Desktop

Guide

Welcome to the Ubuntu Desktop Guide, a comprehensive guide to using
Ubuntu in a desktop environment.

The guide is divided into the following chapters:

1.

Getting Started - An introduction to the world of Ubuntu and some
basic concepts which are useful when getting started.

Adding, Removing and Updating Applications - How to manage
your software in Ubuntu.

Common Tasks - Performing common tasks on Ubuntu, including
playing music and video, using the internet, office and graphics pro-
grams and more.

Configuring Your System - Change the settings of your Ubuntu sys-
tem according to your needs.

Getting More Help - Where to find help if this guide doesn't provide
the answer.

HTML and PDF versions of the manual are available online at the Ubuntu
Documentation website [http://help.ubuntu.com].
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2. Conventions

2. Conventions

The following notes will be used throughout the book:

! E | A note presents interesting, sometimes technical, pieces of in-
formation related to the surrounding discussion.

ﬂ A tip offers advice or an easier way of doing something.

A caution alerts the reader to potential problems and helps
avoid them.

‘ 0 A warning advises the reader of a hazard that may arise in a
N given scenario.

Cross-reference conventions for print will be displayed as follows:

e Links to other documents or websites will look like this
[http://www.ubuntu.com].

! E | PDF, HTML, and XHTML versions of this document will use
hyperlinks to handle cross-referencing.

Type conventions will be displayed as follows:

» File names or paths to directories will be shown in nonospace.

* Commands that you type at a Terminal command prompt will be shown
as:

comand to type

* Options that you click, select, or choose in a user interface will be
shown in nonospace type.

Menu selections, mouse actions, and keyboard short-cuts:

* A sequence of menu selections will be displayed as follows: File ->
Open

* Mouse actions shall assume a right-handed mouse configuration. The

terms “click” and “double-click” refer to using the left mouse button.
The term “right-click” refers to using the right mouse button. The term

ix
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3. Contributing and Feedback

“middle-click” refers to using the middle mouse button, pressing down
on the scroll wheel, or pressing both the left and right buttons simultan-
eously, based on the design of your mouse.

Keyboard shortcut combinations will be displayed as follows: Ctrl-N
.Where the conventions for “Control”, “Shift,” and “Alternate” keys
will be Ctrl, Shift, and Alt, respectively, and shall mean the first key is
to be held down while pressing the second key.



3. Contributing and Feedback

3. Contributing and Feedback

This book is developed by the Ubuntu Documentation Team
[https://wiki.ubuntu.com/DocumentationTeam]. You can contribute to this
document by sending ideas or comments to the Ubuntu Documentation
Team mailing list. Information about the team, its mailing lists, projects,
etc. can be found on the Ubuntu Documentation Team Website
[https://wiki.ubuntu.com/DocumentationTeam].

If you see a problem with this document, or would like to make a sugges-
tion, you can simply file a bug report at the Ubuntu Bugtracker
[https://launchpad.net/products/ubuntu-doc/+bugs]. Your help is vital to the
success of our documentation!

Many thanks,

-Your Ubuntu Documentation Team

X1
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Chapter 1. Getting
Started

This chapter introduces the world of Ubuntu and some basic concepts which
are useful when getting started with an Ubuntu system.



1.1. About the Name

1. About Ubuntu

Thank you for your interest in Ubuntu 6.06 - the Dapper Drake release.

Ubuntu is an entirely open source operating system built around the Linux
kernel. The Ubuntu community is built around the ideals enshrined in the
Ubuntu Philosophy [http://www.ubuntu.com/ubuntu/philosophy]: that soft-
ware should be available free of charge, that software tools should be usable
by people in their local language and despite any disabilities, and that
people should have the freedom to customize and alter their software in
whatever way they see fit. For those reasons:

* Ubuntu will always be free of charge, and there is no extra fee for the
"enterprise edition," we make our very best work available to everyone
on the same Free terms.

* Ubuntu includes the very best in translations and accessibility infra-
structure that the free software community has to offer, to make Ubuntu
usable for as many people as possible.

* Ubuntu is released regularly and predictably; a new release is made
every six months. You can use the current stable release or the current
development release. Each release is supported for at least 18 months.

* Ubuntu is entirely committed to the principles of open source software
development; we encourage people to use open source software, im-
prove it and pass it on.

The Ubuntu community is comprised of developers, programmers, testers,
techwriters, documentation testers, translators, and most importantly, the
people who use Ubuntu every day. We invite you to join this community
and help make Ubuntu the operating system you, your family, your friends,
and your colleagues will love to use. Help us translate Ubuntu into your lan-
guage, try it on new and unusual hardware, improve the experience of other
users with hints, tips, and FAQs, or help to shape the direction Ubuntu is
headed by providing feedback about the software you love most.

Find out more at the Ubuntu website [http://www.ubuntu.com].

1.1. About the Name

Ubuntu is a South African ethical ideology focusing on people's allegiances
and relations with each other. The word comes from the Zulu and Xhosa
languages. Ubuntu (pronounced "0o-BOON-too") is seen as a traditional
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1.2. Free Software

African concept, is regarded as one of the founding principles of the new re-
public of South Africa and is connected to the idea of an African Renais-
sance.

A rough translation of the principle of Ubuntu is "humanity towards others".
Another translation could be: "the belief in a universal bond of sharing that
connects all humanity".

"A person with ubuntu is open and available to others, af-
firming of others, does not feel threatened that others are
able and good, for he or she has a proper self-assurance
that comes from knowing that he or she belongs in a
greater whole and is diminished when others are humili-
ated or diminished, when others are tortured or op-
pressed."

—Archbishop Desmond Tutu

As a platform based on GNU/Linux, the Ubuntu operating system brings
the spirit of ubuntu to the software world.

1.2. Free Software

The Ubuntu project is entirely committed to the principles of open source
software development; people are encouraged to use open source software,
improve it, and pass it on. This means that Ubuntu is and will always be
free of charge.

However, this means more than just being available at zero cost. The philo-
sophy of free software is that people should be free to use software in all the
ways that are "socially useful". "Free software" doesn't just mean that you
shouldn't have to pay for it, it also means that you should be able to use the
software in any way you wish: the code that makes up free software is
available for anyone to download, change, fix, and use in any way. So apart
from the fact that free software is often available without charge, this free-
dom also has technical advantages: when programs are developed, the hard
work of others can be used and built upon. With non-free software, this can-
not happen and when programs are developed, they have to start from
scratch. For this reason the development of free software is fast, efficient
and exciting!

You can find out more about the philosophy of free software here
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1.3. The Difference

[http://www.gnu.org/philosophy/].
1.3. The Difference

There are many different operating systems based on GNU/Linux: Debian,
SuSE, Gentoo, RedHat, and Mandriva are examples. Ubuntu is yet another
contender in what is already a highly competitive world. So what makes
Ubuntu different?

Based on Debian, one of the most widely acclaimed, technologically ad-
vanced, and well-supported distributions, Ubuntu aims to create a distribu-
tion that provides an up-to-date and coherent Linux system for desktop and
server computing. Ubuntu includes a number of carefully selected packages
from the Debian distribution and retains its powerful package management
system which allows easy installation and clean removal of programs. Un-
like most distributions that ship with a large amount of software that may or
may not be of use, Ubuntu's list of packages is reduced to a number of im-
portant applications of high quality.

By focusing on quality, Ubuntu produces a robust and feature-rich comput-
ing environment that is suitable for use in both home and commercial envir-
onments. The project takes the time required to focus on finer details and is
able to release a version featuring the latest and greatest of today's software
once every 6 months. Ubuntu is available in flavours for the 1386
(386/486/Pentium(II/III/TV) and Athlon/Duron/Sempron processors),
AMD64 (Athlon64, Opteron, and new 64-bit Intel processors), and Power-
PC (iBook/Powerbook, G4 and G5) architectures.

1.4. The Desktop

The default desktop environment for Ubuntu is GNOME
[http://www.gnome.org/], a leading UNIX and Linux desktop suite and de-
velopment platform.

Another leading UNIX and Linux desktop is KDE [http://www .kde.org/].
The Kubuntu [http://www kubuntu.org] project offers Ubuntu users an al-
ternative choice to the default GNOME desktop environment. Thanks to the
efforts of the Kubuntu team, Ubuntu users are now able to install and use
the KDE desktop easily on their system. To get a working install of
Kubuntu on an Ubuntu install, install the kubuntu-desktop package. Once
kubuntu-desktop is installed, one can choose to use either a Gnome or KDE
desktop environment.
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1.5. Version and Release Numbers

The Ubuntu version numbering scheme is based on the date we release a
version of the distribution. The version number comes from the year and
month of the release rather than reflecting the actual version of the software.
Our first release (Warty Warthog) was in October 2004 so its version was
4.10. This version (Dapper Drake) was released in June 2006 so its version
number is 6.06.

1.6. Backing and Support

Ubuntu is maintained by a quickly growing community. The project is
sponsored by Canonical Ltd. [http://www.canonical.com], a holding com-
pany founded by Mark Shuttleworth. Canonical employs the core Ubuntu
developers and offers support and consulting services for Ubuntu.

Canonical Ltd also sponsors a number of other Open Source software
projects, about which more information can be found on the Canonical
website [http://www.canonical.com].

1.7. What is Linux?

The Linux kernel [http://www kernel.org], pronounced 'lee-nucks' is the
heart of the Ubuntu operating system. A kernel is an important part of any
operating system, providing the communication bridge between hardware
and software.

Linux was brought to life in 1991 by a Finnish student named Linus Tor-
valds. At the time, it would run only on 1386 systems, and was essentially
an independently created clone of the UNIX kernel, intended to take ad-
vantage of the then-new 1386 architecture.

Nowadays, thanks to a substantial amount of development effort by people
all around the world, Linux runs on virtually every modern architecture.

The Linux kernel has gained an ideological importance as well as a technic-
al one. There is an entire community of people who believe in the ideals of
free software and spend their time helping to make open source technology
as good as it can be.

People in this community gave rise to initiatives such as Ubuntu, standards
committees that shape the development of the Internet, organizations like
the Mozilla Foundation, responsible for creating Mozilla Firefox, and
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1.8. What is GNU?

countless other software projects from which you've certainly benefited in
the past.

The spirit of open source, commonly attributed to Linux, is influencing soft-
ware developers and users everywhere to drive communities with common
goals.

1.8. What is GNU?

The GNU Project, pronounced “guh-noo”, was launched in 1984 to develop
a complete UNIX style operating system which is comprised of free soft-
ware: the GNU system. Variants of the GNU operating system, which use
the Linux kernel, are now widely used; though these systems are often re-
ferred to as “Linux,” they are more accurately called GNU/Linux systems.

The GNU project is closely linked to the philosophy of free software, which
is central to the projects that derive from it, such as Ubuntu. The concept of
free software is explained at Section 1.2, “Free Software” [3].



3. Linux Basics

2. Getting Ubuntu

There are a number of methods you may use to obtain a copy of Ubuntu, all
of which are described on the Ubuntu Web site download page
[http://www.ubuntu.com/download].

The first method is to download an ISO image from a mirror server near
you and make an 'Install CD' from it.

If you don't have a CD burner or you have limited or expensive bandwidth,
we can send you pressed copies of the 'Install CD' free of charge. You may
request CDs via Shipit [http://shipit.ubuntu.com], the Ubuntu CD Distribu-
tion System.

6 Ordered CDs may take several weeks to arrive.

You can also contact an Ubuntu Local Community Team (LoCoTeam) near
you. These are self-organized groups of Ubuntu enthusiasts who want to
bring the Ubuntu community onto a local level. Most LoCoTeams have ex-
tra copies of Ubuntu and give them out freely. A list of existing Ubuntu Lo-
CoTeams can be found on the Ubuntu wiki
[https://wiki.ubuntu.com/LoCoTeamList].

Another method of obtaining Ubuntu is to join a local Linux Users Group
(LUG) and ask if somebody can make you a copy. Normally, you will have
to pay for the cost of the CD and delivery.

If you do not know of an LUG near you, a list can be found at Linux Users
Groups WorldWide [http://lugww.counter.li.org/].
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3.1. Directories and File Systems

3. Linux Basics

Linux is inspired by the Unix operating system which first appeared in
1969, and has been in continous use and development ever since. Many of
the design conventions behind Unix also exist in Linux and are central to
understanding the basics of the system.

Unix was primarily oriented towards the command line interface, and that
legacy is carried on in Linux. Thus, the graphical user interface with its
windows, icons and menus are built on top of a basic command line inter-
face. Furthermore, this means that the Linux file system is structured to be
easily manageable and accessible from the command line.

3.1. Directories and File Systems

Linux and Unix file systems are organised in a hierarchical, tree-like struc-
ture. The highest level of the file system is the / or root directory. In the
Unix and Linux design philosophy, everything is considered a file - includ-
ing hard disks, partitions and removable media. This means that all other
files and directories (including other disks and partitions) exist under the
root directory.

For example, / hone/ j ebedi ah/ cheeses. odt shows the correct full path to
the cheeses. odt file that exists in the j ebedi ah directory which is under
the hone directory, which in turn, is under the root (/ ) directory.

Underneath the root (/) directory, there is a set of important system direct-
ories that are common across most Linux distributions that are used. The
following is a listing of common directories that are directly under the root
(/') directory:

* /bin - important binary applications

* /boot - boot configuration files

* /dev - the device files

* /etc - configuration files, startup scripts, efc...

* /hone - local users' home directories

* /lib - system [ibraries

* /lost+found - provides a lost+found system for files that exist under
the root (/) directory

* /medi a - mounted (loaded) removable media such as CDs, digital cam-
eras, etc...



3.2. Permissions

e /mt - mounted filesystems
* /opt - provides a location for optional applications to be installed

e /proc - special dynamic directory that maintains information about the
state of the system, including currently running processes

* /root - root user home directory, pronounced 'slash-root'

* /sbin - important system binaries

* /sys - system files

* /tnp - temporary files

* /usr - applications and files that are mostly available for all users to ac-
cess

* /var - variable files such as logs and databases

3.2. Permissions

All of the files on a Linux system have permissions that allow or prevent
others from viewing, modifying or executing. The super user "root" has the
ability to access any file on the system. Each file has access restrictions,
user restrictions and have an owner/group association.

Every file is secured by the following three sets of permissions, in order of
importance:

® user

applies to the user who is the owner of the file

* group

applies to the group that is associated with the file

e other

applies to all other users

Inside each of the three sets of permissions are the actual permissons. The
permissions, along with the way they apply differently to files and director-
ies, are outlined below:

e read
files can be displayed/opened

directory contents can be displayed
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* write
files can be edited or deleted

directory contents can be modified

* execute
executable files can be run as a program

directories can be entered

To view and edit the permissions on files and directories, open the Places-
>Home Folder and right-click on a file or directory. Then select Properties.
The permissions exist under the Permissions tab and allow for the editing of
all permission levels, if you are the owner of the file.

To learn more about file permissions in Linux, read the file permissions
page [https://wiki.ubuntu.com/FilePermissions] in the Ubuntu Wiki.

3.3. Root And Sudo

The root user in GNU/Linux is the user which has administrative access to
your system. Normal users do not have this access for security reasons.
However, Ubuntu does not include the root user. Instead, administrative ac-
cess is given to individual users, who may use the "sudo" application to per-
form administrative tasks. The first user account you created on your sys-
tem during installation will, by default, have access to sudo. You can re-
strict and enable sudo access to users with the Users and Groups application
(see Section 3.6, “Users and Groups” [13]Jfor more information).

When you run an application that requires root privileges, sudo will ask you
to input your normal user password. This ensures that rogue applications
cannot damage your system, and serves as a reminder that you are about to
perform administrative actions which require you to be careful!

To use sudo when using the command line, simply type "sudo" before the
command you wish to run. Sudo will then prompt you for your password.

Sudo will remember your password for a set amount of time. This feature
was designed to allow users to perform multiple administrative tasks
without being asked for a password each time.
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! E | Be careful when doing administrative tasks, you might dam-
age your system!

Some other tips on using sudo:

* Touse a "root" terminal, type "sudo -i" at the command line.

* All of the default graphical configuration tools in Ubuntu already use
sudo, so they will prompt you for your password if needed.

*  For more information on the sudo program and the absence of a root
user in Ubuntu, read the sudo page [https://wiki.ubuntu.com/RootSudo]
on the Ubuntu wiki.

3.4. Terminals

Working at the command line is not as daunting a task as you would think.
There is no special knowledge needed to know how to use the command
line, it is a program like everything else. Most things in Linux can be done
using the command line, although there are graphical tools for most pro-
grams, sometimes they are just not enough. This is where the command line
comes in handy.

The terminal is often called the command prompt or the shell. In days gone
by, this was the way the user interacted with the computer, however Linux
users have found that the use of the shell can be quicker than a graphical
method and still holds some merit today. Here you will learn how to use the
terminal.

The original use of the terminal was a file browser and indeed it is still used
as a file browser, in the event of the graphical environment failing. You can
use the terminal as a file browser to navigate your files and undo the
changes that have been made.

3.4.1. Starting the Terminal

To start Terminal choose Applications->Accessories->Terminal .

3.4.2. Common Commands

View Directories: - Is The 1s (LiSt) lists files in different
colors with full formatted text

Create Directories: - mkdir The mkdir (MaKeDIRectory) com-

(directory name) mand will create a directory.

11
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Change Directories: - cd
(/directory/location)

Copy Files/Directories: - cp (file or
directory name) (to directory or fi-
lename)

Remove Files/Directories: - rm (file
or directory name)

Rename Files/Directories: - mv
(file or directory name)

Find Files/Directories: - locate (file
or directory name)

The cd (ChangeDirectory) command
will change from your current direct-
ory to any directory you specify.

The cp (CoPy) command will copy
any files you specify. The cp -r com-
mand will copy any directories you
specify.

The rm (ReMove) command will de-
lete any filename you specify. The rm
-rf command will remove any direct-
ory you specify.

The mv (MoVe) command will re-
name/move any file or directory you
specify.

The locate command will search your
computer for any filename you spe-
cify. It uses an index of the files on
your system to work quickly: to up-
date this index run the command up-
datedb. This command is run auto-
matically each day, if you leave your
computer on. It needs to be run with
administrative privileges (see Sec-
tion 3.3, “Root And Sudo” [10]).

You can also use wildcards to match one or more files, such as "*" (for all
files) or "?" (to match one character).

For a more thorough introduction to the Linux command line, please read
the command line introduction [https://wiki.ubuntu.com/BasicCommands]
on the Ubuntu wiki.

3.4.3. Switch to Console mode

The usual method of command-line access in Ubuntu is to start a terminal
(see Section 3.4.1, “Starting the Terminal” [11] above) , however some-
times it is useful to switch to the real console:

1. Use the Ctrl-Alt-F1 shortcut keys to switch to the first console.
2. To switch back to Desktop mode, use the Ctrl-Alt-F7 shortcut keys.

12
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! E | There are six consoles available. Each one is accessible with
the shortcut keys Ctrl-Alt-F1 to Ctrl-Alt-F6.

3.4.4. Disable the beep sound in Terminal mode

1. Start a Terminal session, select: Applications->Accessories->Terminal
from the desktop menu system.

2. Edit->Current Profile... . Select the General tab. Uncheck the Terminal
bell checkbox.

3.5. Text Editing

All of the configurations and settings in Linux are saved in text files. Even
though you most often can edit configurations through the graphical inter-
face, you may occasionally have to edit them by hand. Gedit is the default
Ubuntu text editor, which you can launch by clicking Applications-
>Accessories->Text Editor on the desktop menu system.

At times in this guide, Gedit is run from the command line using gksudo,
which runs Gedit with administrative privileges, in order to modify config-
uration files.

If you need to use a text editor from the command line, you can use nano,
which is a simple to use text editor. When running it from the command
line, always use the following command, which ensures that the editor will
not introduce line breaks:

nano -w

For more information about how to use nano, refer to the guide on the wiki
[https://wiki.ubuntu.com/NanoHowto].

There are also quite a few other terminal-based editors available in Ubuntu,
popular ones include VIM and Emacs (the pros and cons of each are cause
for much friendly debate within the Linux community). These are often
more complex to use than nano, but are also more powerful.

3.6. Users and Groups

To add users or groups to your system, you can use the Users And Groups
application located in System->Administration->Users and Groups .

13
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3.6. Users and Groups

To add a new user, click on Add user, fill-in the data fields then click OK.
To edit the properties of each user, click the Properties button located in the
main Users window.

To add a new group, select the Groups tab and click Add group. Choose a
name for the new group and, if you want, change the default value for the
Group ID. If you try to allocate a Group ID that is in use, the system will
warn you.

You can add users to the newly created group by selecting a user from the
left menu and clicking on the Add button. Removing a user is as simple as
adding one: select a user from the right menu then click Remove. When you
are ready, click OK and the new group with its users, if inserted, will be
created.

To edit the properties of a group, from within the Groups main window,
choose a group name and click on the Properties button.

To remove a user or a group from the system, select the user or group you
want to delete and click Delete.

14



Chapter 2. Adding,
Removing and Updating
Applications

This chapter is a complete guide to adding, removing and updating applica-
tions on an Ubuntu system.
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2. Add/Remove Applications

1. Introduction

In order to add or remove applications in Ubuntu you need to use a package
manager. A package manager is a tool that makes installing and unin-
stalling applications easy by handling the software in preconfigured pack-
ages that are optimized for Ubuntu. The following package managers are
described in this chapter:

* Add/Remove Applications - this is the simplest way to manage pro-
grams.

* Synaptic - this graphical program provides a more advanced means of
managing programs.

* APT - this is a powerful command line program to manage programs.

You may also wish to increase the number of programs available to install
through your package managers. Not all the programs that exist for Ubuntu
are available by default. You may have to add extra repositories in order to
make them available: that is also described in this chapter.

Finally, this chapter explains how to update your system.

D You can only have one package management application run-
ning at a time. For example, if you are running Add/Remove
Applications and try to launch Update Ubuntu, it will fail with
an error. Close the running application before you relaunch the
new one.
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3. Synaptic Package Manager

2. Add/Remove Applications

Add/Remove Applications is a simple graphical way of installing and re-
moving applications in Ubuntu. To launch Add/Remove Applications click
Applications->Add/Remove Applications on the desktop menu system.

! E I Running Add/Remove Applications requires administrative
privileges (see Section 3.3, “Root And Sudo” [10]).

To install new applications select the category on the left, then check the
box of the application you want to install. When finished click Apply, then
your chosen programs will be downloaded and installed automatically, as
well as installing any additional applications that are required.

Alternatively, if you know the name of the program you want, use the
Search tool at the top.

! E I If you have not activated the online package archive, you may
be asked to insert your Ubuntu CD-ROM to install some pack-
ages.

Some applications and packages are not available to install using Add/

Remove Applications. If you cannot find the package you are looking for,
click Advanced which will open the Synaptic package manager (see below).
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4. Command Line Package Management

3. Svynaptic Package Manager

Synaptic is an advanced package management application that can install
and remove every package available to your system. The interface is graph-
ical like Add/Remove Applications but a lot more information is presented
to the user, which means that Synaptic gives you complete control over the
package management of your system.

! E I Running Synaptic requires administrative privileges (see Sec-
tion 3.3, “Root And Sudo” [10]).

To launch Synaptic, choose System->Administration->Synaptic Package
Manager on the desktop menu system.

The Synaptic screen is divided up into four sections, the two most important
being the package categories on the left side, and the packages on the right.

To install packages, just choose the category, find the package name in the
list, right click on it and choose "Mark this package for installation". Once
you are satisfied with your selections click Apply on the top button bar.
Synaptic will then download and install the required packages from the on-
line repositories and/or from your Ubuntu installation CD.

Alternatively you can click the Search tool bar button, enter the package
name or a short search term in the search text field and click the Search but-
ton.

Synaptic will now show you a much shorter list from which to select your
application for installation. This is usually much easier than having to look
through the very long list of applications on your own.
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4.1. APT

4. Command Line Package Management

4.1. APT

APT (Advanced Packaging Tool) is a powerful package management sys-
tem, on which the graphical programs described above like Add/Remove
Applications and Synaptic are based. APT automatically handles dependen-
cies and performs other operations on system packages to allow the installa-
tion of the desired package/s.

! E i Running APT requires administrative privileges (see Sec-
tion 3.3, “Root And Sudo” [10]).

Some common commands that can be used with APT:

* Install packages:

sudo apt-get install packagenane

* Remove packages:

sudo apt-get renove packagenane

* Retrieve new lists of packages:

sudo apt-get update

* Upgrade system with available updates:

sudo apt-get upgrade

* List further commands and options:

apt-get help

For further information about the use of APT, read the com-
prehensive Debian APT User Manual
[http://www.debian.org/doc/user-manuals#apt-howto].
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5.1. Install/uninstall .deb files

5. Installing a Single Package File

The preferred method of installing programs is via the package managers
described in this chapter. However, although the Ubuntu package archives
are very large, it is possible that you may wish to install a package which is
not available in the Ubuntu archives. If this happens, you can also download
and install files from websites.

It is important to ensure that any files you download come
from a safe source before installing them.

There are many different kinds of Linux package files. Most of these are as-
sociated with the package managers of specific Linux distributions. Ex-
amples are Debian Package files (.deb files), Redhat Package Manager
files (.rpm files), and Tarballs (.tar files).

This section deals with installing these single files.

‘ OI It is not guaranteed that these files will be compatible with

N your system and you will not receive security updates if you
install these files. For these reasons, if you wish to install a
program, always use a native Ubuntu package of the applica-

tion available through a package manager, if there is one avail-
able.

5.1. Install/uninstall .deb files

These files are Debian packages. The package files associated with Ubuntu
have the .deb suffix because of Ubuntu's close relations with the Debian
GNU/Linux distribution. You will need administrative privileges to install a
.deb file (see Section 3.3, “Root And Sudo” [10]).
To install a .deb file, simply double click on it.
2. Alternatively, you can also install a .deb file by opening a terminal and
typing:
sudo dpkg -i package_file.deb

3. To uninstall a .deb file, deselect it in your package manager, or type:

sudo dpkg -r package_nane

20



5.3. Install tarballs

5.2. Convert .rpm files to .deb files

Another type of package files is Red Hat Package Manager files which
have the .rpm suffix. It is not recommended to install these on an Ubuntu
system. In almost all cases, a native Ubuntu .deb package is available.
However, if absolutely necessary, an .rpm file can be converted to a .deb
package using the program alien.

1. Install the alien program (Chapter 2, Adding, Removing and Updating
Applications [15]).

2. Run the following command in a terminal, with administrative priv-
ileges:

sudo alien package_file.rpm

5.3. Install tarballs

Files with the .far.gz or .tar.bz2 suffix are package files known as tarballs
which are widely used in Linux and Unix.

If there is no native Ubuntu package available in any of the Ubuntu reposit-
ories, you can use the command line to install or uninstall the Tarball file by
following the instructions that come with the package.

Tarballs often contain the source code of the program, and need to be com-
piled in order to be used. To do this, extra software will generally be needed
(see Section 8.1, “Basic Compilers” [44).
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6.1. What are Repositories?

6. Extra Repositories

6.1. What are Repositories?

There are thousands of programs available to install on Ubuntu. These pro-
grams are stored in software archives (repositories) and are made freely
available for installation over the Internet. This makes it very easy to install
new programs in Linux, and it is also very secure, because each program
you install is built specially for Ubuntu and checked before it is installed.
To organise the software, Ubuntu repositories are categorised into four
groups: Main, Restricted, Universe, and Multiverse.

The rationale used to determine which software goes into which category is
based on two factors:

* The level of support software development teams provide for a program.

* The level of compliance the program has to the Free Software Philo-
sophy [http://www.ubuntu.com/ubuntu/philosophy].

You can find more information about the Repositories available on the web-
site [http://www.ubuntu.com/ubuntu/components].

The standard Ubuntu Install CD contains some software from the Main and
Restricted categories. Once your system is made aware of the Internet-based
locations for these repositories, many more software programs are made
available for installation. Using the software package management tools
already installed on your system, you can search for, install and update any
piece of software directly over the Internet, without the need for the CD.

6.2. Adding Extra Repositories

To enable the extra repositories:

Open System->Administration->Software Properties .
Select Add

To enable the Universe repository, check the Community Maintained
(Universe) button.

! E | Adding this repository will mean that the majority of the

Free Software universe will be available to install on your
system. This software is supported by a carefully selected
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7. Updates

group of volunteers within the Ubuntu Community, but is
not supported by the core Ubuntu development team and
may not include security updates.

To enable the Multiverse repository, check the Non-free (Multiverse)
button.

| OI Adding this repository will mean that software which has

\ been classified as non-free will be available to install on
your system. This software may not be permitted in some
jurisdictions. When installing each package from this re-
pository, you should verify that the laws of your country

permit you to use it. Again, this software may not include
security updates.

Click Close to save your changes and exit.
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7. Updates

7. Updates

Sometimes the Ubuntu developers release feature and security updates for
applications and packages within the Ubuntu system.

When these updates are available, Ubuntu will inform you with a pop-up
and a red icon in your notification area. To update your system, click the
red button, enter your password and click OK.

The Update Manager program will list the available updates: to download
and install these updates click Install Updates. Ubuntu will then download
and install the available updates from the Internet.

When Update Manager has finished updating your system, close the pop-up
window with the Close button, then close Update Manager to finish updat-
ing your system.

! E I After installing some important updates, it may be necessary

to restart your computer. If so, Ubuntu will inform you with a
popup and an icon in your notification area.
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Chapter 3. Common
Tasks

This chapter contains information on common tasks.
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1.1. Playing and Extracting Audio CDs

1. Music

1.1. Playing and Extracting Audio CDs

When you insert an audio CD, the Sound Juicer CD player and ripper opens
automatically. To play the CD, click the Play button or press Ctrl-P. To
play a particular track, double-click on the track or select the track and click
Play.

To extract (rip) your audio CD, make sure the tracks that you want to rip are
selected, then click the Extract button or press Ctrl-Enter.

E If you are connected to the internet, Sound Juicer will retrieve
the CD artist, title, and track data from MusicBrainz.org
[http://musicbrainz.org], a community-maintained database
which contains data on over 360,000 albums.

To start Sound Juicer manually, choose Applications->Sound & Video-
>Sound Juicer CD Extractor.

You can use the preferences window to control where the extracted audio
files are stored on your computer, the filename of extracted audio files, and
the file format and codec used for the files. In the main window, choose
Edit->Preferences.

Sound Juicer can extract audio files to the following formats:

* Ogg Vorbis - Ogg Vorbis is a patent-free lossy audio compression
format which typically produces higher quality and greater compression
than MP3. See the Vorbis website [http://www.vorbis.com/faq/] for
more information.

* FLAC - FLAC is the Free Lossless Audio Codec. It can compress audio
files up to 50% without removing any information from the audio
stream. For more information on this format, see the FLAC homepage
[http://flac.sourceforge.net/] on sourceforge.net.

* WAV - Use the WAV format for voice recordings. Sound Juicer uses
this format for low quality mono audio files.

You can also extract CD audio files to the proprietary non-free MP3 format.

Instructions on how to rip to the MP3 format are in the help for Sound
Juicer. Choose Help->Contents and navigate to the Preferences section.
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1.3. Playing and Organising Music Files

1.2. Burning CDs

When you put a blank CD in the drive Ubuntu will ask if you want to burn
an audio or data CD. Clicking on Burn Audio CD will launch Serpentine .

To add music to your audio CD, either drag music from your File Browser
or use the Add button. You will also need to select the size of your CD (21,
74, 80 or 90 minutes). Serpentine will warn you if you exceed the set limit.

To make a photo or data CD, click the burn Burn Data CD. Ubuntu will
open a CD/DVD Creator window. The CD Creator is built into the File
Browser, and it allows you to add any file or folder you have permission to
access. When you are ready to burn the CD, click Write to Disc. Ubuntu
will then prompt you to select the drive containing the blank CD, and give
you the opportunity to name the CD and select the write speed. Finally,
click Write to create the new photo or data CD.

1.3. Playing and Organising Music Files

To play and organize your music, Ubuntu comes with Rhythmbox Music
Player, which looks similar to iTunes. When you first start Rhythmbox, it
will scan your home directory for any supported music files you have and
add it to the database. To start Rhythmbox, choose Applications->Sound &
Video->Rhythmbox Music Player

Ubuntu does not directly support the MP3 format, because it is restricted by
patents and proprietary rights. Instead Ubuntu supports the Ogg Vorbis
format out of the box, a completely free, open and non-patented format.
Ogg Vorbis files also sound better then MP3 files of the same file size and
are supported by many popular music players (a list of players is here
[http://wiki.xiph.org/index.php/PortablePlayers]).

You can still play your old MP3 files by installing MP3 support (see Sec-
tion 3, “Multimedia Codecs” [32). Instructions for other formats, such as
Windows Media Audio (wma/wmv) and other patent encumbered formats
can be found on the Ubuntu Wiki
[http://wiki.ubuntu.com/RestrictedFormats].

The Cowbell ID3 tag editor can edit the metadata on your mp3 and other
music files. To use Cowbell:

1. Install the cowbell package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]);
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1.4. Using your Ipod

2. To run Cowbell, choose Applications->Sound & Video->Cowbell Mu-
sic Organizer.

1.4. Using your Ipod

You can play music directly off your IPOD with Rhythmbox Music Player.
Simply plug your IPOD into the computer, and open Rhythmbox.

To transfer music files to and from an IPOD, you can use the program gtk-
pod:

1. Install the gtkpod package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. To run gtkpod, choose Applications->Sound & Video->gtkpod.

1.5. Editing Audio Files

Audacity is free, open source software for recording and editing sounds. To
use Audacity:

1. Install the audacity package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

To run Audacity, choose Applications->Sound & Video->Audacity.

3. For further help about using Audacity, consult the program's help by
choosing Help->Contents.
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2.1. DVD Playback

2. Video

To play video, Ubuntu comes with Totem Movie Player which looks and
functions similar to Windows Media Player. Some features of Totem in-
clude custom playlists, DVD playback and more. You can start Totem by
clicking: Applications->Sound & Video->Movie Player from the desktop
menu system.

To read video files, Totem uses the Gstreamer framework. To play some
video formats, you may need to add further codec support (see Section 3,
“Multimedia Codecs” [32}.

There are also other multimedia applications available. Examples include
Mplayer, Xine and Totem-xine (which uses the Xine framework, instead of
the Gstreamer framework. Some users may benefit from trying alternative
video players.

2.1. DVD Playback

The movie players provided in Ubuntu are capable of reading DVDs that
are not encrypted. However, most commercial DVDs are encrypted with
CSS (the Content Scrambling System) and currently for legal reasons it is
not possible to include support for these DVDs in Ubuntu. However it is
possible to enable support as follows:

‘ 0 The legal status of this library is not fully clear. In some coun-
N tries it is possible that the use of this library to play or copy
DVDs is not permitted by law. Verify that you are within your

rights in using it.

1. Install the libdvdread3 package (see Chapter 2, Adding, Removing and
Updating Applications [15]).

! E | You will need to use Synaptic Package Manager to install
this package

2. To activate DVD decryption, type the following line into a terminal
prompt:

sudo /usr/share/doc/|ibdvdread3/ exanpl es/install-css.sh

3. To play DVDs with Totem, you will need to install some extra codecs
(see Section 3, “Multimedia Codecs” [32).
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2.2. Backing Up DVDs

However, the Gstreamer framework (used by Totem) does not support
menus or subtitles for DVD playback. For this reason, you can install a
separate DVD player, Xine, which supports these. To install Xine, in-
stall the gxine package from the Universe repository (see Chapter 2,
Adding, Removing and Updating Applications [15]).

You can then open gxine from the Sound & Video menu.

2.2. Backing Up DVDs

Backing up your DVDs to files or onto DVD+/- discs can be done with
DVD::RIP. To install DVD::RIP:

‘ 0 Before backing up a DVD, you must ensure that you are leg-
N ally permitted to make copies of it.

1.

Install the Multimedia Codecs (see Section 3, “Multimedia Codecs”
[21).
Enable DVD video playback (see Section 2.1, “DVD Playback” [29]).

Install dvdrip and transcode from the Multiverse repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

You can run the program using the command dvdrip (see Section 1.2,
“Start a Program Manually” [48}. If you wish, you can add a menu
entry for the program dvdrip (see Section 1.1, “Menu Editing” [48).
We recommend you enter it in the Sound & Video menu, and that you
use the file / usr/ shar e/ per| 5/ Vi deo/ DVDRi p/ i con. xpmfor the icon.

To start dvd::rip, choose Applications->Sound & Video->dvd::rip.

2.3. RealPlayer 10

1.

30

Install the libstdc++5 package (see Chapter 2, Adding, Removing and
Updating Applications [15]).

! E I You will need to use Synaptic Package Manager to install
this package

Download the Realplayer package from here
[ftp://ftp.nerim.net/debian-marillat/pool/main/r/realplay/realplayer_10.
0.6-0.0_i386.deb].

Install the package you have downloaded (see Section 5.1,


ftp://ftp.nerim.net/debian-marillat/pool/main/r/realplay/realplayer_10.0.6-0.0_i386.deb

2.4. Video Editing

“Install/uninstall .deb files” [20]).

4. To run Real Player 10, choose Applications->Sound & Video-
>RealPlayer 10.

2.4. Video Editing

Kino is an advanced video editor. It features excellent integration with
IEEE-1394 for capture, VTR control, and recording back to the camera. It
captures video to disk in Raw DV and AVI format, in both type-1 DV and
type-2 DV (separate audio stream) encodings. For more information, see the
Kino website [http://www kinodv.org/article/static/2]. To use it:

1. Install the kino package (see Chapter 2, Adding, Removing and Updat-
ing Applications [15]).

2. To run Kino, choose Applications->Sound & Video->Kino Video Edit-
or.

You can also try the PiTiVi video editor by installing the pitivi package
from the Universe repository (see Chapter 2, Adding, Removing and Updat-
ing Applications [15]). PiTiVi is a video editor for the GNOME desktop. It
is still in fairly early development, but worth a try.
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3.1. Add Codecs to Gstreamer

3. Multimedia Codecs

Many applications in Ubuntu use the GStreamer open source multimedia
framework. The codec plugins for GStreamer are organised in different
packages depending on the licensing that applies to the various codecs. You
can see which codecs are contained in which plugin on the GStreamer web-
site [http://gstreamer.freedesktop.org/documentation/plugins.html].

Other applications, such as Mplayer and Xine, do not use the Gstreamer
framework. Due to patent and copyright restrictions, codecs for these pro-
grams are not included at all in Ubuntu. For more information on these read
the Restricted Formats [https://wiki.ubuntu.com/RestrictedFormats] wiki

page.
3.1. Add Codecs to Gstreamer

To install extra codecs for Gstreamer:

»  Install the following packages from the Universe and Multiverse repos-
itories (see Chapter 2, Adding, Removing and Updating Applications
[15]):

gstreamer(.10-plugins-ugly
gstreamer(.10-plugins-ugly-multiverse
gstreamer(.10-plugins-bad
gstreamer(.10-plugins-bad-multiverse
gstreamer(.10-ffmpeg

! E | You will need to use Synaptic Package Manager to install
these packages

| 0 Some of these packages may not be permitted in some
\ countries: you should verify that you are permitted to use

them before installing them.

32


http://gstreamer.freedesktop.org/documentation/plugins.html
http://gstreamer.freedesktop.org/documentation/plugins.html
https://wiki.ubuntu.com/RestrictedFormats

4.1. Connecting to the Internet

4. Internet

4.1. Connecting to the Internet

To connect to the internet, do the following:

1. If you have a Modem or ADSL connection, read Section 3.5,
“Modems” [62 [first.

System->Administration->Networking

3. Select the Connections tab. Select the Et her net connect i on interface
from the list, then click the Properties button. Ensure that the button
marked Enable this connection is checked. From the Configuration
drop-list select DHCP/ Stati ¢ | P addr ess, then click OK.

4. Select the DNS tab add or delete DNS Servers in the DNS Servers list.
To activate or deactivate network connections, do the following:

1. System->Administration->Networking

2. Select Network settings+Connections Tab+Ethernet connection Act i v-
at e/ Deacti vate

4.2. Browse Network Computers

1. To view computers on the network, open:

Places->Network Servers

2. You may need to enter a username and password, and a domain. You
should obtain these from your network administrator.

3. Alist of network resources will be displayed.

4.3. Email

The Evolution groupware suite can handle all your email, contact lists, tasks
and calendar needs. It also can act as a newsreader and also integrates with
the Gnome panel clock, giving you one-click access to your task list.

Evolution can be launched by clicking Applications->Internet->Evolution
Mail from the desktop menu system.

Alternatively the Mozilla Thunderbird email client is available. To install
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4.4, World Wide Web

this popular email client, install the mozilla-thunderbird package (see
Chapter 2, Adding, Removing and Updating Applications [15]).

To start Thunderbird, choose Applications->Internet->Thunderbird Mail
Client from the desktop menu system.

4.4. World Wide Web

The powerful and secure Mozilla Firefox web browser is included in
Ubuntu. Firefox features tabbed browsing, pop-up blocking, in-built search
facilities, live bookmarks and more. Also supported are popular plug-ins
such as Java, Macromedia Flash, and Real Player. Firefox can be launched
by clicking Applications->Internet->Firefox from the desktop menu system.

4.4.1. Viewing Online Audio and Video in Firefox

In order to view online audio and video streams in Firefox, you may need to
install some plugins. Which plugin you choose to install depends on the me-
dia player which you prefer (see Section 2, “Video” [29]).

1. For the Totem Gstreamer plugin (the default Ubuntu media player), in-
stall the totem-gstreamer-firefox-plugin package from the Universe re-
pository (see Chapter 2, Adding, Removing and Updating Applications
[15]).

2. For the Totem Xine plugin, install the totem-xine-firefox-plugin pack-
age from the Universe repository (see Chapter 2, Adding, Removing
and Updating Applications [15]).

3. For the Mplayer plugin, install the mozilla-mplayer package from the
Multiverse repository (see Chapter 2, Adding, Removing and Updating
Applications [15]).

4. The changes will take effect when you close and open Firefox.

! E | These steps will install the plugin for Firefox. However, to
play some formats, you may need to add some extra codecs
(see Section 3, “Multimedia Codecs” [32]).

4.4.2. Macromedia Flash for Firefox

To view flash graphics from the Mozilla Firefox web browser:

1. Install the flashplugin-nonfree package from the Multiverse repository
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4.5. Instant Messaging

(see Chapter 2, Adding, Removing and Updating Applications [15]).

2. To download and install the plugin, enter the following command in a
terminal:

sudo update-flashpl ugin

3. The plug-in will be available the next time you start Firefox.

4.4.3. Java plugin for Mozilla Firefox

Some websites require the Java plugin for Mozilla Firefox. There are two
ways of enabling support for this plugin. Most users will find that the easi-
est way is to install the j2rel.4-mozilla-plugin package from the Multiverse
repository.

Alternatively, for a more complete Java installation, see Section 8.2, “Java
Runtime Environment (1.5)” [44]

4.4.4. NVU Web Authoring System

NVU is a WYSIWYG (What You See Is What You Get) graphical web
design application, similar to Dreamweaver.

1. Install the nvu package from the Universe repository (see Chapter 2,
Adding, Removing and Updating Applications [15]).

2. To start Nvu, choose Applications->Office->Nvu from the desktop
menu system.

4.4.5. Bluefish Web Development Studio

Bluefish is a powerful editor for web designers and programmers. Bluefish
supports many programming and markup languages, and includes many
utilities for designers and programmers.

1. Install the bluefish package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. To start Bluefish, choose Applications->Programming->Bluefish Edit-
or

4.5. Instant Messading
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4.6. Peer To Peer

4.5.1. Gaim

Gaim is the default instant messenger client in Ubuntu. With Gaim you can
talk to people who use AIM/ICQ, Gadu-Gadu, GroupWise, IRC, Jabber,
MSN, Napster and Yahoo. The ability to use one client instead of several is
a great benefit and allows you to have all of your buddies in one window so
you can just click a name and talk. To start Gaim, choose Applications-
>Internet->Gaim Internet Messenger from the menu.

4.5.2. XChat-GNOME

XChat-GNOME is a advanced, graphical, multi-platform Internet Relay
Chat (IRC) client. Its features include advanced scripting support (perl and
python) and a clean, easy to use interface.

1. Install the xchat-gnome package from the main repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. To start XChat-GNOME, choose Applications-
>Internet->Xchat-GNOME IRC Chat .

4.5.2.1. Joining #ubuntu with XChat-Gnome

One excellent way to get help with Ubuntu or introduce yourself to IRC is
to join Ubuntu's official support channel on Freenode.

Start XChat-Gnome as above.

2. When you start XChat-Gnome for the first time, it will ask you for an
IRC Nickname & your real name. Pick anything you want for your
nick (first initial & your last name is good, or be more creative), put
your real name or part of it, and press OK.

3. In the Server Window that opens next, select Ubuntu Servers, and
press Connect.

4.6. Peer To Peer

4.6.1. BitTorrent

BitTorrent capability is included in Ubuntu by default. Find a BitTorrent
storrent file online, click on it in Firefox, and the Gnome BitTorrent client
should start automatically.
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4.7. News Readers

Alternatively, download a . t orrent file and double click on it.

4.6.2. aMule File Sharing Client

1. Install the amule package from the Universe repository (see Chapter 2,
Adding, Removing and Updating Applications [15]).

2. To open aMule, choose Applications->Internet->aMule

4.7. News Readers

4.7.1. Pan News Reader

1. Install the pan package (see Chapter 2, Adding, Removing and Updat-
ing Applications [15]).

2. To open Pan Newsreader, choose Applications->Internet->Pan News-
reader.

4.7.2. Liferea News Reader

1. Install the liferea package from the Universe repository (see Chapter 2,
Adding, Removing and Updating Applications [15]).

2. To open Liferea Feed Reader, choose Applications->Internet->Liferea
Feed Reader.
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5.1. Introduction

5. Office

5.1. Introduction

Ubuntu comes with a comprehensive office suite installed - OpenOffice.org.
The OpenOffice.org project is one of the most successful open source
projects in the world, and provides a powerful wordprocessor, spreadsheet,
presentation designer and database management, and provides support for
most languages. The Suite has excellent compatibility with other major Of-
fice suites, such as Microsoft Office.

For more information about OpenOffice.org, see the OpenOffice.org web-
site [http://www.openoffice.org/product/index.html].

However, you may wish to add extra programs to your system. This section
outlines a number of other useful office applications.

5.2. GNOME Office

The GNOME desktop features a separate office suite. These programs are
generally lighter and faster than the programs in the OpenOffice.org suite,
and have fewer features as a result. But this may be exactly what you want.
The Suite has excellent compatibility with other major Office suites, such as
Microsoft Office.

The GNOME Office Suite includes the following software:

* A word processor (Abiword);

* A spreadsheet (Gnumeric);

* A database management program (GNOME-DB);

* A diagram editor (Dia);

* Two graphics applications (Inkscape and The GIMP); and

* A project management application (Planner).

! E | Each of these applications can also be installed separately.

To install the GNOME Office suite:

1. Install the gnome-office package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. The Office applications can then be found in the menu at Applications-
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5.3. GnuCash Accounting Application

>Office, and the Graphics applications can be found at Applications-
>Graphics.

5.3. GnuCash Accounting Application

GnuCash is a program to manage your personal or business finances. De-
signed to be easy to use, yet powerful and flexible, GnuCash allows you to
track bank accounts, stocks, income and expenses. As quick and intuitive to
use as a checkbook register, it is based on professional accounting prin-
ciples to ensure balanced books and accurate reports.

To find out more about GnuCash, see the GnuCash website
[http://www.gnucash.org/].

To use GnuCash:

1. Install the gnucash package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. You can open GnuCash by running the command gnucash (see Sec-
tion 1.2, “Start a Program Manually” [48). If you wish, you can add a
menu entry for the program gnucash (see Section 1.1, “Menu Editing”

[48).

5.4. Scribus Desktop Publishing Application

Scribus is a professional desktop publishing program. For more informa-
tion, see the Scribus website [http://www.scribus.org.uk/].

1. Install the scribus package (see Chapter 2, Adding, Removing and Up-
dating Applications [15]).

2. To install additional templates, install the scribus-template package
from the Universe repository (see Chapter 2, Adding, Removing and
Updating Applications [15]).

! E | You will need to use Synaptic Package Manager to install
this package

3. To start Scribus, choose Applications->Office->Scribus .
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6.1. gThumb Image Viewer

6. Graphics & Drawing

Ubuntu has some very powerful, world-class graphics and drawing applica-
tions available.

6.1. gThumb Image Viewer

gThumb is an advanced image viewer and browser. It has many useful fea-
tures, such as filesystem browsing, slide show, image catalogs, web album
creation, camera import, image CD burning, batch file operations and quick
image editing features like transformation and color manipulation.

gThumb is included in Ubuntu by default. To start it, choose Applications-
>Graphics->gThumb Image Viewer .

gThumb's excellent help files are accessible from Help->Contents.

For more advanced photo & image editing, see The GIMP, below.

6.2. The GIMP (Gnu Image Manipulation Program)

The GIMP lets you draw, paint, edit images, and much more! GIMP in-
cludes the functionality and plug-ins of other famous image editing and pro-
cessing programs.

The GIMP is installed in Ubuntu by default, and can be started by choosing
Applications->Graphics->GIMP Image Editor .

More information is available from the GIMP homepage.
[http://www.gimp.org/]

6.3. Inkscape Vector Graphics Editor

Inkscape is a powerful editor for working with the SVG (Scalable Vector
Graphics) format.

1. Install the inkscape package (see Chapter 2, Adding, Removing and
Updating Applications [15]).

2. To start Inkscape choose Applications->Graphics->Inkscape SVG
Vector Illustrator .

6.4. Blender 3d Modeller
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7. Games

Blender is an integrated 3d suite for modelling, animation, rendering, post-
production, interactive creation and playback.

1. Install the blender package (see Chapter 2, Adding, Removing and Up-
dating Applications [15]).

2. To start Blender choose Applications->Graphics->Blender 3d model-
ler.
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7.1. Frozen-Bubble

7. Games

Ubuntu comes with a number of games by default, including Aisleriot Solit-
aire, Gnometris, and Mines.

Explore Ubuntu's Games menu at Applications->Games .

7.1. Frozen-Bubble

In Frozen-Bubble you attempt to shoot bubbles into groups of the same col-
or to cause them to pop.

1. Install the frozen-bubble package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. To start Frozen-Bubble, choose Applications-
>Games->Frozen-Bubble.

7.2. PlanetPenguin Racer

Race Tux, the Linux mascot, down a snow- and ice-covered mountain as
quickly as possible, avoiding the trees and rocks that will slow you down.

! E I Ensure you have hardware accelerated 3D drivers installed for
your video card. For more information see Section 3,
“Hardware” [59]

1. Install the planetpenguin-racer package from the Universe repository
(see Chapter 2, Adding, Removing and Updating Applications [15]).

2. To start PlanetPenguin Racer, choose Applications-
>Games->PlanetPenguin-Racer.

7.3. Scorched3D

Scorched3D is a 3D remake of Scorched Earth, an artillery duel game.

! E I Ensure you have hardware accelerated 3D drivers installed for
your video card. For more information see Section 3,
“Hardware” [59]

1. Install the scorched3d package from the Universe repository (see
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7.4. Windows Games

Chapter 2, Adding, Removing and Updating Applications [15]).
2. To start Scorched3D, choose Applications->Games->scorched 3d.

7.4. Windows Games

Many games which are available for Windows can be run on Linux through
emulators. Examples of these are Wine and Cedega

1. For information about Wine, see the Ubuntu wiki
[https://wiki.ubuntu.com/Wine].

2. For information about Cedega, see the Ubuntu wiki
[https://wiki.ubuntu.com/Cedega]
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8.1. Basic Compilers

8. Programming

8.1. Basic Compilers

1.

In order to be able to compile programs, some extra packages are ne-
cessary. These can be installed all at once, as follows:

Install the build-essential package (see Chapter 2, Adding, Removing
and Updating Applications [15]).

8.2. Java Runtime Environment (1.5)

! E | The following instructions are only for i386 and amd64 com-

puters. For PowerPC machines, please look at the Ubuntu
Wiki. [https://wiki.ubuntu.com/JavaPPC]

! E | At the time of this writing J2SE is at version 5.0 Update 6.
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This is subject to change. If you do not see this version on
Sun's website, download the newest version displayed.

Go to http:/fjava.sun.com/j2se/1.5.0/download.jsp and click on
“Download JRE 5.0 Update 6”. Do not choose the link with the Net-
Beans bundle.

You must first accept the licence, then click on “Linux self-extracting
file” and Download jre-1_5_0_06-linux-i586.bin to your hard drive.

! E | If you use an amd64 computer, please replace jre-
1_5_0_06-linux-i586.bin with jre-
1_5_0_06-linux-amd64.bin.

Install the java-package package from the Multiverse repository (see
Section 6, “Extra Repositories” [22]).

Make the downloaded file executable. At the command line, change to
the directory where you downloaded the file, and type

chmod +x jre-1_5_0_06-1inux-i586.bin

To install JRE, first build an Ubuntu package. Type
fakeroot make-jpkg jre-1_5_0_06-1inux-i586.bin

Then install the package you have built:
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8.3. Development Tools

sudo dpkg -i sun-j2rel.5_1.5. 0+updat e06_i 386. deb

To get your system to use Sun Java instead of the open-source (but less
functional) GIJ that is installed by default, run:

sudo update-alternatives --config java

and pick the option that has j 2re1. 5- sun in it.

8.3. Development Tools

A list of handy open source development tools for use on Ubuntu such as
Integrated Development Environments (IDEs) and powerful editors.

Anjuta [http://anjuta.sourceforge.net/] is an Integrated Development En-
vironment (IDE) for C and C++.

Bazaar-NG [http://www .bazaar-ng.org/] is a decentralised version con-
trol system used for Ubuntu development.

Bluefish [http://bluefish.openoffice.nl/index.html] is a powerful editor
for experienced web designers and programmers.

Eclipse [http://www.eclipse.org/] is an IDE for Java and other program-
ming languages. It forms the basis for closed-source programs such as
JBuilder.

Eric [http://www.die-offenbachs.de/detlev/eric3.html] is a fully featured
Python and Ruby IDE.
Glade [http://glade.gnome.org/] is a User Interface designer for building
GNOME applications.

IDLE [http://www.python.org/idle/] is the Python IDE built with the Tk-
inter GUI toolkit.

KDevelop [http://www.kdevelop.org/] is a IDE for KDE which supports
many programming languages.

MonoDevelop [http://www.monodevelop.com/Main_Page] is an IDE for
writing mono/.net applications in C# and other languages.

NetBeans [http://www.netbeans.org/index.html] is a Java IDE that fea-
tures support for CVS and a form builder.

8.4. Programming Documentation

Some useful documentation for programming with Ubuntu.
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8.4. Programming Documentation

8.4.1. Dive Into Python

Dive Into Python is a book on learning how to program in the preferred
Ubuntu language, Python. Aimed at programmers with some previous ex-
perience, it comes installed with every Ubuntu installation.

You can read Dive Into Python here
[file:///usr/share/doc/diveintopython/html/toc/index.html].

8.4.2. PyGTK Tutorial

PyGTK Tutorial is a tutorial on developing with the graphical toolkit often
used for developing Ubuntu applications. It assumes that you have know-
ledge of Python but not necessarily GTK.

1. Install the python-gtk2-tutorial package (see Chapter 2, Adding, Re-
moving and Updating Applications [15]).

! E I You will need to use Synaptic Package Manager to install
this package

2. To access the documentation, visit python-gtk-tutorial
[file:///usr/share/doc/python-gtk2-tutorial/html/index.html].

8.4.3. Other Documentation

Devhelp is an application to read and search all of the documentation that
you install.

1. Install the devhelp package (see Chapter 2, Adding, Removing and Up-
dating Applications [15]).
2. Choose: Applications->Programming->Devhelp
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Chapter 4. Configuring
Your System

This chapter contains information on configuring your system.
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1.1. Menu Editing

1. Desktop Tricks

This section details some tips for using and customising Ubuntu's desktop
environment (called GNOME), and the file manager (called Nautilus).

1.1. Menu Editing

Ubuntu comes with the Alacarte Menu Editor, so you can customize your
menus and add entries for applications that don't automatically appear after
they are installed.

To add a new menu entry:

1. Open Alacarte with Applications->Accessories->Alacarte Menu Edit-
or, or by right-clicking on any top-level menu and choosing Edit
Menus.

2. In Alacarte's left-hand pane, choose the submenu the new entry should
appear in.

3. Choose File->New Entry. In the New Entry window, choose a Name,
Comment, Command and Icon. The Command will usually be the
package name, Name is what will appear on the menu, and the Com-
ment will appear in the tooltip that appears near the menu entry. Icons
are added to the / usr/ shar e/ pi xmaps directory by default, or can be
chosen from anywhere in your files.

To change the order of menu entries, use the up and down arrows on the
right-hand side of the Alacarte window.

To stop a menu entry from being displayed, use the checkboxes beside each
entry. This does not erase the menu entry, so you can restore it later in the
same way.

1.2. Start a Program Manually

Sometimes it can be useful to start a program manually, for example when
the program does not have an entry in the menu. This is easy to do with the
Run Applications dialogue.

For an application you intend to use regularly that does not have a menu
entry, it is also very easy to add a menu entry to Ubuntu. (see Section 1.1,
“Menu Editing” [48])
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1.3. Run programs automatically when
GNOME starts

1. Open the Run Applications dialogue by typing: Alt-F2

2.  Enter the name of the program you wish to run, and press Enter.

1.3. Run programs automatically when GNOME
starts

Choose System->Preferences->Sessions .
Click on the Startup Programs tab.

3. Use the Add, Edit, and Delete buttons to manage programs to run at
startup. Some programs will automatically add themselves to this list
when you configure them.

1.4. Login automatically to GNOME when the com-
puter starts

It is possible to login a user automatically when the computer boots. This is
not recommended for most computers, as it is not secure and may allow
other users access to your information

System->Administration->Login Screen Setup

2. Select the Security tab. Check the Enable Automatic Login checkbox
option.

3. Choose the user you wish to be automatically logged in.

1.5. Change Display Mode in Nautilus

Ubuntu's file manager Nautilus provides two modes in which you can inter-
act with your filesystem: Spatial mode and Browser mode.

* In Browser mode, the file manager window represents a browser, which
can display any location. Opening a folder updates the current file man-
ager window to show the contents of the new folder.

* In Spatial mode, the file manager window represents a particular folder.
Opening a folder opens the new window for that folder. Each time you
open a particular folder, you will find its window displayed in the same
place on the screen and the same size as the last time you viewed it (this
the reason for the name).

Browser mode is the default setting on Ubuntu, but you may wish to change

49



1.6. Show hidden files and folders in
Nautilus

this:

bl A

In Nautilus, choose Edit->Preferences.
Click on the Behavior tab.
Unselect the Always open in browser windows check box.

Close and reopen Nautilus.

1.6. Show hidden files and folders in Nautilus

1.

In Nautilus, use the Ctrl-H shortcut keys to toggle hidden files and
folders on and off, or select View->Show Hidden Files.

To permanently show all hidden files and folders, choose Edit-
>Preferences.

Click on the Views tab.
Select the Show hidden and backup files check box.

1.7. Open the Location Bar in Nautilus

The Location Bar is the bar in your file manager in which you can type an
address. Toggle the bar on and off with: Go->Location... You can also use
the Ctrl-L shortcut keys.

1.8. View remote SSH, FTP, and SFTP servers us-

ing Nautilus
1. Make sure the Nautilus Location Bar is open (see Section 1.7, “Open
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the Location Bar in Nautilus” [50]).

In the Location Bar, enter the following:

For SSH, use:

ssh://username@sh. server.com

For FTP, use:

ftp://username@t p. server.com

For SFTP, use:

sftp://username@ftp. server.com



1.9. Change the default "Open with" pro-
gram for a file type

Replace username with your username and replace everything after the
@ symbol with the server's address. You will be prompted for a pass-
word if needed. If there is no username (anonymous) omit the user-
name and the @ symbol.

Alternatively, to specify your password manually, change one of the
above like so:

ftp://username: password@t p. server.com

To access remote servers easily through Nautilus, add a permanent

bookmark to the server by selecting Places->Connect to Server... and
entering the details for the remote server.

1.9. Change the default "Open with" program for a

file type

1.

In Nautilus, right click on the file and choose Properties from the menu
that appears. The Properties dialog opens.
Click on the Open With tab. A list of applications appears.

Select the default application you want for the file type. If the applica-
tion is not on the list, use the Add button to add the application to the
list.

1.10. Open files with administrative privileges from

the file manager

To enable support for opening files with administrative privileges from the
file manager, you need to add a Nautilus script:

‘ 0 Please note that opening files with administrative privileges
constitutes a security risk. Always ensure that you are familiar

with the file that you are opening.

Open a new file to edit in the relevant directory:

gedit $HOVE/ . gnone2/ nautil us-scripts/ Open\ as\ Adm nistrator

Insert the following lines into the new file:

for uri in $NAUTI LUS_SCRI PT_SELECTED URI'S; do
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1.11. Install Extra Fonts

gksudo "gnone-open $uri" &
done

3. Save the edited file (an example
[../sample/nautilus_open_as_administrator])

4. Make the edited file executable:

chnod +x $HOVE/ . gnone2/ nauti |l us-scripts/ Open\ as\ Admi nistrator

5. You can now open files as root by right clicking on the file and select-
ing Scripts->Open as Administrator

1.11. Install Extra Fonts

This section describes how to install extra fonts from the Ubuntu archives.

1. For international fonts, install the following packages from the Uni-
verse repository (see Chapter 2, Adding, Removing and Updating Ap-
plications [15]):

xfonts-intl-arabic
xfonts-intl-asian
xfonts-intl-chinese
xfonts-intl-chinese-big
xfonts-intl-european
xfonts-intl-japanese
xfonts-intl-japanese-big
xfonts-intl-phonetic

2. For Microsoft TrueType core fonts, install the msttcorefonts package
from the Multiverse repository (see Chapter 2, Adding, Removing and
Updating Applications [15]).

3. For Ghostscript fonts, install the gsfonts-x11 package (see Chapter 2,
Adding, Removing and Updating Applications [15]).

4.  After installing any new font, rebuild the font information files by typ-
ing the following at a terminal prompt:

sudo fc-cache -f -v
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1.12. RAR Archiver

If you prefer to download individual fonts by hand, you can install them
simply and easily by opening a file manager, and typing fonts:/// into the
location bar (See Section 1.7, “Open the Location Bar in Nautilus” [50]).
Then you can simply drag the font you downloaded into the group of exist-
ing fonts.

1.12. RAR Archiver

1. Install the rar package from the Multiverse repository (see Chapter 2,
Adding, Removing and Updating Applications [15]).

2. Run:

sudo In -fs /fusr/bin/rar /usr/bin/unrar

3. To open arar file, double click on it.

1.13. Advanced Desktop Applets

gDesklets is a system for bringing mini programs (desklets), such as weath-
er forecasts, news tickers, system information displays, or music player con-
trols, onto your desktop, in a symbiotic relationship of eye candy and use-
fulness.

1. Install the gdesklets and gdesklets-data packages from the Universe re-
pository (see Chapter 2, Adding, Removing and Updating Applications

[15]).
Choose: Applications->Accessories->gDesklets

3. For more information, visit the gDesklets website
[http://www.gdesklets.org/]

1.14. Hide Recent Documents in the Places menu

To hide Recent Documents from the Places menu, open a terminal and run
the command:

chnod 400 ~/.recently-used

To enable it again, run the command:

chnod 600 ~/.recently-used
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1.16. Change my preferred email client to
Mozilla Thunderbird

1.15. Show the Computer, Home, and Trash desktop
icons in GNOME

1. Open the Configuration Editor, by running the program gconf - edi t or
(see Section 1.2, “Start a Program Manually” [48]).

Choose apps->nautilus->desktop.

Tick the box beside computer_icon_visible, home_icon_visible, and
trash_icon_visible. The changes take effect immediately.

1.16. Change my preferred email client to Mozilla
Thunderbird

Choose System->Preferences->Preferred Applications
Click on the Mail Reader tab, and select the Custom option.

In the Command text box, type nozi | | a-t hunder bird %, then close
the dialog.

1.17. Restart GNOME without rebooting the com-
puter
Save and close all open applications.

. Use the Ctrl-Alt-Backspace shortcut keys to restart GNOME.
3. If Ctrl-Alt-Backspace is disabled, type

sudo /etc/init.d/gdmrestart

(See Section 1.18, “Preventing the Ctrl-Alt-Backspace shortcut keys
from restarting X [54]to disable Ctrl-Alt-Backspace.)

1.18. Preventing the Ctrl-Alt-Backspace shortcut
keys from restarting X

1. Make a backup copy of your existing / et ¢/ X11/ xor g. conf file:

sudo cp /etc/ X11/ xorg. conf /etc/X11/ xorg. conf_backup

2. Open/etc/ X11/ xor g. conf for editing:

sudo gedit /etc/X11/xorg. conf
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2. Partitions and Booting

Add the following lines to the end of the file:

Section "ServerFl ags"
Option "Dont Zap" "yes"
EndSecti on

Save the edited file (an example
[../sample/xorg.conf_disablectrlaltbackspacegnome]).

The change will take effect the next time you log in to GNOME. If you
want the change to take effect immediately, restart GNOME manually.
(See Section 1.17, “Restart GNOME without rebooting the computer”

[54])
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2.1. Graphical Partition Editor

2. Partitions and Booting

2.1. Graphical Partition Editor

Gparted is a graphical tool to edit disk partitions.

1.

Install the gparted package (see Chapter 2, Adding, Removing and Up-
dating Applications [15]).

You can run the application with System->Administration ->Gnome
Partition Editor .

2.2. Make partitions available from Ubuntu

Windows and other partitions should be automatically available from any
Ubuntu system. If they are not, you can enable them using the graphical

disks tool.

1.  Open System->Administration->Disks

2. Select the correct hard disk, and click the Partitions tab.
3. Select the relevant partition, and click Enable.

4. To unmount the partition, click Disable.

2.3. Make partitions automatically available

Again, Windows and other partitions should be automatically available
from Ubuntu. If they are not, the following procedure will make them auto-
matically available:

1.
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Read Section 3.7.1, “Check disk space usage and view the partition ta-
ble” [63]

First make a directory where the partition can be made available
("mounted"):

sudo nkdir /medi a/ wi ndows

Next, backup your disk configuration file and open the file in a text ed-
itor with administrative privileges:

sudo cp /etc/fstab /etc/fstab_backup
sudo gedit /etc/fstab



2.4. Run a system command automatic-
ally at startup

4. Append the following line at the end of file:
/ dev/ hdal / medi a/ wi ndows ntfs umask=0222 0 0

! E i Replace /dev/hdal with the correct device name for your
partition.

If your Windows partition uses the FAT32 filesystem, re-
place ntfs with vfat in the above command.

If you have a FAT32 filesystem, it is also safe to allow
read-write access. To do this, change the value of umask
to 0000.

5. Save the edited file (an example [../sample/fstab_automountntfs])

6. The changes will take effect when the computer is restarted.

2.4. Run a system command automatically at startup

Sometimes it can be useful to add a custom command to the startup process
so that your computer executes it on every boot. To do this:

1. Edit the crontab with administrative privileges (see Section 3.3, “Root
And Sudo” [10]):

sudo crontab -e

2. Insert the following line:

@ eboot /hone/ user/ comand

|E i Replace / home/ user / command with the full address to
your command.

3. Save the file and exit.

2.5. Change default Operating System at boot

To change the Operating System which starts by default when booting, it is
necessary to edit the configuration file for booting.
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2.6. Permanently disable/enable boot-up
services

1. Make a backup of your boot configuration file, and open it in a text ed-
itor:

sudo cp /boot/grub/ menu.|st /boot/grub/menu.lst_backup
sudo gedit /boot/grub/nenu.l st

2. Find this line:
default 0

3. Replace with the following line:

default X _sequence

4.  Save the edited file (an example
[../sample/menu.list_changedefaultosgrub])

2.6. Permanently disable/enable boot-up services

This requires administrative privileges (see Section 3.3, “Root And Sudo”

[10).

1. Run Services Settings: System->Administration->Services.

2. Enter your password.

3. Tick/untick the services you want running, then click OK when done.
4

For greater control over the boot-up services, install the bum from the
Universe repository (see Chapter 2, Adding, Removing and Updating
Applications [15]) and run it: System->Administration->Boot-up Man-
ager.
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3.1. Digital Cameras

3. Hardware

3.1. Digital Cameras

Most USB digital cameras will be automatically detected by Ubuntu.
Simply plug in and switch on your USB digital camera, Ubuntu will then
ask you if you would like to import the photos from your camera. Click on
Import, Ubuntu will then show you a preview of your photos. Choose a loc-
ation to save your photos to, then click on Import, Ubuntu will then save
your photos to your hard drive.

If you do not get the auto-import popup with your camera, it might be worth
starting gThumb and trying File->Import Photos.... See Section 6.1,
“gThumb Image Viewer” [40] for more on gThumb.

3.2. 3D Graphic Cards

3.2.1. Introduction to 3D Video Acceleration

Most video hardware should work automatically with Ubuntu. However
with some types of video hardware, 3D acceleration (which is needed by
some games) will not be supported automatically. This section details how
to get this working with some popular video hardware.

The first step is to find out whether 3D acceleration is working.

1.  To do this, enter in a terminal:

gl xinfo | grep rendering

2. If 3D acceleration is working, the following will be displayed:

direct rendering: Yes

3. If not, follow the instructions in the following sections to activate 3D
acceleration.

3.2.2. 3D Nvidia Video Card Driver

No Nvidia Video cards have 3D acceleration enabled automatically with
Ubuntu, because the manufacturer does not release open source drivers.
However, it is possible to activate 3D acceleration. The process depends on
which type of video card you have.
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3.3. Keyboard Layouts

1. If you have an older TNT, TNT2, TNT Ultra, GeForcel or Ge-
Force2 card, install the nvidia-glx-legacy and nvidia-settings pack-
ages from the Restricted repository (see Chapter 2, Adding, Removing
and Updating Applications [15]).

2. Alternatively, if you have a newer card, install the nvidia-glx pack-
age from the Restricted repository (see Chapter 2, Adding, Removing
and Updating Applications [15]).

3. To enable the new driver, run the following command in a terminal:

sudo nvidi a-gl x-config enable

4. You may adjust the settings of the new drivers by running the applica-
tion nvidia-settings (see Section 1.2, “Start a Program Manually”
[48]). If you wish, add a menu entry for this program (see Section 1.1,
“Menu Editing” [48]).

3.2.3. 3D ATI Video Card Driver

Many ATI video cards work well with Ubuntu automatically. To check that
3d acceleration works with your card, see Section 3.2.1, “Introduction to
3D Video Acceleration” [59]. If it does not work, this procedure should ac-
tivate it.

1. Install the xorg-driver-fglrx package from the Restricted repository
(see Chapter 2, Adding, Removing and Updating Applications [15]).

2. You now need to configure the computer to use the new driver so run
this command in a terminal:

sudo dpkg-reconfigure xserver-xorg

3. When the dialogue appears and asks whether to do automatic detection
of your video, pick Yes.

When asked to select a driver, pick fglrx.
5. Follow the remaining instructions as appropriate.

Restart your machine for changes to take effect.

3.3. Keyboard Layouts

This section deals with adding keyboard layouts to your system, and switch-
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3.4. Wireless Cards

ing between them easily.

3.3.1. Add a Layout

To add a keyboard layout to your system:

Go to System->Preferences->Keyboard
Choose Layouts

Press Add... to add further keyboard layouts. It is simpler to have two
layouts; the maximum is currently four.

4.  Close the dialogue.

3.3.2. Switch Keyboard Layouts
To switch between keyboard layouts, you can set a key combination:

1. Go to System->Preferences->Keyboard

2. To configure your layouts, choose Layout Options
3. Expand the Group Shift/Lock behaviour option
4

Choose the key combination that enables you to switch between key-
board layouts. The default is by pressing both Alt keys at the same
time. A common alternative is to use Alt-Shift.

Close the dialogue

o v

You can now use your key combination to switch between keyboard
layouts.

3.3.3. Keyboard Indicator

Alternatively add the Keyboard Indicator applet to your panel:

1. Right-click on an empty space on the panel where you want to add the
applet
Click Add to Panel...

3. Choose Keyboard Indicator from the Ultilities section

You can now right-click on the Keyboard Indicator to manage your
keyboard layouts.

3.4. Wireless Cards
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3.5. Modems

Many wireless cards are automatically detected by Ubuntu during installa-
tion. A complete listing of wireless cards which work with Ubuntu can be
found on Ubuntu Wiki
[https://wiki.ubuntu.com/HardwareSupportComponentsWirelessNetworkCa
rds]. Please add your wireless card to the list if it works with Ubuntu.

Some cards may not work automatically with Ubuntu. If this is the case,
please look at the Wireless Troubleshooting Guide
[https://wiki.ubuntu.com/WirelessTroubleshootingGuide] on the Ubuntu
Wiki which is an excellent resource for troubleshooting wireless cards.

All information regarding wireless networking on Ubuntu is collected at
Wireless Networking Central [https://wiki.ubuntu.com/WifiDocs] on the
Ubuntu Wiki.

3.5. Modems

3.5.1. Winmodems

Most winmodems are not supported by Ubuntu, but drivers can be found
that will enable the use of such modems. First you need to identify what
chipset your winmodem is using:

wget -c http://1innmodens. technion.ac.il/packages/scanMbdem gz
gunzi p -c scanMbdem gz > scanMbdem

chnod +x scanModem

sudo ./scanMbdem

gedit Modeni ModenDat a. t xt

Read this file, it should list what modem chipset you have. Once you are
aware of the chipset you have, see http://www.linmodems.org/ and follow
the directions for your modem. More infomation can be found at SettingUp-
Modems [https://wiki.ubuntu.com/SettingUpModems] on the Ubuntu Wiki.

3.5.2. ADSL Modems

All PPPOE and router-style ADSL modems are supported by Ubuntu (that
use ethernet for the connections), and some USB ADSL modems are sup-
ported too. For router-style ADSL modems, just connect it up, configure the
modem as per your ISPs instructions and configure networking in Ubuntu.
For information on PPPOE modems see this guide
[https://wiki.ubuntu.com/ADSLPPPoE] on the Ubuntu wiki.
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3.7. Other Tips

3.6. Printers

Some printers will be automatically detected by Ubuntu; for those that are
not, choose System->Administration->Printing then choose Printer->Add
Printer and run the Printer Install Wizard.

There are some printers that need further setup. Search the databases at
LinuxPrinting.org [http://www linuxprinting.org/] or check the Ubuntu
Wiki's Printer page
[https://wiki.ubuntu.com/HardwareSupportComponentsPrinters] for pos-
sible information on your printer.

3.7. Other Tips

3.7.1. Check disk space usage and view the partition table

1. Launch System->Administration->Disks
Select the Harddrive, then the Partitions tab

3. Each partition will be listed under Partition List, with disk space and
mount point.

3.7.2. List devices

1. To list mounted devices, run the following command in a terminal:

nount

The listing shows the device (such as a hard disk partition), the mount
point (where you access the files), the filesystem type and the mount
options.

This example shows the hda2 hard disk partition mounted as '/', with
the filesystem type ext3. The partition is mounted with two options,
one to allow the device to be read from and wrote to and the other to
remount the device as read only in the event of any errors.

/ dev/ hda2 on / type ext3 (rw, errors=renmount-ro)

2. To list PCI devices:

| spci

3. To list USB devices:
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4. Networking

| susb

3.7.3. Mount/unmount CD/DVD-ROMs manually, and show all hid-

den and associated files/folders

64

Assuming that / nedi a/ cdron®/ is the location of CD/DVD-ROM
To mount CD/DVD-ROM:

sudo nount /nmedi a/ cdronD/ -o unhide

To unmount CD/DVD-ROM:

sudo unmpunt /nedi a/ cdr on®/



4.1. Change the Computer Name

4. Networking

4.1. Change the Computer Name

System->Administration->Networking

2. Select the General tab. Enter the name of the computer in the Host-
name field.

3. Click OK, close all open applications and reboot.

4.2. Networking Utilities

4.2.1. Firestarter Firewall

A firewall protects a computer system from unauthorized access. It is not
normally necessary to install a firewall on an Ubuntu system, because ac-
cess to the system is closed by default. However, if you run any services
which you allow other computers to access (for example, the Apache web
server), it is advisable to install a firewall. Firestarter is a program which al-
lows you to control a firewall through a graphical interface.

1. Install the Firestarter package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. After it is installed, run Applications->System Tools->Firestarter to
configure your firewall. The firewall will now start in the background
when your computer starts.

4.2.2. Graphical Network Monitor

Etherape displays network activity among different hosts using circles of
varying size.

1. Install the etherape package from the Universe repository (see
Chapter 2, Adding, Removing and Updating Applications [15]).

2. Choose: Applications->Internet->Etherape

4.2.3. Network Traffic Analyzer

Ethereal is a network traffic analyzer/sniffer that captures packets off the
network in real time and displays the contents of them.

1. Install the ethereal package from the Universe repository (see
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4.2. Networking Utilities

Chapter 2, Adding, Removing and Updating Applications [15]).
2. Choose: Applications->Internet->Ethereal
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Chapter 5. Getting More
Help

There are a number of places from which you can obtain help with your
Ubuntu desktop system, these include:

The Ubuntu Documentation Website [http://help.ubuntu.com] - this con-
tains this guide, and other guides produced by the Ubuntu Documenta-
tion Team for Ubuntu and Kubuntu.

The Ubuntu Wiki [https://wiki.ubuntu.com/UserDocumentation] - this
contains many guides contributed by the community.

Web Forums [http://www.ubuntu.com/community/forums] - here you
can ask questions on a forum and receive answers from the forum com-
munity.

Mailing Lists [http://lists.ubuntu.com] - here you can ask questions by
email, and receive answers from the mailing list community.

IRC chat: irc.freenode.net channel #ubuntu - chat in realtime with the
irc community. You will need an irc client to connect. Ubuntu comes
with a messenger client, open Applications->Internet->Gaim Internet
Messenger .

For more information, visit the How to Get Help
[https://wiki.ubuntu.com/HowToGetHelp] wiki page.
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Appendix A. Creative
Commons by
Attribution-ShareAlike 2.0

CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND
DOES NOT PROVIDE LEGAL SERVICES. DISTRIBUTION OF THIS
LICENSE DOES NOT CREATE AN ATTORNEY-CLIENT RELATION-
SHIP. CREATIVE COMMONS PROVIDES THIS INFORMATION ON
AN "AS-IS" BASIS. CREATIVE COMMONS MAKES NO WAR-
RANTIES REGARDING THE INFORMATION PROVIDED, AND DIS-
CLAIMS LIABILITY FOR DAMAGES RESULTING FROM ITS USE.

License

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE
TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL"
OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/
OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER
THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT
LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE,
YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS
LICENSE. THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED
HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH
TERMS AND CONDITIONS.

1. Definitions.

a. "Collective Work'' means a work, such as a periodical issue, an-
thology or encyclopedia, in which the Work in its entirety in un-
modified form, along with a number of other contributions, con-
stituting separate and independent works in themselves, are as-
sembled into a collective whole. A work that constitutes a Col-
lective Work will not be considered a Derivative Work (as
defined below) for the purposes of this License.

b. "Derivative Work'' means a work based upon the Work or upon
the Work and other pre-existing works, such as a translation, mu-
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sical arrangement, dramatization, fictionalization, motion picture
version, sound recording, art reproduction, abridgment, condensa-
tion, or any other form in which the Work may be recast, trans-
formed, or adapted, except that a work that constitutes a Collect-
ive Work will not be considered a Derivative Work for the pur-
pose of this License. For the avoidance of doubt, where the Work
is a musical composition or sound recording, the synchronization
of the Work in timed-relation with a moving image ("synching")
will be considered a Derivative Work for the purpose of this Li-
cense.

""Licensor'' means the individual or entity that offers the Work
under the terms of this License.

"Original Author'' means the individual or entity who created
the Work.

"Work"' means the copyrightable work of authorship offered un-
der the terms of this License.

"You'" means an individual or entity exercising rights under this
License who has not previously violated the terms of this License
with respect to the Work, or who has received express permission
from the Licensor to exercise rights under this License despite a
previous violation.

""License Elements'' means the following high-level license at-
tributes as selected by Licensor and indicated in the title of this
License: Attribution, ShareAlike.

Fair Use Rights. Nothing in this license is intended to reduce, limit, or
restrict any rights arising from fair use, first sale or other limitations on
the exclusive rights of the copyright owner under copyright law or oth-
er applicable laws.

License Grant. Subject to the terms and conditions of this License, Li-
censor hereby grants You a worldwide, royalty-free, non-exclusive,
perpetual (for the duration of the applicable copyright) license to exer-
cise the rights in the Work as stated below:

a.

to reproduce the Work, to incorporate the Work into one or more
Collective Works, and to reproduce the Work as incorporated in
the Collective Works;

to create and reproduce Derivative Works;

to distribute copies or phonorecords of, display publicly, perform
publicly, and perform publicly by means of a digital audio trans-
mission the Work including as incorporated in Collective Works;



to distribute copies or phonorecords of, display publicly, perform
publicly, and perform publicly by means of a digital audio trans-
mission Derivative Works.

For the avoidance of doubt, where the work is a musical composi-

tion:

i.  '"Performance Royalties Under Blanket Licenses.' Li-
censor waives the exclusive right to collect, whether indi-
vidually or via a performance rights society (e.g. ASCAP,
BMI, SESAC), royalties for the public performance or public
digital performance (e.g. webcast) of the Work.

ii. ""Mechanical Rights and Statutory Royalties." Licensor
waives the exclusive right to collect, whether individually or
via a music rights society or designated agent (e.g. Harry
Fox Agency), royalties for any phonorecord You create from
the Work ("cover version") and distribute, subject to the
compulsory license created by 17 USC Section 115 of the
US Copyright Act (or the equivalent in other jurisdictions).

""Webcasting Rights and Statutory Royalties.' For the avoid-
ance of doubt, where the Work is a sound recording, Licensor
waives the exclusive right to collect, whether individually or via a
performance-rights society (e.g. SoundExchange), royalties for
the public digital performance (e.g. webcast) of the Work, subject
to the compulsory license created by 17 USC Section 114 of the
US Copyright Act (or the equivalent in other jurisdictions).

The above rights may be exercised in all media and formats whether
now known or hereafter devised. The above rights include the right to
make such modifications as are technically necessary to exercise the
rights in other media and formats. All rights not expressly granted by
Licensor are hereby reserved.

Restrictions. The license granted in Section 3 above is expressly made
subject to and limited by the following restrictions:

a.

You may distribute, publicly display, publicly perform, or pub-
licly digitally perform the Work only under the terms of this Li-
cense, and You must include a copy of, or the Uniform Resource
Identifier for, this License with every copy or phonorecord of the
Work You distribute, publicly display, publicly perform, or pub-
licly digitally perform. You may not offer or impose any terms on
the Work that alter or restrict the terms of this License or the re-
cipients' exercise of the rights granted hereunder. You may not
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sublicense the Work. You must keep intact all notices that refer to
this License and to the disclaimer of warranties. You may not dis-
tribute, publicly display, publicly perform, or publicly digitally
perform the Work with any technological measures that control
access or use of the Work in a manner inconsistent with the terms
of this License Agreement. The above applies to the Work as in-
corporated in a Collective Work, but this does not require the Col-
lective Work apart from the Work itself to be made subject to the
terms of this License. If You create a Collective Work, upon no-
tice from any Licensor You must, to the extent practicable, re-
move from the Collective Work any reference to such Licensor or
the Original Author, as requested. If You create a Derivative
Work, upon notice from any Licensor You must, to the extent
practicable, remove from the Derivative Work any reference to
such Licensor or the Original Author, as requested.

You may distribute, publicly display, publicly perform, or pub-
licly digitally perform a Derivative Work only under the terms of
this License, a later version of this License with the same License
Elements as this License, or a Creative Commons iCommons li-
cense that contains the same License Elements as this License
(e.g. Attribution-ShareAlike 2.0 Japan). You must include a copy
of, or the Uniform Resource Identifier for, this License or other li-
cense specified in the previous sentence with every copy or
phonorecord of each Derivative Work You distribute, publicly
display, publicly perform, or publicly digitally perform. You may
not offer or impose any terms on the Derivative Works that alter
or restrict the terms of this License or the recipients' exercise of
the rights granted hereunder, and You must keep intact all notices
that refer to this License and to the disclaimer of warranties. You
may not distribute, publicly display, publicly perform, or publicly
digitally perform the Derivative Work with any technological
measures that control access or use of the Work in a manner in-
consistent with the terms of this License Agreement. The above
applies to the Derivative Work as incorporated in a Collective
Work, but this does not require the Collective Work apart from
the Derivative Work itself to be made subject to the terms of this
License.

If you distribute, publicly display, publicly perform, or publicly
digitally perform the Work or any Derivative Works or Collective
Works, You must keep intact all copyright notices for the Work
and give the Original Author credit reasonable to the medium or



means You are utilizing by conveying the name (or pseudonym if
applicable) of the Original Author if supplied; the title of the
Work if supplied; to the extent reasonably practicable, the Uni-
form Resource Identifier, if any, that Licensor specifies to be as-
sociated with the Work, unless such URI does not refer to the
copyright notice or licensing information for the Work; and in the
case of a Derivative Work, a credit identifying the use of the
Work in the Derivative Work (e.g., "French translation of the
Work by Original Author," or "Screenplay based on original
Work by Original Author"). Such credit may be implemented in
any reasonable manner; provided, however, that in the case of a
Derivative Work or Collective Work, at a minimum such credit
will appear where any other comparable authorship credit appears
and in a manner at least as prominent as such other comparable
authorship credit.

Representations, Warranties and Disclaimer

UNLESS OTHERWISE AGREED TO BY THE PARTIES IN WRIT-
ING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO
REPRESENTATIONS OR WARRANTIES OF ANY KIND CON-
CERNING THE MATERIALS, EXPRESS, IMPLIED, STATUTORY
OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WAR-
RANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A
PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE AB-
SENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR
THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT
DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE
EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLU-
SION MAY NOT APPLY TO YOU.

Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED
BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LI-
ABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL,
INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY
DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF
THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.

Termination

a. This License and the rights granted hereunder will terminate auto-
matically upon any breach by You of the terms of this License.
Individuals or entities who have received Derivative Works or
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Collective Works from You under this License, however, will not
have their licenses terminated provided such individuals or entit-
ies remain in full compliance with those licenses. Sections 1, 2, 5,
6, 7, and 8 will survive any termination of this License.

Subject to the above terms and conditions, the license granted
here is perpetual (for the duration of the applicable copyright in
the Work). Notwithstanding the above, Licensor reserves the right
to release the Work under different license terms or to stop dis-
tributing the Work at any time; provided, however that any such
election will not serve to withdraw this License (or any other li-
cense that has been, or is required to be, granted under the terms
of this License), and this License will continue in full force and
effect unless terminated as stated above.

Miscellaneous

a.

Each time You distribute or publicly digitally perform the Work
or a Collective Work, the Licensor offers to the recipient a license
to the Work on the same terms and conditions as the license gran-
ted to You under this License.

Each time You distribute or publicly digitally perform a Derivat-
ive Work, Licensor offers to the recipient a license to the original
Work on the same terms and conditions as the license granted to
You under this License.

If any provision of this License is invalid or unenforceable under
applicable law, it shall not affect the validity or enforceability of
the remainder of the terms of this License, and without further ac-
tion by the parties to this agreement, such provision shall be re-
formed to the minimum extent necessary to make such provision
valid and enforceable.

No term or provision of this License shall be deemed waived and
no breach consented to unless such waiver or consent shall be in
writing and signed by the party to be charged with such waiver or
consent.

This License constitutes the entire agreement between the parties
with respect to the Work licensed here. There are no understand-
ings, agreements or representations with respect to the Work not
specified here. Licensor shall not be bound by any additional pro-
visions that may appear in any communication from You. This Li-
cense may not be modified without the mutual written agreement
of the Licensor and You.



Creative Commons is not a party to this License, and makes no warranty
whatsoever in connection with the Work. Creative Commons will not be li-
able to You or any party on any legal theory for any damages whatsoever,
including without limitation any general, special, incidental or consequen-
tial damages arising in connection to this license. Notwithstanding the fore-
going two (2) sentences, if Creative Commons has expressly identified itself
as the Licensor hereunder, it shall have all rights and obligations of Li-
censor.

Except for the limited purpose of indicating to the public that the Work is li-
censed under the CCPL, neither party will use the trademark "Creative
Commons" or any related trademark or logo of Creative Commons without
the prior written consent of Creative Commons. Any permitted use will be
in compliance with Creative Commons' then-current trademark usage
guidelines, as may be published on its website or otherwise made available
upon request from time to time.

Creative Commons may be contacted at hitp://creativecommons.org/.
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Appendix B. GNU Free
Documentation License

Version 1.2, November 2002
Copyright © 2000,2001,2002 Free Software Foundation, Inc.

Free Software Foundation, Inc.
51 Franklin St, Fifth Floor,
Boston,

MA

02110-1301

USA

Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed.
Version 1.2, November 2002

PREAMBLE

The purpose of this License is to make a manual, textbook, or other func-
tional and useful document "free" in the sense of freedom: to assure every-
one the effective freedom to copy and redistribute it, with or without modi-
fying it, either commercially or noncommercially. Secondarily, this License
preserves for the author and publisher a way to get credit for their work,
while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of
the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for
free software.

We have designed this License in order to use it for manuals for free soft-
ware, because free software needs free documentation: a free program
should come with manuals providing the same freedoms that the software
does. But this License is not limited to software manuals; it can be used for
any textual work, regardless of subject matter or whether it is published as a
printed book. We recommend this License principally for works whose pur-
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pose is instruction or reference.
APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that con-
tains a notice placed by the copyright holder saying it can be distributed un-
der the terms of this License. Such a notice grants a world-wide, royalty-
free license, unlimited in duration, to use that work under the conditions
stated herein. The "Document", below, refers to any such manual or work.
Any member of the public is a licensee, and is addressed as "you". You ac-
cept the license if you copy, modify or distribute the work in a way requir-
ing permission under copyright law.

A "Modified Version" of the Document means any work containing the
Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the
Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document's overall subject (or to related
matters) and contains nothing that could fall directly within that overall sub-
ject. (Thus, if the Document is in part a textbook of mathematics, a Second-
ary Section may not explain any mathematics.) The relationship could be a
matter of historical connection with the subject or with related matters, or of
legal, commercial, philosophical, ethical or political position regarding
them.

The "Invariant Sections" are certain Secondary Sections whose titles are
designated, as being those of Invariant Sections, in the notice that says that
the Document is released under this License. If a section does not fit the
above definition of Secondary then it is not allowed to be designated as In-
variant. The Document may contain zero Invariant Sections. If the Docu-
ment does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-
Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words,
and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy,
represented in a format whose specification is available to the general pub-
lic, that is suitable for revising the document straightforwardly with generic
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text editors or (for images composed of pixels) generic paint programs or
(for drawings) some widely available drawing editor, and that is suitable for
input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transpar-
ent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent.
An image format is not Transparent if used for any substantial amount of
text. A copy that is not "Transparent"” is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII
without markup, Texinfo input format, LaTeX input format, SGML or
XML using a publicly available DTD, and standard-conforming simple
HTML, PostScript or PDF designed for human modification. Examples of
transparent image formats include PNG, XCF and JPG. Opaque formats in-
clude proprietary formats that can be read and edited only by proprietary
word processors, SGML or XML for which the DTD and/or processing
tools are not generally available, and the machine-generated HTML, Post-
Script or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such
following pages as are needed to hold, legibly, the material this License re-
quires to appear in the title page. For works in formats which do not have
any title page as such, "Title Page" means the text near the most prominent
appearance of the work's title, preceding the beginning of the body of the
text.

A section "Entitled XYZ" means a named subunit of the Document whose
title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific
section name mentioned below, such as "Acknowledgements", "Dedica-
tions", "Endorsements", or "History".) To "Preserve the Title" of such a sec-
tion when you modify the Document means that it remains a section "En-
titled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which
states that this License applies to the Document. These Warranty Disclaim-
ers are considered to be included by reference in this License, but only as
regards disclaiming warranties: any other implication that these Warranty
Disclaimers may have is void and has no effect on the meaning of this Li-
cense.

VERBATIM COPYING
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You may copy and distribute the Document in any medium, either commer-
cially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are re-
produced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or
control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you dis-
tribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you
may publicly display copies.

COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have prin-
ted covers) of the Document, numbering more than 100, and the Docu-
ment's license notice requires Cover Texts, you must enclose the copies in
covers that carry, clearly and legibly, all these Cover Texts: Front-Cover
Texts on the front cover, and Back-Cover Texts on the back cover. Both
covers must also clearly and legibly identify you as the publisher of these
copies. The front cover must present the full title with all words of the title
equally prominent and visible. You may add other material on the covers in
addition. Copying with changes limited to the covers, as long as they pre-
serve the title of the Document and satisfy these conditions, can be treated
as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you
should put the first ones listed (as many as fit reasonably) on the actual cov-
er, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering
more than 100, you must either include a machine-readable Transparent
copy along with each Opaque copy, or state in or with each Opaque copy a
computer-network location from which the general network-using public
has access to download using public-standard network protocols a complete
Transparent copy of the Document, free of added material. If you use the
latter option, you must take reasonably prudent steps, when you begin dis-
tribution of Opaque copies in quantity, to ensure that this Transparent copy
will remain thus accessible at the stated location until at least one year after
the last time you distribute an Opaque copy (directly or through your agents
or retailers) of that edition to the public.
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It is requested, but not required, that you contact the authors of the Docu-
ment well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under
the conditions of sections 2 and 3 above, provided that you release the Mod-
ified Version under precisely this License, with the Modified Version filling
the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must
do these things in the Modified Version:

GNU FDL Modification Conditions

A. Use in the Title Page (and on the covers, if any) a title distinct from
that of the Document, and from those of previous versions (which
should, if there were any, be listed in the History section of the Docu-
ment). You may use the same title as a previous version if the original
publisher of that version gives permission.

B. List on the Title Page, as authors, one or more persons or entities re-
sponsible for authorship of the modifications in the Modified Version,
together with at least five of the principal authors of the Document (all
of its principal authors, if it has fewer than five), unless they release
you from this requirement.

C. State on the Title page the name of the publisher of the Modified Ver-
sion, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to
the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giv-
ing the public permission to use the Modified Version under the terms
of this License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and re-
quired Cover Texts given in the Document's license notice.

H. Include an unaltered copy of this License.

leml

Preserve the section Entitled "History", Preserve its Title, and add to it
an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section En-
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titled "History" in the Document, create one stating the title, year, au-
thors, and publisher of the Document as given on its Title Page, then
add an item describing the Modified Version as stated in the previous
sentence.

J. Preserve the network location, if any, given in the Document for public
access to a Transparent copy of the Document, and likewise the net-
work locations given in the Document for previous versions it was
based on. These may be placed in the "History" section. You may omit
a network location for a work that was published at least four years be-
fore the Document itself, or if the original publisher of the version it
refers to gives permission.

K. For any section Entitled "Acknowledgements" or "Dedications", Pre-
serve the Title of the section, and preserve in the section all the sub-
stance and tone of each of the contributor acknowledgements and/or
dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their
text and in their titles. Section numbers or the equivalent are not con-
sidered part of the section titles.

M. Delete any section Entitled "Endorsements”. Such a section may not be
included in the Modified Version.

N. Do not retitle any existing section to be Entitled "Endorsements" or to
conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices
that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections
as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version's license notice. These titles must be distinct from any
other section titles.

You may add a section Entitled "Endorsements", provided it contains noth-
ing but endorsements of your Modified Version by various parties--for ex-
ample, statements of peer review or that the text has been approved by an
organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a
passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover

Text and one of Back-Cover Text may be added by (or through arrange-
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ments made by) any one entity. If the Document already includes a cover
text for the same cover, previously added by you or by arrangement made
by the same entity you are acting on behalf of, you may not add another; but
you may replace the old one, on explicit permission from the previous pub-
lisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give
permission to use their names for publicity for or to assert or imply endorse-
ment of any Modified Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this
License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of
all of the original documents, unmodified, and list them all as Invariant Sec-
tions of your combined work in its license notice, and that you preserve all
their Warranty Disclaimers.

The combined work need only contain one copy of this License, and mul-
tiple identical Invariant Sections may be replaced with a single copy. If
there are multiple Invariant Sections with the same name but different con-
tents, make the title of each such section unique by adding at the end of it,
in parentheses, the name of the original author or publisher of that section if
known, or else a unique number. Make the same adjustment to the section
titles in the list of Invariant Sections in the license notice of the combined
work.

In the combination, you must combine any sections Entitled "History" in the
various original documents, forming one section Entitled "History"; like-
wise combine any sections Entitled "Acknowledgements", and any sections
Entitled "Dedications". You must delete all sections Entitled "Endorse-
ments".

COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other docu-
ments released under this License, and replace the individual copies of this
License in the various documents with a single copy that is included in the
collection, provided that you follow the rules of this License for verbatim
copying of each of the documents in all other respects.
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You may extract a single document from such a collection, and distribute it
individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects re-
garding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and in-
dependent documents or works, in or on a volume of a storage or distribu-
tion medium, is called an "aggregate" if the copyright resulting from the
compilation is not used to limit the legal rights of the compilation's users
beyond what the individual works permit. When the Document is included
in an aggregate, this License does not apply to the other works in the ag-
gregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of
the Document, then if the Document is less than one half of the entire ag-
gregate, the Document's Cover Texts may be placed on covers that bracket
the Document within the aggregate, or the electronic equivalent of covers if
the Document is in electronic form. Otherwise they must appear on printed
covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute
translations of the Document under the terms of section 4. Replacing Invari-
ant Sections with translations requires special permission from their copy-
right holders, but you may include translations of some or all Invariant Sec-
tions in addition to the original versions of these Invariant Sections. You
may include a translation of this License, and all the license notices in the
Document, and any Warranty Disclaimers, provided that you also include
the original English version of this License and the original versions of
those notices and disclaimers. In case of a disagreement between the trans-
lation and the original version of this License or a notice or disclaimer, the
original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedica-
tions", or "History", the requirement (section 4) to Preserve its Title (section
1) will typically require changing the actual title.

TERMINATION
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You may not copy, modify, sublicense, or distribute the Document except
as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatic-
ally terminate your rights under this License. However, parties who have re-
ceived copies, or rights, from you under this License will not have their li-
censes terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the
GNU Free Documentation License from time to time. Such new versions
will be similar in spirit to the present version, but may differ in detail to ad-
dress new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the
Document specifies that a particular numbered version of this License "or
any later version" applies to it, you have the option of following the terms
and conditions either of that specified version or of any later version that
has been published (not as a draft) by the Free Software Foundation. If the
Document does not specify a version number of this License, you may
choose any version ever published (not as a draft) by the Free Software
Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the
License in the document and put the following copyright and license notices
just after the title page:

Sample Invariant Sections list

Copyright (c) YEAR YOUR NAME. Permission is gran-
ted to copy, distribute and/or modify this document under
the terms of the GNU Free Documentation License, Ver-
sion 1.2 or any later version published by the Free Soft-
ware Foundation; with no Invariant Sections, no Front-
Cover Texts, and no Back-Cover Texts. A copy of the li-
cense is included in the section entitled "GNU Free Docu-
mentation License".
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If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts,
replace the "with...Texts." line with this:

Sample Invariant Sections list

with the Invariant Sections being LIST THEIR TITLES,
with the Front-Cover Texts being LIST, and with the
Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combina-
tion of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recom-
mend releasing these examples in parallel under your choice of free soft-
ware license, such as the GNU General Public License, to permit their use
in free software.
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