Bug 106469

Summary: Failed to build xwayland (1.20)
Product: xorg Reporter: Marco <mpiazza>
Component: Server/GeneralAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: git   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xwayland patch to fix build none

Description Marco 2018-05-10 21:33:50 UTC
Created attachment 139481 [details] [review]
Xwayland patch to fix build

Buiding just released xorg 1.20, I found it does not compile from source.

The error is:
../../../hw/xwayland/xwayland-glamor.c: In function ‘xwl_glamor_egl_device_has_egl_extensions’:
../../../hw/xwayland/xwayland-glamor.c:117:42: error: ‘EGL_PLATFORM_DEVICE_EXT’ undeclared (first use in this function); did you mean ‘EGL_PLATFORM_X11_EXT’?
     egl_display = glamor_egl_get_display(EGL_PLATFORM_DEVICE_EXT, device);
                                          ^~~~~~~~~~~~~~~~~~~~~~~
                                          EGL_PLATFORM_X11_EXT
../../../hw/xwayland/xwayland-glamor.c:117:42: note: each undeclared identifier is reported only once for each function it appears in
make: *** [Xwayland-xwayland-glamor.o] Error 1



These are the option I use to build xserver:
../src/configure -v --with-pkgversion='Debian 7.3.0-16' --with-bugurl=file:///usr/share/doc/gcc-7/README.Bugs --enable-languages=c,ad
a,c++,go,brig,d,fortran,objc,obj-c++ --prefix=/usr --with-gcc-major-version-only --with-as=/usr/bin/x86_64-linux-gnu-as --with-ld=/usr/bin/x86_64-linu
x-gnu-ld --program-suffix=-7 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gett
ext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes -
-with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-
zlib --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m
64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none --without-cuda-driver --enable-checking=release --build=x86_64-linux
-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu


You can find attached patch I used to make it build.

Marco
Comment 1 GitLab Migration User 2018-12-13 22:39:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/536.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.