Bug 105715

Summary: Cant open lib error
Product: XQuartz Reporter: Dominique <dgutierrez>
Component: New BugsAssignee: Jeremy Huddleston Sequoia <jeremyhu>
Status: RESOLVED NOTABUG QA Contact: Jeremy Huddleston Sequoia <jeremyhu>
Severity: normal    
Priority: medium    
Version: 2.7.11 (xserver-1.18.4)   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Dominique 2018-03-23 15:22:34 UTC
Hello,

I get these messages when trying to open from the terminal

 
DG$ open -a XQuartz
LSOpenURLsWithRole() failed for the application /Applications/Utilities/XQuartz.app with error -10810.

DG$ DISPLAY=:0 xterm
dyld: Library not loaded: /opt/X11/lib/libfreetype.6.dylib
  Referenced from: /opt/X11/lib/libXft.2.dylib
  Reason: Incompatible library version: libXft.2.dylib requires version 19.0.0 or later, but libfreetype.6.dylib provides version 18.0.0
Abort trap: 6

I have version 10.13.3 mac. Xquartz was working fine before but now I cannot open it or any programs that use it. I have tried reinstalling x quartz 2.7.7 and 2.7.8 and 2.7.11 restarting everytime but it does not open 
I get this message when I try and open xquartz:
The application “XQuartz” can’t be opened.

Best,
Dominique
Comment 1 Jeremy Huddleston Sequoia 2018-03-24 07:29:47 UTC
Don't set DYLD_LIBRARY_PATH.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.