Bug 106722

Summary: [i915] Linux machine hanged after several reboots
Product: DRI Reporter: ccalderon
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED DUPLICATE QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: intel-gfx-bugs
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description ccalderon 2018-05-30 11:19:23 UTC
Tested with Ubuntu (4.16, 4.18) and Ubilinux3 and 4 (Debian) distros and multiple kernel versions (from 4.4 to 4.15) on UP board machines.

In all cases, the issue is the same. After several software reboots (in most of the cases less than 100 reboots) the UP machine hangs and is blocked. So, it is impossible to use but disconnecting the power wire.

Using an FTDI connector to use the UART transmitter, some ERROR messages were found in the exact moment where machine hangs.
All the ERROR are on line with the i915 module of DRM used in the GPU.

After disabling all modules for i915 in the kernel configuration file and rebuild the full kernel and test again, with more than 1000 reboots, the UP machine continues working properly. That test was used in Ubuntu and Ubilinux (Debian).
Comment 1 ccalderon 2018-05-30 11:25:45 UTC

*** This bug has been marked as a duplicate of bug 106721 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.