Bug 107853

Summary: [CI][DRMTIP] igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c - fail - Failed assertion: ret != 0
Product: DRI Reporter: Martin Peres <martin.peres>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: RESOLVED WORKSFORME QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: low CC: intel-gfx-bugs
Version: XOrg git   
Hardware: Other   
OS: All   
Whiteboard: ReadyForDev
i915 platform: IVB i915 features: display/Other

Description Martin Peres 2018-09-07 08:14:24 UTC
It usually skipped (Not enough connected outputs), but it failed on the latest drmtip run:

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_105/fi-ivb-3520m/igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c.html

(kms_pipe_b_c_ivb:2742) CRITICAL: Test assertion failure function test_dpms, file ../tests/kms_pipe_b_c_ivb.c:158:
(kms_pipe_b_c_ivb:2742) CRITICAL: Failed assertion: ret != 0
(kms_pipe_b_c_ivb:2742) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_pipe_b_c_ivb:2742) CRITICAL: error: 0 == 0
Subtest pipe-B-dpms-off-modeset-pipe-C failed.


For reference, here is the skip: https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_102/fi-ivb-3520m/igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c.html
Comment 1 CI Bug Log 2019-04-10 13:31:45 UTC
A CI Bug Log filter associated to this bug has been updated:

{- IVBm: igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c - fail - Failed assertion: ret != 0, Last errno: 25, Inappropriate ioctl for device -}
{+ IVBm: igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c - fail - Failed assertion: ret != 0 +}

 No new failures caught with the new filter
Comment 2 CI Bug Log 2019-04-10 13:31:55 UTC
A CI Bug Log filter associated to this bug has been updated:

{- IVBm: igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c - fail - Failed assertion: ret != 0 -}
{+ IVBm: igt@kms_pipe_b_c_ivb@pipe-b-dpms-off-modeset-pipe-c - fail - Failed assertion: ret != 0 +}

 No new failures caught with the new filter
Comment 3 Arek Hiler 2019-08-15 12:54:25 UTC
IVB has limited number of FDI lanes and it's impossible to use big modes on pipe B and C at the same time.

kms_pipe_b_c_ivb@pipe_b-dpms_off-modeset-pipe-c checks that we can use the extra FDI lane when the other output that would be otherwise using it is DPMS OFFed.

This happened 4 times total, last time over half a year ago, but cannot be closed yet (we need another half a year to be somewhat sure it's gone).

Since its so rare and exercises unlikely scenario for users (2 external monitors, one has to be DPMS OFFed and second one has to be set *afterwards* to a rather demanding mode) the impact is rather negligible and I am setting the priority to low.
Comment 4 Lakshmi 2019-11-29 13:28:44 UTC
Reproduction rate of this issue is once in 3 drmtip runs. Last seen drmtip_204 (10 months old) and current drmtip run is 408.

Closing this issue as WORKSFORME.
Comment 5 CI Bug Log 2019-11-29 13:28:49 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.