Bug 108783

Summary: Nouveau crash in X server / display system with PAGE_NOT_PRESENT/NULL_DMAOBJ running Minecraft Feed The Beast Continuum
Product: xorg Reporter: Petter Reinholdtsen <pere>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
dmesg output from /var/log/kern.log from the crash none

Description Petter Reinholdtsen 2018-11-19 07:30:11 UTC
Created attachment 142513 [details]
dmesg output from /var/log/kern.log from the crash

When running Minecraft Feed The Beast on a machine with the NVIDIA Quadro NVS 295 graphics controller, the graphics system hangs after a while while loading Feed The Beast.  The machine in question is using Debian Stretch 9.6 with the latest updates.  I had to reboot the machine to get it working again.  Switching from the nouveau kernel driver to the nvidia-legacy-340xx-kernel-dkms kernel driver solved the problem.

After the crash I found the found the attached kernel messages in /var/log/kern.log.  Please let me know if there is anyting more information I can provide, while the machine and setup is available for me to test on.

The machine in question have 16 GiB RAM.
Comment 1 Petter Reinholdtsen 2018-11-22 06:53:49 UTC
I tried to reproduce this on an updated Debian Buster, but failed, because Minecraft Feed The Beast crashed in userspace before the problematic point in the startup where the kernel driver crashed using Debian Stretch.
Comment 2 Martin Peres 2019-12-04 09:46:48 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/466.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.