Bug 111105

Summary: buffer in tig flickers
Product: DRI Reporter: Jiri Slaby <jirislaby>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED NOTOURBUG QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: intel-gfx-bugs
Version: XOrg git   
Hardware: Other   
OS: All   
Whiteboard: Triaged
i915 platform: SKL i915 features:
Attachments:
Description Flags
video of the issue
none
dmesg since the boot
none
xorg 0 log none

Description Jiri Slaby 2019-07-11 09:23:52 UTC
Created attachment 144759 [details]
video of the issue

Very often, when I am using tig, part of its screen flickers. I took a video of that (attached). First I press page-up, page-down and when the issue occurs, it is enough to move with mouse to see the flickering.

I am on kernel 5.1.7. This happens for a long time, maybe since I have the laptop.
Comment 1 Jiri Slaby 2019-07-11 09:24:12 UTC
Created attachment 144760 [details]
dmesg since the boot
Comment 2 Jiri Slaby 2019-07-11 09:24:39 UTC
Created attachment 144761 [details]
xorg 0 log
Comment 3 Denis 2019-07-11 09:49:39 UTC
hi, if I got right, you are using modesetting driver. I remember issues with flickering related to driver exactly.

So you can try to exchange it to "intel".



    cd /usr/share/X11/xorg.conf.d
    sudo gedit 20-intel.conf
    #this will create an empty txt file with a name 20-intel.conf
    Paste text below:

Section "Device"

    Identifier "Intel"

    Driver "intel"

    Option "TearFree" "true"

    Option "DRI" "3"

EndSection

4. Save document

5. Logout from your session and login again
Comment 4 Jiri Slaby 2019-07-11 10:32:17 UTC
(In reply to Denis from comment #3)
> hi, if I got right, you are using modesetting driver. I remember issues with
> flickering related to driver exactly.

Thanks, but modesetting is preferred on Skylake. So instead of using intel ddx, I reported it here to have it fixed instead of working it around.
Comment 5 Denis 2019-07-12 10:04:35 UTC
I understand your point, but this check may point the issue to the modesetting driver, in case if with intel it will work fine.
Comment 6 Chris Wilson 2019-07-12 11:41:40 UTC
-modesetting bugs are over in https://gitlab.freedesktop.org/xorg/xserver/issues/new and this just looks like a request for TearFree?
Comment 7 Chris Wilson 2019-07-12 11:48:58 UTC
(In reply to Jiri Slaby from comment #4)
> (In reply to Denis from comment #3)
> > hi, if I got right, you are using modesetting driver. I remember issues with
> > flickering related to driver exactly.
> 
> Thanks, but modesetting is preferred on Skylake. So instead of using intel
> ddx, I reported it here to have it fixed instead of working it around.

Also file a regression report for whoever preferred -modesetting; they should be supporting their decision.
Comment 8 Jiri Slaby 2019-07-15 11:36:00 UTC
I installed the distributed xf86-video-intel-2.99.917+git8674.25c9a2fcc-3.3.x86_64. Give it some time to (not) recur with intel ddx...
Comment 9 Jiri Slaby 2019-07-17 13:18:55 UTC
With intel ddx, I can definitely reproduce the issue when I am typing to a terminal, but I have to move with mouse to actually see the letters -- a different issue? The one with tig I cannot (yet).
Comment 10 Lakshmi 2019-08-28 11:18:35 UTC
Jiri, If the original issue is related to modesetting. I would like to close this issue as NOTOURBUG.
Comment 11 Jiri Slaby 2019-08-29 07:54:23 UTC
(In reply to Lakshmi from comment #10)
> Jiri, If the original issue is related to modesetting. I would like to close
> this issue as NOTOURBUG.

Likely it is modesetting related.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.