Bug 111610

Summary: [CI][RESUME] igt@kms_plane_scaling@*(pixel-format*|clamping) - fail - Failed assertion: ret == 0
Product: DRI Reporter: Martin Peres <martin.peres>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: RESOLVED MOVED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: not set    
Priority: high CC: intel-gfx-bugs
Version: XOrg git   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: TGL i915 features: display/Other

Description Martin Peres 2019-09-09 11:10:24 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html

Starting subtest: pipe-B-scaler-with-pixel-format
(kms_plane_scaling:1382) igt_kms-CRITICAL: Test assertion failure function do_display_commit, file ../lib/igt_kms.c:3464:
(kms_plane_scaling:1382) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_plane_scaling:1382) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_scaling:1382) igt_kms-CRITICAL: error: -22 != 0
Comment 1 CI Bug Log 2019-09-09 11:10:40 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@kms_plane_scaling@*(pixel-format*|clamping) - fail - Failed assertion: ret == 0
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_plane_scaling@pipe-c-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_plane_scaling@pipe-a-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane@pixel-format-pipe-c-planes-source-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane@pixel-format-pipe-a-planes.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane@pixel-format-pipe-b-planes.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane_scaling@pipe-c-scaler-with-clipping-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_plane_scaling@pipe-a-scaler-with-clipping-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-a-planes-source-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-c-planes.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane_scaling@pipe-b-scaler-with-clipping-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-b-planes-source-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-c-planes-source-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-a-planes.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane@pixel-format-pipe-b-planes.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane_scaling@pipe-c-scaler-with-clipping-clamping.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_plane_scaling@pipe-a-scaler-with-clipping-clamping.html
Comment 2 Juha-Pekka Heikkilä 2019-09-10 13:21:27 UTC
There's in log comment which says "[drm:skl_check_pipe_max_pixel_rate [i915]] Max supported pixel clock with scaling exceeded", on log where I checked this failed is used on screen XR4H and RG16 formats on plane sizes which are too big for scaler..so this is problem of the test.
Comment 4 Juha-Pekka Heikkilä 2019-09-12 14:14:46 UTC
I went checking on ICL how this "*-scaler-with-clipping-clamping" test really behave and feel this test is less than useless.

On normal 1080p as well as 4k display all runs trying YUV formats will fail silently, none of them could ever come to screen. This silently failing is by design in this test, if you look at dmesg while "*-scaler-with-clipping-clamping" is running you see almost all runs will fail but still test says "SUCCESS".

Why "*-scaler-with-clipping-clamping" was now visibly failing in CI was there used special screen resolution "3200x1800" which allowed YUV formats to try to show on screen. So, in other words this clipping or clamping with scalers is likely never actually tested using YUV formats and should probably go check if scalers with YUV are tested at all.


..onto the actual bug which look like is a *real* bug that can be seen better in kms_plane@pixel-format-pipe-*-planes, DRM_FORMAT_XRGB16161616F is used just on regular plane of size 64x64 without anything special and it fails with comment "[drm:skl_check_pipe_max_pixel_rate [i915]] Max supported pixel clock with scaling exceeded" so that probably need some fix. This does work on ICL.
Comment 5 Jani Saarinen 2019-09-17 10:45:09 UTC
According to Ville/J-P should be fixed by https://patchwork.freedesktop.org/series/63373/
Comment 6 Jani Saarinen 2019-10-01 11:01:22 UTC
Looks like this now fixed on CI results. Lakshmi can you check.
Comment 7 Lakshmi 2019-10-01 12:10:52 UTC
(In reply to Jani Saarinen from comment #5)
> According to Ville/J-P should be fixed by
> https://patchwork.freedesktop.org/series/63373/

(In reply to Jani Saarinen from comment #6)
> Looks like this now fixed on CI results. Lakshmi can you check.

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_378/fi-tgl-u/igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html

Last seen on drmtip 378. So we need to wait atleast for the next 10 drmtip runs (388) before archiving this issue.
Comment 8 Martin Peres 2019-10-16 12:39:54 UTC
(In reply to Lakshmi from comment #7)
> (In reply to Jani Saarinen from comment #5)
> > According to Ville/J-P should be fixed by
> > https://patchwork.freedesktop.org/series/63373/
> 
> (In reply to Jani Saarinen from comment #6)
> > Looks like this now fixed on CI results. Lakshmi can you check.
> 
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_378/fi-tgl-u/
> igt@kms_plane_scaling@pipe-b-scaler-with-pixel-format.html
> 
> Last seen on drmtip 378. So we need to wait atleast for the next 10 drmtip
> runs (388) before archiving this issue.

Still nothing at 387. I'll take the risk and close it now! 

"Do as I say, not what I do, right?"
Comment 9 CI Bug Log 2019-10-16 12:40:11 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.
Comment 10 CI Bug Log 2019-10-22 13:02:22 UTC
The CI Bug Log issue associated to this bug has been restored.

All the previous filters are now active.
Comment 11 Lakshmi 2019-10-22 13:04:51 UTC
http://gfx-ci.fi.intel.com/cibuglog-ng/testresult/452668746
Starting subtest: pipe-A-scaler-with-clipping-clamping


Stdout	
Starting subtest: pipe-A-scaler-with-clipping-clamping
Stack trace:
#0 ../lib/igt_core.c:1696 __igt_fail_assert()
#1 ../lib/igt_kms.c:3464 do_display_commit()
#2 ../lib/igt_kms.c:3570 igt_display_commit2()
#3 ../tests/kms_plane_scaling.c:497 __real_main622()
#4 ../tests/kms_plane_scaling.c:622 main()
#5 ../csu/libc-start.c:344 __libc_start_main()
#6 [_start+0x2a]
Subtest pipe-A-scaler-with-clipping-clamping: FAIL (350.517s)
Test requirement not met in function igt_display_require_output_on_pipe, file ../lib/igt_kms.c:2156:
Test requirement: !(pipe >= igt_display_get_n_pipes(display))
Pipe E does not exist.
Test requirement not met in function igt_display_require_output_on_pipe, file ../lib/igt_kms.c:2156:
Test requirement: !(pipe >= igt_display_get_n_pipes(display))
Pipe F does not exist.

Stderr	
Starting subtest: pipe-A-scaler-with-clipping-clamping
(kms_plane_scaling:1699) igt_kms-CRITICAL: Test assertion failure function do_display_commit, file ../lib/igt_kms.c:3464:
(kms_plane_scaling:1699) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_plane_scaling:1699) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_scaling:1699) igt_kms-CRITICAL: error: -22 != 0
Subtest pipe-A-scaler-with-clipping-clamping failed.
Comment 12 Jani Saarinen 2019-10-22 14:00:32 UTC
We do not have pipe-e and f. Do we fail because of those missing?
Comment 13 CI Bug Log 2019-10-30 16:08:21 UTC
A CI Bug Log filter associated to this bug has been updated:

{- TGL: igt@kms_plane_scaling@*(pixel-format*|clamping) - fail - Failed assertion: ret == 0 -}
{+ TGL: igt@kms_plane_*@*(pixel-format*|clamping) - fail - Failed assertion: ret == 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7181/re-tgl-u/igt@kms_plane_scaling@pipe-d-scaler-with-clipping-clamping.html
Comment 14 Martin Peres 2019-11-29 19:27:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/intel/issues/408.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.