Bug 112123

Summary: Laptop freezes after suspend [write fault]
Product: xorg Reporter: Sandy <sandy97>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: not set    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
A part of journalctl, describing process of crash none

Description Sandy 2019-10-24 20:34:18 UTC
Created attachment 145812 [details]
A part of journalctl, describing process of crash

Description:
When I suspend (close) my laptop and then try to wake it up, it freezes; everything is displayed, however, inputs stop reacting and everything on screen stops moving too. It happens only with GUIs - when I suspend it while in terminal, it works fine (when I go back to GUI it switches and then freezes, sadly).
According to journal, this is because of Nouveau having trouble with memory read:

paź 24 13:43:31 Langley kernel: [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0
paź 24 21:42:32 Langley kernel: nouveau 0000:01:00.0: fifo: write fault at 0000048000 engine 07 [PFIFO] client 07 [BAR_READ] reason 02 [PAGE_NOT_PRESENT] on channel 2 [003fc13000 Xorg[538]]
paź 24 21:42:32 Langley kernel: nouveau 0000:01:00.0: fifo: fifo engine fault on channel 2, recovering...
(don't mind Polish month)

Usually, keyboard works just for a few seconds (Caps/Num Lock LEDs react), touchpad doesn't. I don't think the whole system crashes, I believe it's still working but is blocked by unresponsive driver.

I believe that if I wait 10 minutes or so, it actually may start working again; however, reboot is faster in this case.

If I just let my laptop be, so it suspends while open, it wakes up perfectly.

Specs:
Distribution: Arch
Kernel: 5.3.7-arch1-1-ARCH (tested mainline 5.4.0-rc4, bug still occurs; also occurs on other, older kernels; didn't test other distros)
Laptop: Sony Vaio, model VPCEH2D1E C1065BHW 
GPU: GeForce 410M

Steps to reproduce:
1. Close the laptop so it goes to sleep
2. Open it and press something
Since I couldn't find anyone else with this same error, I suppose you need similar/same model, graphic card or configuration (Sony Vaio with 410M etc).

I am attaching a part of journalctl (starts at lid closing).

Also, I was instructed to report the bug here at the Arch bug list, where I first described the bug.
Comment 1 Martin Peres 2019-12-04 09:54:25 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/511.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.