Bug 11896

Summary: yelp crashes on startup reading the info dir
Product: Rarian Reporter: Götz Waschk <goetz.waschk>
Component: GeneralAssignee: Don Scorgie <Don>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Götz Waschk 2007-08-08 02:28:58 UTC
This is with yelp 2.19.1 and rarian 0.5.6 on Mandriva Cooker:
(gdb) bt
#0  0xb6f19733 in strchr () from /lib/i686/libc.so.6
#1  0xb752dd15 in process_initial_entry (
    line=0xb3c0bf78 "* Gnash Manual V0_3: .          ???\n")
    at rarian-info.c:115
#2  0xb752ebf6 in process_info_dir (dir=0xb3c142d8 "/usr/share/info")
    at rarian-info.c:444
#3  0xb752ed38 in rrn_info_init () at rarian-info.c:534
#4  0xb752ef79 in rrn_info_get_categories () at rarian-info.c:556
#5  0x08064e03 in toc_process_info (toc=0x824c898) at yelp-toc.c:699
#6  0xb731f424 in g_thread_create_proxy (data=0x8557b30) at gthread.c:634
#7  0xb7115462 in start_thread () from /lib/i686/libpthread.so.0
#8  0xb6f7b82e in clone () from /lib/i686/libc.so.6
Comment 1 Don Scorgie 2007-08-12 08:20:20 UTC
Thanks.  Fixed in SVN.

Note that the root cause is a bad entry for the GNASH info page (didn't know it had one).  It is missing a filename.  You might want to report that to Mandriva (or upstream if you got GNASH there).

2007-08-12  Don Scorgie  <Don@Scorgie.org>

	* librarian/rarian-info.c:
	Fix crashing on entried without a filename
	(bug #11896)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.