Bug 13069

Summary: Odd artifacting in textures
Product: Mesa Reporter: Scott Knauert <sknauert>
Component: Drivers/DRI/r300Assignee: Default DRI bug account <dri-devel>
Status: RESOLVED INVALID QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Scott Knauert 2007-11-02 23:19:56 UTC
Not 100% if this isn't related to https://bugs.freedesktop.org/show_bug.cgi?id=8489
but I get small clusters of minor pixel artifacts when using 3D. The best way to describe them is braille-like glyphs. Here is a snapshot: http://img486.imageshack.us/img486/6743/snapshot3lv3.png

The easiest way to reproduce the bug is to enable Compiz, everything has them, the desktop background, toolbars, widgets (Qt, GTK, etc.). The artifacts seem semi-random, i.e. moving a window around will create new artifact patterns. This does not occur with a normal window manager, except in 3D programs.

Other 3D apps that use textures (for example Mupen64 - yes, I know that's a very poor example of a 3D test app - or ivview) also have these. I believe it is texture related as rendering the same scene in ivview without textures seems devoid of artifacts. These artifacts also don't appear in 3D apps without textures, like glxgears. I'll gladly run any tests or open source app to help narrow down the issue further. I'm not a gamer so I don't have any retail games to test with unfortunately.

I'm running Debian unstable. Xorg 7.3, Mesa 7.0.1-2, compiz 0.5.5+git20071101-shame-0.

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "radeon"
        Option "EnablePageFlip" "true"
        Option "ColorTiling" "true"
        Option "AccelMethod" "EXA"
EndSection

While fglrx has been on this machine, I removed all of the GL libs, so I'm sure that isn't an issue. With fglrx, these artifacts do not seems to occur in 3D apps. I never got compiz working with it, but I somewhat doubt my artifacts are from another component besides the driver. The artifacts occur if I change to XXA or disable ColorTiling and PageFlip. I have a Radeon 9500 np on a PIII 750.
Comment 1 Maciej Cencora 2009-10-10 03:06:47 UTC
Could you try newest versions of mesa,libdrm,xf86-video-ati and kernel radeon drm?
Comment 2 Maciej Cencora 2010-03-07 13:19:54 UTC
Closing due to lack of user feedback.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.