Bug 15683

Summary: 300x230mm reported incorrectly by xdpyinfo for LPL 154W01-TLD monitor
Product: xorg Reporter: Bryce Harrington <bryce>
Component: Server/GeneralAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: hramrach
Version: 7.3 (2007.09)   
Hardware: Other   
OS: All   
URL: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/201032
Whiteboard:
i915 platform: i915 features:

Description Bryce Harrington 2008-04-23 14:58:55 UTC
I'm forwarding a Ubuntu bug reporter's report:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/201032

xdpyinfo is reporting incorrect physical screen dimensions for a LGPhilipsLCD LP154W01-TLD (eisa: LPLbc00, edid: "LPL" prod id 48128).  xrandr correctly reports the dimensions as 331mm x 207mm, and ddcprobe reports screensize: 33 21, yet xdpyinfo reports (300x230 millimeters).  Xorg.0.log does not report what it took from edid in this case, but does indicate it used a 96x96 dpi.

This error causes DPI's to be set incorrectly in some applications (like Firefox).  xdpyinfo is reporting the dpi to be 108x88, which may be what FF and other apps are using.

I notice that a similar monitor from this manufacturer, LGPhilipsLCD LP154W01-A5, was quirked in quirk_detailed_use_maximum_size() (bug #10304).  Perhaps it simply needs a quirk for this monitor as well?

http://launchpadlibrarian.net/12576794/xdpyinfo.log
http://launchpadlibrarian.net/12576796/Xorg.0.log
http://launchpadlibrarian.net/12576809/xorg.conf
http://launchpadlibrarian.net/12576845/xrandr
http://launchpadlibrarian.net/12576864/lspci-vvnn.log
http://launchpadlibrarian.net/12576880/ddcprobe

[Also see bug #15682 which has a similar problem with a different monitor and may also need this same quirk.]
Comment 1 Kiri 2010-02-13 08:07:18 UTC
I am observing DPI set to 96.  Is this the same or different bug?  As the user in
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/201032
I use the "intel" driver and I have an LG monitor (L1919S) attached by VGA.
In Xorg.0.log I see that the Intel reports the correct dimensions in cm for my monitor. I also have an LVDS connected monitor which is disabled in xorg.conf.
Comment 2 Michal Suchanek 2012-04-25 02:16:32 UTC
Xorg reports wrong screen size by design. See bug 23705
Comment 3 GitLab Migration User 2018-12-13 22:19:35 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/367.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.