Bug 15940

Summary: [i915 XvMC] can't scale up by 8x8 times
Product: xorg Reporter: Shuang He <shuang.he>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: VERIFIED WONTFIX QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
test case
none
xorg conf
none
xorg log none

Description Shuang He 2008-05-14 19:00:25 UTC
System Environment:
--------------------------

--Platform: 945G


--2D driver:
commit 548d4c0f979a72eac5d0c9c76da12f0bd05e64e1 

--3D driver:
commit 990e010394a2685c1daeaef61cf4f7e2a0ba419e

--Xserver:
commit cf20df39cc78203d17b99223908af388ecbf7d0e 

--Drm
commit b44f2da380e78769b58c751e81f376f0fa1f48aa 

--Kernel:
2.6.23.1


Bug detailed description:
-------------------------
render a 16x16 video to surface, then try put that surface to window and scaling it up by 8x8 times. But it turns out it's not working well, there's black border on the right and bottom sides.
and it's working with scaling less times, such as 7x7 times.


Reproduce steps:
----------------
1. enable XvMC in xorg.conf
2. start X
3. compile and run attached case



Current result:
----------------
there's black border on the right and bottom sides


Expected result:
----------------
should render correctly
Comment 1 Shuang He 2008-05-14 19:04:30 UTC
Created attachment 16542 [details]
test case
Comment 2 Shuang He 2008-05-14 19:05:51 UTC
Created attachment 16543 [details]
xorg conf
Comment 3 Shuang He 2008-05-14 19:06:58 UTC
Created attachment 16544 [details]
xorg log
Comment 4 Wang Zhenyu 2008-06-02 02:05:35 UTC
yeah, current driver doesn't provide any scale capability in driver.
Comment 5 Michael Fu 2008-11-25 20:47:59 UTC
We will not put further effort on XvMC for 915/945 platform.
Comment 6 Shuang He 2009-01-18 21:19:19 UTC
verified

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.