Bug 17009

Summary: [965GM] PAT breaks xserver
Product: xorg Reporter: Tobias Hain <tobias.hain>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED WORKSFORME QA Contact: Xorg Project Team <xorg-team>
Severity: minor    
Priority: medium    
Version: 7.3 (2007.09)   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg.log git tip video driver and PAT
none
Xorg.log git tip video driver and MTRR
none
Xorg.log 2.3.2 video driver and PAT none

Description Tobias Hain 2008-08-06 07:44:54 UTC
System: Dell XPS M1330
Distro: Ubuntu 8.04.1
Kernel: 2.6.26.1 (vanilla)
xserver: X.Org X Server 1.4.99.906 (1.5.0 RC 6) taken from Ubuntu intrepid xserver-xorg-core (2:1.4.99.906-1ubuntu2)

intel xorg video driver:
. 2.4.99 git tip 2008/06/08 f91134795b545c8baebf218975b261c76a0e5873
. 2.3.2 taken from intrepid (2:2.3.2-2ubuntu3)

description:
. xserver won't start with git tip. Several flashes of distorted xserver images, but finally a black image.
. only occours on PAT enabled kernel

workaround:
. use MTRR instead of PAT (Page Attribute Table) by adding "nopat" kernel option and git tip xserver runs fine
. 2.3.2 release video driver will run even when PAT is enabled

additional information:
There are some interesting lines in X.log when using PAT and xserver fails:

(WW) intel(0): ESR is 0x00000010, page table error
(WW) intel(0): PGTBL_ER is 0x00000100, display B pte
(WW) intel(0): Existing errors found in hardware state.
[...]
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf8ecf000 at 0xb7f4a000
(II) intel(0): [drm] Closed DRM master.

However I also have one X.log running PAT with this "page table error" on 2.3.2. In that case the xserver was running find - just having this warning. But in general 2.3.2 won't show these warnings.

/proc/mtrr looks always like this once X is started (regardless of xserver and PAT):
reg00: base=0x00000000 (   0MB), size=2048MB: write-back, count=1
reg01: base=0x7f800000 (2040MB), size=   8MB: uncachable, count=1
reg02: base=0x7f700000 (2039MB), size=   1MB: uncachable, count=1
reg03: base=0xe0000000 (3584MB), size= 256MB: write-combining, count=1

However if xserver doesn't start and fails then the last line reg03 is not present.
Comment 1 Tobias Hain 2008-08-06 07:45:48 UTC
Created attachment 18156 [details]
Xorg.log git tip video driver and PAT
Comment 2 Tobias Hain 2008-08-06 07:46:09 UTC
Created attachment 18157 [details]
Xorg.log git tip video driver and MTRR
Comment 3 Tobias Hain 2008-08-06 07:46:39 UTC
Created attachment 18158 [details]
Xorg.log 2.3.2 video driver and PAT
Comment 4 Tobias Hain 2008-08-07 01:38:06 UTC
I have seen this error meanwhile more often in X.log

(WW) intel(0): ESR is 0x00000011, page table error
(WW) intel(0): PGTBL_ER is 0x00040000, overlay tiling
(WW) intel(0): Existing errors found in hardware state.

It's a slight deviation compared to the error message above. However this one is taken from a gti tip video driver 2.4.99 and a 2.6.24 kernel with MTRR. And the X session that this error is taken from did work fine.

Therefore I assume that this error message is not necessarily related to PAT. The driver seems to recover from that situation described by the warning.
Comment 5 Wang Zhenyu 2008-08-11 19:47:15 UTC
2.6.27-rc2 with PAT runs ok no my T61 with current video driver. I haven't tried .26 kernel yet.
Comment 6 Tobias Hain 2008-08-12 06:29:27 UTC
I just compiled 2.6.27-rc2 and it gives me the same result as 2.6.26.

If I boot with PAT, then X server will flash a couple of times but no image. If I start with "nopat" kernel option everything works fine here.

I diffed again the Xorg.0.log and the only real difference is this message which shows up when PAT is enabled:

(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf8eed000 at 0xb7eea000
(II) intel(0): [drm] Closed DRM master.

I frequently update intel drivers and if I have updates to this issue, I'll post them here. Meanwhile I consider this one not important since a workaround is known.
Comment 7 Michael Fu 2009-01-04 23:31:15 UTC
(In reply to comment #6)
> I just compiled 2.6.27-rc2 and it gives me the same result as 2.6.26.
> 
> If I boot with PAT, then X server will flash a couple of times but no image. If
> I start with "nopat" kernel option everything works fine here.
> 
> I diffed again the Xorg.0.log and the only real difference is this message
> which shows up when PAT is enabled:
> 
> (II) intel(0): [drm] removed 1 reserved context for kernel
> (II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf8eed000 at 0xb7eea000
> (II) intel(0): [drm] Closed DRM master.
> 
> I frequently update intel drivers and if I have updates to this issue, I'll
> post them here. Meanwhile I consider this one not important since a workaround
> is known.
> 

Tobias, how much memory do you have in your T61? have any chance to try a newer ubuntu like 8.10?

Zhenyu, What's your xserver version that can _not_ reproduce this bug?
Comment 8 Tobias Hain 2009-01-05 10:11:55 UTC
Actually I'm running a Dell XPS M1330 and not a T61 as stated in the first posting. It currently has 2GB of memory.

This bug at some point of time disappeared. I'm now on Ubuntu 8.10 + vanilla 2.6.28 and can't tell at which point it started working again. Haven't bisected and there are too many component versions involved.

Therefore I think it's best to close this bug. I don't mind reopening if I step on it again.
Comment 9 Wang Zhenyu 2009-01-05 17:27:03 UTC
ok, close now. If that appears again, we can open this and take a look again.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.