Bug 17070

Summary: X crash when ran "xrandr -q " with nude X
Product: xorg Reporter: lin, jiewen <jiewen.lin>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: VERIFIED INVALID QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: git   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
xorg.conf
none
Xorg.0.log none

Description lin, jiewen 2008-08-11 01:15:10 UTC
Created attachment 18212 [details]
xorg.conf

System Environment:
--------------------------

--Platform: ct1
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: master   fe90c0522f65f60c4c431787c889b7fb639ab61b
--3D driver: master 1724334d7c82abe55b6506dfe369df4facae6f06
--DRM:  master  e1b8e79796b172c356af98eb49107c8abbebfe5a
--Xserver: master 26d31ad1c7f4c550d73419ecf76912d844186b30
--Kernel: 2.6.25-rc6
--Display connector: VGA

Bug detailed description:
--------------------------
When ran "xrandr -q" after starting X but not started xterm, X crashed a few seconds later (around 5).
Reproduce steps:
----------------
1 X &
3 xrandr -q
Current result:
----------------
fail

Expected result:
----------------
normal
Comment 1 lin, jiewen 2008-08-11 01:16:12 UTC
Created attachment 18213 [details]
Xorg.0.log
Comment 2 lin, jiewen 2008-08-11 01:17:17 UTC
This issue also exists on el1
Comment 3 Wang Zhenyu 2008-08-31 20:45:52 UTC
Looks invalid, no fixed font found, so X exit. Check with your building.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.