Bug 17194

Summary: [915GM] intel-2.4.1 driver outputs only low color depth
Product: xorg Reporter: Alexandre Rostovtsev <tetromino>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: remi
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
photo with 2.4.0 driver (smooth gradient)
none
photo with 2.4.1 driver (striped gradient)
none
Xorg log with 2.4.0 driver
none
Xorg log with 2.4.1 driver none

Description Alexandre Rostovtsev 2008-08-18 18:55:38 UTC
Dell Inspiron 6000, 915GM video, 1680x1050, 2.6.26 kernel, xorg-server-1.4.2

Gentoo's xf86-video-i810-2.4.0-r1 driver (i.e. the intel-2.4.0 driver with some patches selected from git, see http://sources.gentoo.org/viewcvs.py/gentoo-x86/x11-drivers/xf86-video-i810/files/2.4.0/) worked correctly, as did prior driver versions.

Upgrading to xf86-video-i810-2.4.1 (i.e. the intel-2.4.1 driver) resulted in output with a noticeably low color depth. I drew a simple gradient in Inkscape and took some photos - with the 2.4.0 driver, the gradient is smooth, but with the 2.4.1 driver, it's obviously striped.

Weirdly enough, the output of xdpyinfo is the same in both 2.4.0 and 2.4.1
Comment 1 Alexandre Rostovtsev 2008-08-18 19:01:51 UTC
Created attachment 18365 [details]
photo with 2.4.0 driver (smooth gradient)
Comment 2 Alexandre Rostovtsev 2008-08-18 19:03:10 UTC
Created attachment 18366 [details]
photo with 2.4.1 driver (striped gradient)
Comment 3 Alexandre Rostovtsev 2008-08-18 19:09:53 UTC
Created attachment 18367 [details]
Xorg log with 2.4.0 driver
Comment 4 Alexandre Rostovtsev 2008-08-18 19:10:29 UTC
Created attachment 18368 [details]
Xorg log with 2.4.1 driver
Comment 5 Wang Zhenyu 2008-08-18 22:13:28 UTC
Current 2.4-branch has a lvds dither fix, could you try it?
Comment 6 Alexandre Rostovtsev 2008-08-19 00:30:38 UTC
Yes, the dither fix in http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/diff/?h=xf86-video-intel-2.4-branch&id=d5fd845aab4074ed6d0950551e007ea43fd2d0df fixes my color depth problem.

(By the way, as an aside.

Is there any way to get a raw text diff from freedesktop's cgit web interface? Because the diffs that cgit displays are in the form of an HTML table - you can't even copy/paste them into a text editor without destroying whitespace. I had to write a greasemonkey script just to turn cgit's output into something I could actually copy into vim.)
Comment 7 Wang Zhenyu 2008-08-19 00:34:05 UTC
You should install git on your machine ;)

Mark as closed, will bump another version for regression fixes later.
Comment 8 Wang Zhenyu 2008-08-19 00:34:18 UTC
You should install git on your machine ;)

Mark as closed, will bump another version for regression fixes later.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.