Bug 17508

Summary: [GM45 LVDS] Garbled Screen after start of Xorg, on Sony vaio z11wn/b (with nvidia)
Product: xorg Reporter: Oliver Pahl <oliver_pahl>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: jbarnes, kan.liang, karsten, michael.fu, oliver_pahl, rui.zhang, ugo.viti
Version: 7.4 (2008.09)   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 16926, 18858    
Attachments:
Description Flags
lspci output
none
Xorg.0.log
none
xorg.conf
none
Picture of the red line on the left side
none
Grabled output
none
Xorg.0.log without VGA connected
none
dmesg output
none
Xorg.log with ModeDebug enabled and no VGA connected
none
Xorg.log with ModeDebug enabled and VGA connected
none
debug patch
none
Xorg.log with ModeDebug enabled
none
VBios binary
none
VBios binary
none
Xorg.log with pI830->lvds_use_ssc = FALSE
none
Newest Xorg.0.log with master branch driver
none
Newest Xorg.0.log with master branch driver
none
lvds bios timing flags test patch
none
New Xorg.0.log with previous patch applied
none
gpio check program for switchable gfx feature
none
Xorg.0.log for Modeline 1600x900_60
none
Xorg.0.log for Modeline 1600x900_60
none
debug patch
none
set LVDS reference divisor based on current block
none
Failed to start X. No garbled screen, but lockup.
none
Xorg.0.log with Version 2.6.0 and patch applied
none
Xorg.0.log with Version 2.6.0 and patch applied without KMS
none
acpidump output
none
lspic -vxxx output
none
hi Oliver please try this patch on your machine,thanks. none

Description Oliver Pahl 2008-09-09 22:42:21 UTC
After starting Xorg with the intel driver enabled, the screen gets a glowing red line at the left side and then gets totally garbled. If i plug a Monitor in the monitor shows the normal picture. I tried to fiddle a little with xrandr to switch the LVDS to auto or use different resolutions, but nothing helped. I tried this with a gentoo installation and the intel drivers from git as well as with ubuntu and the 2.4.1 and 2.4.2 drivers. My system is a sony vaio z11wn/b with an intel gm45 (x4500) and a nvidia geforce 9300m gs (i can switch between them). X.Org.log shows nothing specific and no errors, as the x-server starts up as expected. I can post it if you need it, but at the moment i cannot access my notebook. xorg.conf used was the one supplied by ubuntu as well as one edited by myself.
Comment 1 Oliver Pahl 2008-09-09 23:02:36 UTC
Created attachment 18793 [details]
lspci output
Comment 2 Oliver Pahl 2008-09-09 23:04:04 UTC
Created attachment 18794 [details]
Xorg.0.log
Comment 3 Oliver Pahl 2008-09-09 23:05:08 UTC
Created attachment 18795 [details]
xorg.conf
Comment 4 Oliver Pahl 2008-09-09 23:07:02 UTC
Created attachment 18796 [details]
Picture of the red line on the left side

The Monitor gets lighted up, then a red line appears at the left side and shrinks to the bottom. Otherwise the screen stays blank. After that the image gets garbled.
Comment 5 Oliver Pahl 2008-09-09 23:07:48 UTC
Created attachment 18797 [details]
Grabled output
Comment 6 Gordon Jin 2008-09-09 23:50:31 UTC
So this happens only when you only use LVDS (laptop panel display), right?

But why the log shows VGA connected?
Comment 7 Oliver Pahl 2008-09-09 23:54:49 UTC
I had no network there, so i had to start with VGA connected to pull the conf and log files. But its the same with LVDS only.
Comment 8 Gordon Jin 2008-09-10 00:02:42 UTC
>> If i plug a Monitor in the monitor shows the normal picture. 

Do you mean if you connect a VGA monitor, both VGA and LVDS display ok?
Comment 9 Oliver Pahl 2008-09-10 00:22:01 UTC
No, if i plug in a VGA Monitor the Display on the VGA is okay, the LVDS is alway garbled, if the monitor is connected or not doesnt matter.
Comment 10 Oliver Pahl 2008-09-10 01:25:59 UTC
Created attachment 18798 [details]
Xorg.0.log without VGA connected

This is the Xorg.0.log without an VGA Display connected
Comment 11 Wang Zhenyu 2008-09-10 01:56:35 UTC
Could you attach your dmesg output?
Comment 12 Oliver Pahl 2008-09-10 02:13:52 UTC
Created attachment 18799 [details]
dmesg output

I can only provide the dmesg output from the ubuntu live cd, because i reinstalled the notebook with xp, while this error still exists. The sonypi kernel error makes no difference, as with the gentoo setup the same error existed even when sonypi was not loaded
Comment 13 Oliver Pahl 2008-09-10 02:16:55 UTC
I have to reformulate :)

I can only provide the dmesg output from the ubuntu live cd, because i
reinstalled the notebook with xp, while this still happens. The sonypi
kernel error makes no difference, as with the gentoo setup the display got corrupted even when sonypi was not loaded and no kernel error was present.
Comment 14 Oliver Pahl 2008-09-11 02:27:23 UTC
I installed Ubuntu again so i could test a fix if you got one. So let me know if something comes up, i would be happy to test.
Comment 15 Wang Zhenyu 2008-09-15 18:44:16 UTC
Could you turn on ModeDebug option and upload new X log?
Comment 16 Oliver Pahl 2008-09-15 22:56:31 UTC
Created attachment 18909 [details]
Xorg.log with ModeDebug enabled and no VGA connected
Comment 17 Oliver Pahl 2008-09-15 22:58:35 UTC
Created attachment 18910 [details]
Xorg.log with ModeDebug enabled and VGA connected
Comment 18 Wang Zhenyu 2008-09-16 00:18:00 UTC
Created attachment 18911 [details] [review]
debug patch

disable vbios panel mode, and try if current mode readback is more correct.

Please try this, this patch applys to 2.4 branch driver.
Comment 19 Oliver Pahl 2008-09-16 02:14:41 UTC
Does the Patch disable the vbios panel mode or do i have to do this manually. Has this bug something to do with the issues described here: http://gentoo-wiki.com/Making_%22broken%22_Intel_video_BIOS_play_nice (could not try yet because currently @ work)
Comment 20 Wang Zhenyu 2008-09-18 00:22:43 UTC
Any update?
Comment 21 Oliver Pahl 2008-09-18 10:30:06 UTC
Sorry, my harddisk crashed 2 days ago, had to get me a new one. Installing Linux again at the moment, will then test and report back.
Comment 22 Oliver Pahl 2008-09-20 05:46:43 UTC
Tried the patch, doesn't change anything Display-wise. Display looks the same, shrinking red line then garbled display.
Comment 23 Wang Zhenyu 2008-09-21 18:53:58 UTC
Could you paste X log with ModeDebug?
Comment 24 Wang Zhenyu 2008-09-22 18:31:26 UTC
oh, do you use 2.4.2 release? Could you try current git master or xf86-video-intel-2.4-branch tip?
Comment 25 Oliver Pahl 2008-09-22 22:13:59 UTC
I tried with git master. Will post the ModeDebug results today after work.
Comment 26 Wang Zhenyu 2008-09-22 22:45:29 UTC
ok, and also try with "NoAccel" option, to see if it's really display issue.
Comment 27 Michael Fu 2008-09-25 21:39:02 UTC
gut feeling that this is a dup of 17292...copying Jesse.
Comment 28 Oliver Pahl 2008-09-29 09:27:31 UTC
Created attachment 19285 [details]
Xorg.log with ModeDebug enabled

My Notebook was defect and i had to replace it. As i am now finished with reinstalling, here is the Xorg.log output with ModeDebug enabled. Sorry for the Delay.
Comment 29 Wang Zhenyu 2008-10-05 20:47:42 UTC
How about if you disable nvidia gfx in somewhere -- bios?

Could you try current xf86-video-intel master?

You may try to test with disable SSC, try to find "pI830->lvds_use_ssc" in src/i830_bios.c, which should look like "pI830->lvds_use_ssc = general->enable_ssc;", change it to "pI830->lvds_use_ssc = FALSE;". and retry.
Comment 30 Wang Zhenyu 2008-10-05 20:49:38 UTC
Could you attach a copy of your video bios? By doing

echo 1 > /sys/devices/pci0000\:00/0000\:00\:02.0/rom
cat /sys/devices/pci0000\:00/0000\:00\:02.0/rom > /tmp/vbios

and upload /tmp/vbios. Thanks.
Comment 31 Oliver Pahl 2008-10-06 00:56:34 UTC
I try the master after school today and send you the vbios. It is not possible to disable the nvidia card.
Comment 32 Oliver Pahl 2008-10-06 06:50:25 UTC
Created attachment 19406 [details]
VBios binary

VBios cat as requested
Comment 33 Oliver Pahl 2008-10-06 06:50:46 UTC
Created attachment 19407 [details]
VBios binary

VBios cat as requested
Comment 34 Oliver Pahl 2008-10-06 06:53:33 UTC
Created attachment 19408 [details]
Xorg.log with pI830->lvds_use_ssc = FALSE

I set pI830->lvds_use_ssc to FALSE but i did not help, still experiencing the same behaviour.
Comment 35 Wang Zhenyu 2008-10-08 01:06:45 UTC
Could you try current master tip with no any debug patch applied? 
Comment 36 Oliver Pahl 2008-10-08 07:21:33 UTC
Created attachment 19493 [details]
Newest Xorg.0.log with master branch driver

tried the latest tip with using the unmodified master branch. Didn't work.
Comment 37 Wang Zhenyu 2008-10-08 17:56:25 UTC
Your log seems not reach the end?
Comment 38 Oliver Pahl 2008-10-08 23:11:15 UTC
Created attachment 19513 [details]
Newest Xorg.0.log with master branch driver

Now it should be complete, Sorry for the inconvenience.
Comment 39 Wang Zhenyu 2008-10-08 23:42:45 UTC
Created attachment 19514 [details] [review]
lvds bios timing flags test patch

Could you try current master with this patch applied?
Comment 40 Oliver Pahl 2008-10-09 00:54:27 UTC
Created attachment 19520 [details]
New Xorg.0.log with previous patch applied

I tried the patch, same behaviour. Only difference i saw, is that after starting X the Monitor fades to dark instead of fading to light withe as previously.
Comment 41 Michael Fu 2008-10-13 01:09:06 UTC
Oliver, what's the exact distribution are you using?
Comment 42 Oliver Pahl 2008-10-13 02:25:45 UTC
At the moment i am working with arch linux. But i tried with Gentoo, Ubuntu and gOS, its the same issue with all of them. I also tried different kernels from 2.6.24 - 27.
Comment 43 Michael Fu 2008-10-13 05:07:04 UTC
(In reply to comment #42)
> At the moment i am working with arch linux. But i tried with Gentoo, Ubuntu and
> gOS, its the same issue with all of them. I also tried different kernels from
> 2.6.24 - 27.
> 

what I mean is what version of the distro, i.e. Ubuntu 8.04 or 8.10 alpha(?)/Beta(?)...
Comment 44 Oliver Pahl 2008-10-13 05:18:25 UTC
gOS 3
Ubuntu 8.04, 8.10 Alpha 3, 4, 5; Beta 1
Gentoo 2008.0
Arch Linux 2008.06

The same Behaviour with all of them.
Comment 45 Michael Fu 2008-10-13 06:48:33 UTC
oliver, what's the native panel resolution that your windows XP says?

We just got a Sony VGN-Z540 which has very similar HW configuration as yours. and it works fine. Zhenyu and I have tested Ubuntu 8.04, 8.10 beta LiveCD... 
Comment 46 Oliver Pahl 2008-10-13 07:12:03 UTC
My native Resolution is 1600x900. I already read somwhere that it seem to work with some of the japanese and american models of the Sony Z-Series. Live CDs of Ubuntu are not working either.
Comment 47 Oliver Pahl 2008-10-19 02:01:38 UTC
Hi,
the Notebook is described on this site:

http://vaio.sony.de/view/ShowProduct.action?product=VGN-Z11WN%2FB&site=voe_de_DE_cons&pageType=Overview&category=VN+Z+Series

(Sorry, but i found no english version - i think its only sold in germany with this configuration) Is there any update?
thanks
Comment 48 Liang Kan 2008-10-20 20:28:03 UTC
Hi,
I once met the similar issue (X crash after login) on Solaris with Sony VGN-Z540.
But when I disable the FBC, all work well. 

Could you please disable the FramebufferCompression in xorg.conf and have another try?
Option     "FramebufferCompression" "False"

Thanks!
Liang Kan
Comment 49 Oliver Pahl 2008-10-21 00:10:20 UTC
Thanks for the tip, but sadly that doesn't work either.
Comment 50 Oliver Pahl 2008-10-29 03:31:54 UTC
Are there any news? Is it possible that the high resolution causes the problem? My Notebook is comparable to the VGN-Z590 with a 1600x900 panel. If it works on a Z540 which only difference i could find is the lower video memory and the lower resolution could it be that. I am kind of helpless here, because i hate windows, and now i have to use it, because neither the intel nor the nvidia card is working under linux (nvidia not at all responding to my bug-report :( )
Comment 51 Wang Zhenyu 2008-10-30 00:18:03 UTC
Oliver, after checking some docs on this switchable graphics feature, it looks like LVDS and CRT has mux control between iGPU (integrated) and dGPU (discrete), TV and all digital outputs are controlled by dGPU only. But current work to control the mux and switch is not ready yet (I'll attach a test program, could you compile that and paste the output?).

You don't have setting in BIOS to use intel graphics only, right? I think vaio should have a key switch above keyboard to switch between gfx devices, have you tried with that switcher? 
Comment 52 Wang Zhenyu 2008-10-30 00:19:31 UTC
Created attachment 19952 [details]
gpio check program for switchable gfx feature

This requires libpciaccess, try to compile with "gcc -o gpio_check gpio_check.c -lpciaccess".
Comment 53 Oliver Pahl 2008-10-30 00:23:28 UTC
No, i cannot disable any of the Graphics cards in bios. The switch is no Hardware switch, i think. In Windows Device Manager i see both cards. And it doesnt make any difference how i put the switch, result stays the same. I'll try the test program immedeatly and post the ouput. Thanx
Comment 54 Oliver Pahl 2008-10-30 00:58:55 UTC
The utility says:

GPIO Base address: 0x500 , Length: 64 bytes
GPIO52 (dGPU_select) is used for native function instead of GPIO...

And i also saw a message popping up when booting i missed before, i think its somehow related to the pcie memory:

pci 0000:01:00.0: BAR 6: can't allocate mem resource [0xd0000000-0xcfffffff]
Comment 55 Michael Fu 2008-11-14 01:19:01 UTC
could you pls try this modeline?

ModeLine "1600x900_60" 76.1 1600 1664 1728 2091 900 901 902 910    +hsync  +vsync

pls attach your xorg.log as well for verification. thanks!
Comment 56 Oliver Pahl 2008-11-14 02:09:56 UTC
Created attachment 20298 [details]
Xorg.0.log for Modeline 1600x900_60

I tried to use it, but i think Xorg doesnt accept this Modeline. I also tried the Modeline given by gtf with the same result. Tried to force both of them using the PreferredMode switch, but it gets ignored.
Comment 57 Oliver Pahl 2008-11-14 02:33:22 UTC
Created attachment 20299 [details]
Xorg.0.log for Modeline 1600x900_60

Typo in xorg.conf now using correct Mode, but no difference
Comment 58 Oliver Pahl 2008-11-14 02:36:05 UTC
Just FYI. I also tried the 915resolution utility by forcing Q965 as chipset, it shows me the resolutions and indeed there is 1600x900 missing. If i overwrite the 1600x1200 resolution with 1600x900 it makes no difference.
Comment 59 Oliver Pahl 2008-11-14 10:42:17 UTC
I installed XP and the NVidia Card is now working under Linux. Now i really can switch between cards but have to reboot to do so. But with the Stamina (Intel) Mode enabled i still get the red line and the garbled output afterwards.
Comment 60 Wang Zhenyu 2008-11-17 01:18:59 UTC
Created attachment 20364 [details] [review]
debug patch

Could you try this patch against current git master? First try starting X without external CRT attached.
Comment 61 Wang Zhenyu 2008-11-20 19:06:06 UTC
Created attachment 20484 [details] [review]
set LVDS reference divisor based on current block

Could you please try this patch against current git master?
Comment 62 Oliver Pahl 2008-11-23 20:08:38 UTC
Created attachment 20530 [details]
Failed to start X. No garbled screen, but lockup.

Upgraded to newest intel-git, mesa-git and drm. Applied the patch. X does not start, but a system lockup occurs.
Comment 63 Wang Zhenyu 2008-12-15 22:29:39 UTC
Oliver, it looks patch on bug #17292 works for some people, could you test that too? That's https://bugs.freedesktop.org/attachment.cgi?id=20365
Comment 64 Wang Zhenyu 2008-12-28 17:52:32 UTC

*** This bug has been marked as a duplicate of bug 17292 ***
Comment 65 Oliver Pahl 2009-01-20 06:30:04 UTC
Created attachment 22112 [details]
Xorg.0.log with Version 2.6.0 and patch applied

Tried the patch, does not work. Still the same effect. Tried with 2.5.1 and 2.6.0. The red line is persistent :( Sorry for the late reply, but i had to do my Bachelors work and so i had no time to try.
Comment 66 Oliver Pahl 2009-01-20 06:36:50 UTC
I also tried the other patch proposed to fix bug 17292, but that one did not help either. So i am reopening this Bug. Thank you.
Comment 67 Oliver Pahl 2009-01-20 12:33:57 UTC
Created attachment 22114 [details]
Xorg.0.log with Version 2.6.0 and patch applied without KMS

I saw that there is no Debug output if KMS is enabled, so i disabled it. I also applied the same hack used in bug 17292 and applied its principle to the KMS code in intel_bios.c changing it to the following: 

	panel_fixed_mode->hdisplay = (dvo_timing->hactive_hi << 8) |
		dvo_timing->hactive_lo;
	panel_fixed_mode->hsync_start = panel_fixed_mode->hdisplay +
		((dvo_timing->hsync_off_hi << 8) | dvo_timing->hsync_off_lo);
	panel_fixed_mode->hsync_end = panel_fixed_mode->hsync_start +
		dvo_timing->hsync_pulse_width;
	panel_fixed_mode->htotal = panel_fixed_mode->hsync_end +
		((dvo_timing->hblank_hi << 8) | dvo_timing->hblank_lo);

	panel_fixed_mode->vdisplay = (dvo_timing->vactive_hi << 8) |
		dvo_timing->vactive_lo;
	panel_fixed_mode->vsync_start = panel_fixed_mode->vdisplay +
		dvo_timing->vsync_off;
	panel_fixed_mode->vsync_end = panel_fixed_mode->vsync_start +
		dvo_timing->vsync_pulse_width;
	panel_fixed_mode->vtotal = panel_fixed_mode->vsync_end +
		((dvo_timing->vblank_hi << 8) | dvo_timing->vblank_lo);

Result sadly stays the same.
Comment 68 Wang Zhenyu 2009-01-20 22:18:24 UTC
(In reply to comment #66)
> I also tried the other patch proposed to fix bug 17292, but that one did not
> help either. So i am reopening this Bug. Thank you.
> 

Have you tried last patch on it? https://bugs.freedesktop.org/attachment.cgi?id=21910
Comment 69 Oliver Pahl 2009-01-21 00:36:36 UTC
Yes i did, the result stays the same. Also tried it on the KMS code as stated in my previous post.
Comment 70 Wang Zhenyu 2009-02-01 18:49:39 UTC
Does current master work for you?

Jesse's patch is
commit 57a02b50c60c10a25ff0f3cd93af9f37fa0d1b11
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Mon Jan 26 14:58:28 2009 -0800

    Fixup bogus VBT modes when detected
    
Comment 71 Michael Fu 2009-02-01 19:08:01 UTC
zhenyu, it seems that the fixed mode in Oliver's vbios is correct ( Htotal is > Hsync ), so Jesse's patch won't help...

In the mean time, check out the m,n,p1,p2 setting for pipe B, where the LVDS sit, between X startup and EnterVT... the mysterious spreadsheet has prove the setting used when X startup is the right combination to get the required frequency (100 Mhz dot clock). The dot clock doesn't change between X startup and EnterVT, while those parameters changed..  In order to get a given frequency, there is only one combination is right. Then the one our driver get via "calculation" is wrong, if it's not equal to the one used when X startup?
Comment 72 Wang Zhenyu 2009-02-01 19:51:04 UTC
Is there any difference for LVDS PLL setting in GM45 than pre chipsets?
Comment 73 Michael Fu 2009-02-01 20:49:59 UTC
no change, I think, thus I doubt if this is GM45 specific. If it's true, the problem seems persist for a while - If a LVDS panel by nature can only accept one dot clock (no matter what clock the modeline says, it's changed to the one of fixed mode in lvds_mode_fixup), maybe we shouldn't bother to change (m,n,p1,p2) in crtc_mode_set from the working case ( the one set by vbios ), unless we can get the same combination via calculation... 
Comment 74 Oliver Pahl 2009-02-14 01:10:01 UTC
After using the workaround described here: http://thinkfat.blogspot.com/2009/02/sony-vaio-z21-news-switching-off-nvidia.html (replacing the sony-laptop module) the Intel card initializes and I have a screen and can work normally. But as soon as the Monitor enters any standby mode and resumes the red line is back.
Comment 75 Wang Zhenyu 2009-02-15 18:57:21 UTC
So if we want intel graphics to work, we have to disable NV completely, that's the theory right? Does any _DSM method should be called after you left standby? 

Could you send your acpidump output? Our acpi guys might be interested to look at. 
Comment 76 ykzhao 2009-02-15 21:38:23 UTC
Hi, Oliver
    Do you mean that the Intel graphics can work if the _DSM object is evauated for the nvidia card? Right? 
    In fact the _DSM object is only to enable/disable the device's wakeup capability from the sleeping state. And it can't enable/disable the corresponding device.
    
    Will you please attach the output of acpidump, lspci -vxxx?
    It will be great if you can check whether the nvidia card can be disabled in BIOS option.
    thanks.
Comment 77 Oliver Pahl 2009-02-16 05:10:45 UTC
Created attachment 22978 [details]
acpidump output

The acpidump output.
Comment 78 Oliver Pahl 2009-02-16 05:11:33 UTC
Created attachment 22979 [details]
lspic -vxxx output

Output of lspci -vxxx
Comment 79 Oliver Pahl 2009-02-16 05:14:30 UTC
The acpidump as well as the lspci were done after loading the sony-laptop module with the previously mentioned patch applied.
The BIOS like all sony BIOSes has not much settings. There is no setting to disable any of the two Cards.
Comment 80 Michael Fu 2009-02-22 22:45:54 UTC
(In reply to comment #74)
> After using the workaround described here:
> http://thinkfat.blogspot.com/2009/02/sony-vaio-z21-news-switching-off-nvidia.html
> (replacing the sony-laptop module) the Intel card initializes and I have a
> screen and can work normally. But as soon as the Monitor enters any standby
> mode and resumes the red line is back.
> 

would you pls help to post a reg_dump after you get it works via the workaround?
Comment 81 zhang rui 2009-02-23 23:44:51 UTC
interesting.
ACPI only defines the _OFF method for a power resource device.
How/when to use the _OFF method for a regular device is not stated in the ACPI spec 3.0.

what if you don't invoke _DSM? does this workaround still work?

about the resume problem, what if you call _OFF again after resume?

Comment 82 Wang Zhenyu 2009-03-01 21:26:08 UTC
Rui, maybe you can make a debug patch for Oliver? or from you analysis is it possible in gfx driver to workaround this?
Comment 83 Oliver Pahl 2009-03-05 07:40:41 UTC
Hi, 
sorry again for the delay :( But my setup is not working again. After posting i found out, that the fix is not working every time. it only works on one out of ten occasions. I dont get it.
Does anyone know what could cause this?
Thanks
Comment 84 MaLing 2009-03-06 22:35:33 UTC
Created attachment 23602 [details] [review]
hi Oliver please try this patch on your machine,thanks.

before entering X, pll parameter of bios pll seting are n = 2, m1 = 19, m2 = 5, p1 =2, p2 = 14, however driver change it as n = 3, m1 = 10, m2 = 8, p1 = 1 , p2  =14 although their clock are both 100M, please try it.
Thanks
Ma Ling
Comment 85 Oliver Pahl 2009-03-09 15:23:42 UTC
Hi,
i applied the patch to the current trunk, but it does not change the behavior. If you need any logs or dumps, let me know.
Comment 86 MaLing 2009-03-09 18:21:19 UTC
(In reply to comment #85)
> Hi,
> i applied the patch to the current trunk, but it does not change the behavior.
> If you need any logs or dumps, let me know.

yes, could you please upload log file with Modedebug option on.

Thanks
Ma Ling
Comment 87 Wang Zhenyu 2009-03-09 18:28:49 UTC
I think this one does need help from acpi side, to give us the capability to switch between intel and nv card, it looks they can't be enabled in meanwhile. Oliver, have  you tried any custom dsdt hack yet?
Comment 88 Oliver Pahl 2009-03-09 23:54:17 UTC
I tried. I disassembled my dsdt, repaired it, changed the OSYS Var to "Windows 2006". Otherwise i dont know how to hack specifics in the it. I'll upload the ModeDebug log in the afternoon.
Comment 89 zhang rui 2009-03-10 00:24:44 UTC
hi, all

it seems that some works are already done for this issue. 
http://archive.netbsd.se/?ml=xorg&a=2009-02&t=9908058

Oliver,
Could you please try the latest sony-laptop driver and see if it helps in your case please?

I don't know if this (invoking _DSM) is the right direction, and I'll kick off a discussion about this in the mail list.
Comment 90 Oliver Pahl 2009-03-10 02:29:53 UTC
Hi,
i tried the module already, yielded the same result. I am not sure, that this is the definitive answer. While it enables to use the NVidia Card in my case, by switching, the card itself is not deactivated properly. Only the second intel PCI Entry disappears (0:02.1).
Comment 91 Oliver Pahl 2009-03-10 04:35:26 UTC
Hello,
something strange happend. If I switch to stamina mode with the module i get the red line. But if i switch to speed, and then to stamina again, it works. I really do not get it...
Comment 92 zhang rui 2009-03-10 20:08:06 UTC
Oliver,
How do you switch between them?
and the problem only happens when you enable the Intel graphics card and disable the nvidia one, right?
Comment 93 Oliver Pahl 2009-03-11 00:00:09 UTC
Hi,
found out yesterday by trial and error, that it only works with the patch from MaLing applied to the master branch. Without it i get the red Line anyways. The procedure is as follows. With the modified sony-laptop module i can switch between the cards (no real switch though, but ACPI hack, as explained in the link you gave a few posts back). To make it work i have to activate the nvidia card first, then I have to switch to the intel card, then and only then X starts up okay.
Comment 94 Wang Zhenyu 2009-03-12 09:11:42 UTC
lower priority. 

Rui suggested we could add that fix for linux sony_acpi module. And Ling's patch would be commited after some cleanups.
Comment 95 Michael Fu 2009-03-17 00:11:51 UTC
summary: 

- Ling's patch has been checked in as fix for bug# 17805
- the other issue is about ACPI. it's been fixed in sony-acpi module.

so, I'm closing this bug.
Comment 96 Oliver Pahl 2009-03-22 09:09:24 UTC
Sorry to report a followup to this bug, but i dont know if i should open a new one. With the current Master X starts fine, but as soon as i open any app i get artifacts all over the screen. If I move a window, the artifacts are moved to.