Bug 17927

Summary: [965GM] TV Out is not detected on Thinkpad R61i
Product: xorg Reporter: c4pp4
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: 7.3 (2007.09)   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg.0.log none

Description c4pp4 2008-10-06 07:57:39 UTC
Created attachment 19409 [details]
Xorg.0.log

Can you please help me with it?
(It works with WinXP)

Thinkpad R61i Type 8932-9ZG
Ubuntu 8.04.1
Intel driver 2.2.1

$ lspci -vvnn | grep -A1 "VGA compat"
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Unknown device [17aa:20b5]

$ lspci -vvnn | grep -A1 "Display"
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
	Subsystem: Lenovo Unknown device [17aa:20b5]

$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+   60.0     50.0  
   1280x768       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9
Comment 1 c4pp4 2008-10-06 11:03:08 UTC
Maybe the problem is here:

file: src/i830_quirks.c

/* Lenovo T61 has no TV output */
{ PCI_CHIP_I965_GM, 0x17aa, 0x20b5, quirk_ignore_tv },
Comment 2 c4pp4 2008-10-06 19:31:06 UTC
I think it's similar like here: https://bugs.freedesktop.org/show_bug.cgi?id=14432
Comment 3 Gordon Jin 2008-10-07 06:14:41 UTC
Yes, it looks similar. So reassign to Zhenyu.
Comment 4 Wang Zhenyu 2008-10-08 18:11:57 UTC
You can simply try removing that quirk line, which we should do. As I believe current video bios data parsing already give us the right answer.
Comment 5 Wang Zhenyu 2008-10-08 18:28:00 UTC
Removed that one in master now. 

commit 4128b01ec84ffa0f03c335c36738f383376d9381
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Thu Oct 9 09:19:41 2008 +0800

    Remove Lenovo T61 TV quirk
    
    BIOS already says no integrated TV, and this quirk blocks TV
    on R61i which has the same subdevice id as T61.
Comment 6 c4pp4 2008-10-13 11:35:12 UTC
Thank you very much, it works!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.