Bug 18423

Summary: Changing my keys
Product: gstreamer Reporter: Thiago Sousa Santos <thiagoss>
Component: accountAssignee: Thomas Vander Stichele <thomas>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium CC: uraeus
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments: The ssh pub key.
GPG Pub Key

Description Thiago Sousa Santos 2008-11-07 02:53:18 UTC
I recently got my account created, but I couldn't login as I forgot the passphrase for accessing my ssh keys. As I couldn't send my gpg keys to the server, I'm unable to change them (AFAIK). So I'm sending a new ssh and gpg keys.
Comment 1 Thiago Sousa Santos 2008-11-07 02:54:36 UTC
Created attachment 20126 [details]
The ssh pub key.

My ssh pub key.
Comment 2 Thiago Sousa Santos 2008-11-07 02:59:26 UTC
Created attachment 20127 [details]
GPG Pub Key

I couldn't send it to server, it gives timeout.
Comment 3 Thomas Vander Stichele 2008-11-09 06:49:36 UTC
Are you sure you already have an account ? I can't find it.  What is your login name ?

There is a thiago login, but that's a different person.


Also, the whole point of using GPG is to make sure we can trust that you are who you say you are.

Right now I have no basis to trust that the person who created this ticket is Thiago.  Or put in a different way, if someone wants to steal your account, it's simple to create a ticket here and attach ssh and GPG key, and ask for a key change.

You need to upload your gpg key to a known and trusted keyserver.  There are various ones, so you can choose which one.

Please reassign to me when you've mentioned your account name and some way for me to get your GPG key.
Comment 4 Thomas Vander Stichele 2008-11-09 06:52:46 UTC
*** Bug 17396 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Vander Stichele 2008-11-09 06:55:26 UTC
Looks like you asked for one before, but that didn't get created.
Comment 6 Thomas Vander Stichele 2008-11-09 06:57:01 UTC
reassign to me when you provided the info please
Comment 7 Christian Schaller 2008-11-18 09:13:58 UTC
Thiago you need to tell thomas what account name you want for him to create you an account. Seems the problem with your earlier log in was simply that we assume the 'thiago' account was yours.

As for putting your gpg into a server, this one seems to be active:
http://pgpkeys.pca.dfn.de/

Most of these pgpkey servers seems to be more offline than online though.
Comment 8 Thiago Sousa Santos 2008-11-18 09:48:17 UTC
I've just tried this one and it works! Key is there.

Real name: Thiago Sousa Santos
Account: thiagoss
email: thiagoss@embedded.ufcg.edu.br
Comment 9 Christian Schaller 2008-11-18 10:14:42 UTC
Great news, I will close this as fixed then :)
Comment 10 Thiago Sousa Santos 2008-11-20 03:19:46 UTC
I'll reopen this, my account has not been created, only me gpg key that has been  uploaded to a keyserver.
Comment 11 Thiago Sousa Santos 2008-11-20 04:44:11 UTC
By the way, I used http://pgpkeys.pca.dfn.de/ as the keyserver. I'm reassigning the bug to thomassvs
Comment 12 Thomas Vander Stichele 2008-11-22 01:59:40 UTC
Account created, reopen if there is some problem.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.