Bug 19127

Summary: [GM965] Infinite loop in intel_batch_flush
Product: xorg Reporter: Ari Entlich <lmage11>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED INVALID QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium Keywords: NEEDINFO
Version: git   
Hardware: Other   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
X log
none
Another X log (with ModeDebug)
none
Yet another X log none

Description Ari Entlich 2008-12-16 20:47:38 UTC
Created attachment 21226 [details]
X log

Got this during random usage, I think I was trying to open a feed in Firefox's Feed Sidebar extension. Nothing relevant in kernel log.

I'm terribly sorry if this was already fixed or isn't relevant anymore, as I was running http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=768f317cf0da4cd6682af2e71e71c3e130e05182 . 

Is there something I could do to get better backtraces from the server? Would compiling it with debugging info help?
Comment 1 Gordon Jin 2008-12-16 23:17:30 UTC
You could refer to http://intellinuxgraphics.org/how_to_report_bug.html:
-- Provide gdb backtrace. See the guide for how to use gdb for X server crash

Are you able to stably reproduce this? Do you have a driver version with which it works fine?
Comment 2 Wang Zhenyu 2008-12-17 00:39:02 UTC
You need to upgrade to latest git and test again, kernel, drm, xf86-video-intel, etc.
Comment 3 Ari Entlich 2008-12-17 06:59:24 UTC
I've put ModeDebug in my xorg.conf. Unfortunately, I don't think I can get a gdb backtrace most of the time, because the X server is frozen and I can't switch to a text VT. I can try to have ssh running more of the time, so that I can remote into my laptop, but that's the only situation in which I could do it.

No, I don't currently have a reliable way of reproducing this, but I thought it'd be good to have a bug to track the problem nonetheless.

I'll try to only report bugs against latest git versions in the future, but since there's no clear evidence that this has been fixed, I don't think it should be closed.
Comment 4 Ari Entlich 2008-12-17 08:40:25 UTC
Hit this again. I'll recompile with debugging info and start up sshd so I can get a backtrace next time.

Log forthcoming.
Comment 5 Ari Entlich 2008-12-17 08:41:26 UTC
Created attachment 21245 [details]
Another X log (with ModeDebug)
Comment 6 Ari Entlich 2008-12-17 21:08:44 UTC
Created attachment 21261 [details]
Yet another X log

And again... *sigh* I'll get a real backtrace on this at some point, I swear.

I don't know if this means anything, but I seem to be getting this a lot while using Openoffice Writer.
Comment 7 Wang Zhenyu 2008-12-28 23:07:11 UTC
any update? I have no idea what the problem might be with current info.
Comment 8 Ari Entlich 2008-12-29 15:50:19 UTC
It could be that this was caused by trying to use intelfb along with everything else. I'll have to do some more testing.
Comment 9 Ari Entlich 2008-12-29 15:54:43 UTC
Oh, and I was able to log in remotely via ssh at one point when I hit this problem, but gdb was being retarded so I couldn't get a backtrace. Sorry. :(
Comment 10 Wang Zhenyu 2009-01-12 00:06:15 UTC
Is this still there with recent updates? 2.5.99.2 has been released and for testing.
Comment 11 Wang Zhenyu 2009-02-01 19:01:19 UTC
ping? Does this happen with 2.6.1?
Comment 12 Wang Zhenyu 2009-02-08 18:41:10 UTC
Ari, I assume you don't see this issue now, so close, feel free to open if you still can see it and provide more info.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.