Bug 19172

Summary: 2.5.99.1 doesn't work with UXA on 2.6.27.10
Product: xorg Reporter: Lukasz Jernas <deejay1>
Component: Driver/intelAssignee: Gordon Jin <gordon.jin>
Status: RESOLVED NOTABUG QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg server log
none
Xorg log none

Description Lukasz Jernas 2008-12-19 01:25:37 UTC
When trying to run 2.5.99.1 with todays libdrm on xserver 1.5.3 with kernel 2.6.27.10 I can only get a working KDE 4.2 beta environment with XAA or EXA (hmm, the latter seems to work while I write this, weird) enabled.
Chipset is Intel 852/855GM. With UXA I can get a plain xsession, run x11perf -aa10text or glxgears but kdm reboots the server constantly ending with a permanent system unavailability.
Logs attached
Comment 1 Lukasz Jernas 2008-12-19 01:26:34 UTC
Created attachment 21294 [details]
Xorg server log
Comment 2 Lukasz Jernas 2008-12-19 01:27:02 UTC
Created attachment 21295 [details]
Xorg log
Comment 3 Gordon Jin 2008-12-19 22:21:34 UTC
UXA needs GEM kernel, i.e. 2.6.28 (or current -rc).

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.