Bug 1988

Summary: Xwindows freeze-out
Product: LTSP Reporter: Premysl Hruby <prema.h>
Component: LTSP CoreAssignee: Jim McQuillan <jam>
Status: RESOLVED NOTABUG QA Contact:
Severity: critical    
Priority: highest    
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Premysl Hruby 2004-12-02 02:04:46 UTC
Sometimes Xserver on Diskless-terminal freeze-out without any corelations with
work on it. It doesn't response even on the Zap-signal (Ctrl-Alt-BkSpace) or
keyboard switching on text console, mouse or keyboard doesn't work at all, too. 
But I can remotely login over telnet to this diskless and kill the Xserver, it
reopen and to the next freeze-out it work fine.

I have standard LTSP 4.1 instalation without any changes in packages.

Thanks for help,
prema
Comment 1 Jim McQuillan 2005-09-11 07:36:39 UTC
This is almost certainly caused by running out of ram on the client.  The
Xserver becomes unstable when it fails to get memory from an allocation request.
 In many cases, it'll just kill the Xserver.  other times, it will lock up the
screen.
Turning on NFS-SWAP in the lts.conf file (see lts.conf.readme) for more info can
often make this problem go away.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.