Bug 20628

Summary: sudden change of resolution to 320x200
Product: xorg Reporter: Elmar Stellnberger <estellnb>
Component: Driver/radeonhdAssignee: Luc Verhaegen <lverhaegen>
Status: RESOLVED WONTFIX QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg log
none
xrandr --prop, erroneous self-screen-reconfig
none
xrandr --prop, normal operation
none
xorg.conf
none
Xorg.0.log: both screens turn and stay dark instead of one none

Description Elmar Stellnberger 2009-03-12 09:25:24 UTC
Suddenly while playing a video with mplayer the screen resolution has changed from 1920x1200 - 1920x1200, xinerama to 320x200 - 320x200, clone mode at pressing Ctrl-C. Reconfiguring the screen with xrandr failed. Had to restart the X server. The bug is so far non reproducible. However I have posted the available log files.

> xrandr --output DVI-D_1 --off
xrandr: Configure crtc 0 failed
> xrandr --output DVI-D_1 --right-of PANEL
xrandr: Configure crtc 0 failed
> xrandr --output DVI-D_1 --mode 1920x1200
xrandr: Configure crtc 0 failed
Comment 1 Elmar Stellnberger 2009-03-12 09:27:54 UTC
Created attachment 23798 [details]
Xorg log
Comment 2 Elmar Stellnberger 2009-03-12 09:28:50 UTC
Created attachment 23799 [details]
xrandr --prop, erroneous self-screen-reconfig
Comment 3 Elmar Stellnberger 2009-03-12 09:29:54 UTC
Created attachment 23800 [details]
xrandr --prop, normal operation
Comment 4 Elmar Stellnberger 2009-03-12 09:31:03 UTC
Created attachment 23801 [details]
xorg.conf
Comment 5 Elmar Stellnberger 2009-03-24 02:21:07 UTC
reproducible by starting supertux in xinerama mode.
Comment 6 Elmar Stellnberger 2009-08-23 13:10:56 UTC
Lately a similar error message occured when trying to re-enable one of two screens having been disabled previously:
> xrandr --output PANEL --mode 1920x1200;
xrandr: Configure crtc 0 failed
> xrandr --output DVI-D_1 --mode 1920x1200 --right-of PANEL;
xrandr: Configure crtc 0 failed

If the 'Configure crtc 0' error occurs once it is from that point on not possible any more to change anything about the screen settings. When doing a few reconfiguration as f.i. for game playing I run quite often into that mess. Looks like some kind of corruption of an internal data structure on subsequent crtc reconfigurations.
Comment 7 Elmar Stellnberger 2009-08-23 13:13:12 UTC
Created attachment 28870 [details]
Xorg.0.log: both screens turn and stay dark instead of one

After trying to re-enable the second screen both screens stayed dark. It was not possible to reenable any of them.
Comment 8 Jeremy Huddleston Sequoia 2011-10-16 15:57:25 UTC
Does this issue occur with the preferred ati driver (xf86-vide-ati)?  If so, please move this to the Driver/Radeon component.  

Development of radeonhd has pretty much halted and development focus is on the ati driver.  Please see http://www.x.org/wiki/radeonhd

If the issue does not exist in the ati driver (or if there is no response to this message), this bug will be closed as WONTFIX unless someone contributes a patch.
Comment 9 Jeremy Huddleston Sequoia 2011-11-07 15:37:45 UTC
Closing due to lack of response.  Please reopen and move to the Driver/Radeon 
component if this issue persists with xf86-video-ati

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.