Bug 20680

Summary: Couldn't execute command: gpk-update-viewer2
Product: PackageKit Reporter: Michal Nowak <mnowak>
Component: GeneralAssignee: Richard Hughes <richard>
Status: RESOLVED NOTOURBUG QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Michal Nowak 2009-03-16 02:43:33 UTC
Select "Show updates" from gpk-u-icon, results in:


[...]
TI:10:37:03	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name,220
 - setting icon name pk-update-normal
TI:10:37:03	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_get_update_policy,659
 - '/apps/gnome-packagekit/auto_update' gconf key is null!
TI:10:37:03	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_query_updates,793
 - policy unknown
TI:10:37:03	TH:0x22fa6f0	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,270
 - rescan
TI:10:37:03	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name,220
 - setting icon name (null)
TI:10:37:03	TH:0x22fa6f0	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,144
 - refresh tooltip 0
TI:10:37:03	TH:0x22fa6f0	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,183
 - nothing to show
TI:10:37:03	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_pulse_timeout_cb,113
 - polling check
TI:10:37:03	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_pulse_timeout_cb,117
 - not pulsing as icon cleared
TI:10:37:03	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name_cb,178
 - polling check
TI:10:37:04	TH:0x22fa6f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name_cb,178
 - polling check
TI:10:37:14	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_activate_update_cb,355
 - icon left clicked
TI:10:37:17	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_activate_update_cb,355
 - icon left clicked
TI:10:37:19	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_activate_update_cb,355
 - icon left clicked
TI:10:37:21	TH:0x22fa6f0	FI:gpk-check-update.c	FN:gpk_check_update_menuitem_show_updates_cb,339
 - Couldn't execute command: gpk-update-viewer2
`--^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^


There's no such command, but ``gpk-update-viewer'' is.
Comment 1 Richard Hughes 2009-03-16 03:14:00 UTC
You need to update the gnome-packagekit package. Thanks.
Comment 2 Michal Nowak 2009-03-16 03:29:55 UTC
Umm. Right, I updated to gnome-packagekit-0.4.5-3.fc11.x86_64 and it's OK now. Thanks.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.