Bug 20726

Summary: [945GM] intel driver segfaults if xorg.conf refers to not connected external VGA monitor
Product: xorg Reporter: Peter Lewis <pete>
Component: Driver/intelAssignee: Wang Zhenyu <zhenyu.z.wang>
Status: RESOLVED INVALID QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
xorg.0.log with intel driver backtrace none

Description Peter Lewis 2009-03-18 08:52:16 UTC
If, in xorg.conf, a Monitor section refers to the external VGA output, and it is not connected, then the intel driver segfaults and X does not start.

Steps to reproduce:

1. Ensure that there is no monitor connected to the external VGA port
2. Include a section in xorg.conf such as:
Section "Monitor"
        Identifier "VGA"
        Option "Above" "LVDS"
EndSection
3. Start X

Doing this, I received the backtrace as attached in xorg.0.log.

This may be related to bug 20725, since both appear to be about the inability of the intel driver to disable the external output (whether requested to explicitly, or through its non presence).

Other info requested:

% uname -m
i686

% pkg-config --modversion libdrm
2.3.1

Mesa version 7.2

XServer 1.5.3

intel driver version 2.4.3

Any more info needed, just let me know :-)
Comment 1 Peter Lewis 2009-03-18 08:52:54 UTC
Created attachment 23997 [details]
xorg.0.log with intel driver backtrace
Comment 2 Wang Zhenyu 2009-03-22 09:09:47 UTC
I can't produce this with current intel driver master and xserver 1.6. Could you try them?
Comment 3 Wang Zhenyu 2009-03-22 22:55:55 UTC
For none modes output, xserver will skip output relative check for it, so this shouldn't happen.

Please try with latest stable release, reopen if you can still see this.
Comment 4 Peter Lewis 2009-04-02 05:54:40 UTC
Yep, confirming that this is fixed in latest version.

Thanks!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.