Bug 25779

Summary: Crash in radeon using the drm-radeon-testing branch of drm-next
Product: DRI Reporter: Kevin DeKorte <kdekorte>
Component: DRM/RadeonAssignee: Default DRI bug account <dri-devel>
Status: RESOLVED NOTOURBUG QA Contact:
Severity: normal    
Priority: medium    
Version: DRI git   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg log with error at bottom none

Description Kevin DeKorte 2009-12-23 06:51:26 UTC
[drm] TMDS-9: set mode 1680x1050 26
executing set pll
executing set crtc timing
[drm] TMDS-15: set mode 1280x1024 28
Console: switching to colour frame buffer device 160x64
fb0: radeondrmfb frame buffer device
registered panic notifier
[drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
dracut: Starting plymouth daemon
BUG: unable to handle kernel NULL pointer dereference at 0000000000000080
IP: [<ffffffffa0089a28>] atombios_crtc_set_base+0x64/0x5ab [radeon]
PGD 213ff7067 PUD 2135c2067 PMD 0 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/kernel/uevent_seqnum
CPU 1 
Modules linked in: radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core
Pid: 186, comm: plymouthd Not tainted 2.6.32 #10 P5E-VM HDMI
RIP: 0010:[<ffffffffa0089a28>]  [<ffffffffa0089a28>] atombios_crtc_set_base+0x64/0x5ab [radeon]
RSP: 0018:ffff880213f7db88  EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffff880213761000 RCX: ffff880213f22540
RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880213761000
RBP: ffff880213f7dbe8 R08: 000000000000000e R09: ffff880213762000
R10: ffff880213762008 R11: ffff880213fcbe40 R12: 0000000000000000
R13: ffff880213760000 R14: 0000000000000000 R15: ffff880210d8e201
FS:  00007fdc8f5d1700(0000) GS:ffff880028280000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000080 CR3: 0000000213f47000 CR4: 00000000000006e0
After using git pull --rebase and rebuilding the git tree at 9cb5af651634bc2dcc68b58a949a67c251ae222a

I would boot the kernel and get this crash.

I also rebuild libdrm and xf86-video-ati at the same time. Reverting to an earlier kernel is fine.



DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process plymouthd (pid: 186, threadinfo ffff880213f7c000, task ffff88021375c5f0)
Stack:
 0000000000000001 ffff880213e07218 000000001344dc00 ffff880213f22540
<0> 0000000000000009 ffff88021344dc08 ffff880213f7dbe8 ffffffffa00c2d70
<0> ffff88021366b000 ffff88021366b328 0000000000000000 ffff880210d8e201
Call Trace:
 [<ffffffffa0052cc6>] drm_crtc_helper_set_config+0x62f/0x778 [drm_kms_helper]
 [<ffffffffa0024a65>] drm_mode_setcrtc+0x2d2/0x301 [drm]
 [<ffffffffa0022a9f>] ? drm_mode_object_find+0x56/0x65 [drm]
 [<ffffffffa0024793>] ? drm_mode_setcrtc+0x0/0x301 [drm]
 [<ffffffffa00191ea>] drm_ioctl+0x237/0x2f5 [drm]
 [<ffffffff812a502b>] ? tty_ioctl+0x7af/0x7ce
 [<ffffffff81123c4d>] vfs_ioctl+0x6f/0x87
 [<ffffffff8112415c>] do_vfs_ioctl+0x47b/0x4c1
 [<ffffffff811241f8>] sys_ioctl+0x56/0x79
 [<ffffffff81011cb2>] system_call_fastpath+0x16/0x1b
Code: 13 d1 0c a0 48 c7 c2 b0 2d 0c a0 48 c7 c6 20 d1 0c a0 bf 01 00 00 00 45 31 f6 e8 cd 38 f9 ff e9 3c 05 00 00 48 8b 80 a8 00 00 00 <4c> 8b b8 80 00 00 00 4c 89 ff e8 20 ff ff ff 85 c0 41 89 c6 0f 
RIP  [<ffffffffa0089a28>] atombios_crtc_set_base+0x64/0x5ab [radeon]
 RSP <ffff880213f7db88>
CR2: 0000000000000080
---[ end trace b0de8d06b46486f0 ]---
dracut: error: unexpectedly disconnected from boot status daemon
Comment 1 Kevin DeKorte 2009-12-23 08:14:36 UTC
Card is an rv635 card

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 01da
	Flags: bus master, fast devsel, latency 0, IRQ 29
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at fe9e0000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at d000 [size=256]
	[virtual] Expansion ROM at fe900000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon
Comment 2 Kevin DeKorte 2010-01-04 08:35:31 UTC
Trying drm-radeon-testing + this patch http://thread.gmane.org/gmane.linux.kernel/930448
Comment 3 Kevin DeKorte 2010-01-04 09:52:20 UTC
After applying the patch and booting into the new kernel, I still get a black screen on boot and the same drm crash. I can SSH into the box, but the local display is dead.
Comment 4 Kevin DeKorte 2010-01-04 10:27:46 UTC
Created attachment 32440 [details]
Xorg log with error at bottom
Comment 5 Kevin DeKorte 2010-01-05 14:28:30 UTC
Finally figured out that crash was caused by an out of date plymouth. Rebuilt current plymouth that uses new libdrm api and machine booted properly.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.