Bug 30529

Summary: With compiz enabled everything on extended display is shifted to the left by 128 pixels
Product: xorg Reporter: Lukasz Kurylo <Lukasz.Kurylo>
Component: Driver/intelAssignee: Carl Worth <cworth>
Status: RESOLVED DUPLICATE QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
Note that black stripe on the right side of the monitor. none

Description Lukasz Kurylo 2010-10-01 00:53:25 UTC
Created attachment 39096 [details]
Note that black stripe on the right side of the monitor.

I have Notebook with LVDS1:1680x1050 display and external monitor VGA1:1920x1200.
After enabling compiz in kwin everything on that extended VGA1 display (arranged on the right of LVDS1) gets shifted to the left by 128 pixels (left most part is missing), mouse cursor is OK. I believe that this issue is caused by the lack on copy-fb patch in the latest packaged versions of the driver.

xserver-xorg-video-intel (2:2.12.0-1ubuntu5) is OK
xserver-xorg-video-intel (2:2.12.902+git20100930.345c963e-0ubuntu0sarvatt) is BAD

I did git bisect between latest git and 2.12.0 (vanilla) and it was always BAD.

My conclusion is that one of the patches in 2:2.12.0-1ubuntu5 was fixing this.
Comment 1 Chris Wilson 2010-10-01 01:53:24 UTC
commit 52e68630d13f9668f8f4dd6978fa41039bacfaf6
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Aug 8 10:15:59 2010 +0100

    drm/i915: Fix offset page-flips on i965+
    i965 uses the Display Registers to compute the offset from the display
    base so the new base does not need adjusting when flipping. The older
    chipsets use a fence to access the display and so do perceive the
    surface as linear and have a single base register which is reprogrammed
    using the flip.
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: Jesse Barnes <jbarnes@virtuousgeek.org>
    Reported-by: Marty Jack <martyj19@comcast.net>
    Reviewed-by: Jesse Barnes <jbarnes@virtuousgeek.org>

*** This bug has been marked as a duplicate of bug 30295 ***