Bug 31354

Summary: Message that JRE is missing and required pops up multiple times on first run
Product: LibreOffice Reporter: Larsen <larsen007>
Component: LibreofficeAssignee: Stephan Bergmann <sbergman>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium CC: arudzki, celeonar, clemty, GcHoyman, kendy, LibreOffice, michael.meeks, musikit, r0polach, ssanders
Version: 3.3.0 release   
Hardware: All   
OS: Windows (All)   
Whiteboard:
Bug Depends on:    
Bug Blocks: 38046    

Description Larsen 2010-11-03 05:05:00 UTC
On first start, there is a message that a JRE is needed. This dialog pops up multiple times. I also had one case where I opened a ODF file and had to click away that dialog for about a hundred times (seriously!)
Comment 1 Rene Engelhard 2010-11-03 06:42:35 UTC
see also http://bugs.debian.org/602127
Comment 2 Cesare Leonardi 2010-11-21 09:58:58 UTC
To help in the goal of reducing Java dependency, i want to add some information to this bug report.

I talk about a Windows 2000 Pro SP4 environment, without Java installed (there is a 1.3.1 version needed by a printer, but it's ignored by LO).
As described in this bug, only the first time LO starts after the setup there are several messages that pops up saying that JRE is required. They shows up interrupting the splash screen, but thanks to the progressing text i can report when these errors appears:
-----
Abilitazione in corso: Language Tool. Open source language checker
Abilitazione in corso: Presenter console
Abilitazione in corso: ReportBuilder
Abilitazione in corso: Solver for Nonlinear Programming
Abilitazione in corso: Spelling and hypenation dictionary for Danish + Danish thes...
Abilitazione in corso: Wiki Publisher
-----

During the "Nonlinear programming" message the JRE message apperars two times.

Every further LO startings doesn't trigger the JRE messages.
You have to delete the Libreoffice folder under %APPDATA% to trigger them again.

I also wonder why LO try to load "Spelling and hypenation dictionary for Danish + Danish thesaurus", since i asked for the italian langpack, but perhaps it's another bug.

Cesare.
Comment 3 Rainer Bielefeld Retired 2010-11-23 10:40:21 UTC
[Reproducible] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]". I frequently get this message, more often wen my PC is under heavy load. Additionally it seems that a restart after a crash without document recovery can rise No of those messages. Sometimes I can click it away easily, sometimes I closed LibO with Task manager (may be 100 clicks on <ok> would have worked, too.
Although it seems that the problem seems not to cause heavy damages, I see it more serious than "trivial". But I don't think that it's a 3.3 blocker.
Comment 4 Cesare Leonardi 2010-12-06 16:42:10 UTC
For me the JRE needed messages on startup seems gone with 3.3.0rc1 (Win2000 SP4).

Cesare.
Comment 5 Rainer Bielefeld Retired 2010-12-06 20:59:20 UTC
(In reply to comment #4)
I don't think so, yesterday I saw it when I pressed the auto spell check button.
Comment 6 Cesare Leonardi 2010-12-07 08:35:07 UTC
I wrongly recalled that this bug report talked only about the startup phase.
For the start seems resolved, for the rest, yes, the messages continue to appear in many places. For example as soon i open every ODS document.

Me too have the impression that many of them are related to spell check.

Cesare.
Comment 7 Rainer Bielefeld Retired 2010-12-07 11:27:10 UTC
I haven't seen the MULTIPLE messages problem for several time, but u useless message I also frequently see changing UI language in 'Tools -> Options -> Language settings'
Comment 8 gatocl.maipu 2010-12-23 17:04:25 UTC
In my case the problem was in the at least finish of the instal of the LOrc2, the installer get stuck and the java related popup are in the background and silent.
When its happen to you how much time the popup are showed, for me is like the installer crash, only weith the "proccess explorer" i find it was java related
Comment 9 Don't use this account, use tml@iki.fi 2011-03-06 23:31:02 UTC
*** Bug 35074 has been marked as a duplicate of this bug. ***
Comment 10 Don't use this account, use tml@iki.fi 2011-03-06 23:35:55 UTC
Kendy, I vaguely remember you would have tried to make this message appear only once, am I mistaken?
Comment 11 hennr 2011-06-25 02:59:35 UTC
*** Bug 35769 has been marked as a duplicate of this bug. ***
Comment 12 vitriol 2011-09-02 04:02:51 UTC
*** Bug 40574 has been marked as a duplicate of this bug. ***
Comment 13 vitriol 2011-10-03 21:32:20 UTC
*** Bug 41434 has been marked as a duplicate of this bug. ***
Comment 14 Björn Michaelsen 2011-12-23 11:34:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 15 Larsen 2011-12-24 02:16:48 UTC
I did a fresh install of LOdev 3.5.0 on a Windows VM with no Java installed (with all components set to be installed). The message about the missing JRE popped up three times, but as the splash screen wasn´t visible at that time, I cannot say which components caused this.
Comment 16 Rainer Bielefeld Retired 2011-12-24 03:11:11 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Thank you for 3.5 Review!
Comment 17 Cesare Leonardi 2011-12-24 10:26:00 UTC
(In reply to comment #15)
> I did a fresh install of LOdev 3.5.0 on a Windows VM with no Java installed

Me too.
Windows7, no Java installed and on the first LO startup i see multiple JRE missing messages.
Comment 18 Liang Yi 2012-01-04 02:36:35 UTC
I hope a link is provided with the error to download the correct version of JRE.
I even can't find it on LibreOffice's home page now!
Comment 19 Larsen 2012-01-04 03:02:27 UTC
The JRE is provided by Oracle, not by LibreOffice.
You can download it here: http://www.java.com/en/download/
Comment 20 Rainer Bielefeld Retired 2012-01-17 14:01:01 UTC
Still [Reproducible] with "LibreOffice 3.4.5 - German UI [Build ID: OOO340m1 (Build:502)]" WIN XP in VirtualBox an first launch while splash screen was visible. Later launches were not affected.
I doubt that there are many PC without JRE, but most people who see that as first experience with LibO will stop trying LibO at this point - IMHO

@Larsen:
The problem is not that WE do not know how to get Java on the PC.
Comment 21 Larsen 2012-01-19 01:10:13 UTC
@Rainer: That was to help Liang Yi from comment 18
Comment 22 Asa Dotzler 2012-02-18 18:42:32 UTC
At a bare minimum, the text of this warning message needs to be adjusted to note that it is not a hard requirement.
Comment 23 Björn Michaelsen 2012-02-19 03:27:48 UTC
mmeeks already working hard on this.
Comment 24 Michael Meeks 2012-02-20 02:42:53 UTC
Already fixed on master; awaiting review from Stephan to back-port to 3.5.1
Comment 25 Stephan Bergmann 2012-02-20 04:41:11 UTC
Improved mmeeks' original fix now on master with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=55892c6bd740fa0c667656cbb246327f2bb76007> "Clean up work around spurious warning about missing JRE."
Comment 27 dd98 2012-03-14 22:34:32 UTC
On a clean Windows 7 machine I got the "JRE is missing and required" pop up 4 times when I tried to run LO after initial install. Version was 3.5.0rc3 per help dialog. 

After clicking them all away LO failed to load unfortunately :(

Looking forward to the fix. 

This is a very challenging first experience for new users to LO.
Comment 28 Michael Meeks 2012-03-15 04:12:10 UTC
Yep - the fix should be in LibreOffice 3.5.1, and yes the previous experience was really bad :-) but it should be nailed now.
Comment 29 Roman Eisele 2012-08-05 11:06:02 UTC
*** Bug 34809 has been marked as a duplicate of this bug. ***
Comment 30 Roman Eisele 2012-08-18 10:20:22 UTC
(In reply to comment #29)
> *** Bug 34809 has been marked as a duplicate of this bug. ***

Please ignore my previous comment, it was wrong -- bug 34809 is a special bug, similar, but not identical to the present on, and the most important thing: bug 34809 is not yet fixed.