Bug 31624

Summary: INSTALLATION: Associate Flat XML documents with LibreOffice if XSLT filters will be installed
Product: LibreOffice Reporter: Kristof Ralovich <kristof.ralovich>
Component: LibreofficeAssignee: Fridrich Strba <fridrich.strba>
Status: RESOLVED FIXED QA Contact:
Severity: critical    
Priority: highest CC: dag, inpost, iplaw67, LibreOffice, pmladek, thumperward
Version: 3.4.3 release   
Hardware: Other   
OS: Windows (All)   
See Also: https://bugs.freedesktop.org/show_bug.cgi?id=39724
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 37361    

Description Kristof Ralovich 2010-11-14 13:21:02 UTC
On windows the default install of LibreOffice is not able to load the Flat XML variants (.fodt, .fods, .fodp, etc.) of the ODF files. Please include the requried XML filter and respective file associations with the default install of LibreOffice.
Comment 1 Don't use this account, use tml@iki.fi 2010-11-19 06:19:39 UTC
For Fridrich?

Should we make that XSLT filters included by default (but unselectable)? Will that have any potential negative effect, do they include some broken or usually unwanted functionality? If so, should we move out the flat XML stuff into a component that is included by default?
Comment 2 Rainer Bielefeld Retired 2011-09-15 22:03:40 UTC
My Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]" has flat.xml filters by default, "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" has not. I will check whether tat is an extra option for the installation.

@Alex, inpost:
Results here might be relevant for Bug 40881.
Comment 3 Rainer Bielefeld Retired 2011-09-19 04:01:46 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". I modified installation and added xslt filters, but FlatXML still is not assigned to LibO. So those .fodx documents can't be opened from WIN Explorer without problems, but opening via LibO file dialog works without problems (I tested for .fodg).
Comment 4 Rainer Bielefeld Retired 2011-09-27 08:19:25 UTC
I do not know whether it's planned to install XSLT filters by default, but if the will be installed (also for customized installation) filetype association should be done.
Comment 5 Dag Wieers 2011-12-02 14:13:30 UTC
Yes, please. I am involved in a project that generates Flat ODF files (.fodt and .fodp) and out-of-the-box support of these file types greatly benefits our use-case.
Comment 6 Björn Michaelsen 2011-12-23 13:25:58 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 7 Kristof Ralovich 2011-12-25 06:10:58 UTC
issue is still present on win32 xp, with:

LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Comment 8 Dag Wieers 2012-02-02 00:59:16 UTC
This is still a problem in LibreOffice 3.5RC2. Because of this Windows users cannot open or export Flat ODF files.

Can we please fix this ASAP (preferably before the release of 3.5.0) ?
Comment 9 Dag Wieers 2012-02-02 01:07:29 UTC
For people having this same issue, you can enable Flat ODF in your LibreOffice installation by rerunning setup and modifying the installation to include:

    Sample XSLT Filters


    setup.exe -> Modify -> Optional Components -> XSLT Sample Filters

Should get you the required filters for using Flat ODF files, but the related file-associations are still not there. The above configuration should become the default on Windows !!
Comment 10 Dag Wieers 2012-02-02 01:09:26 UTC
Can someone verify this ?

I tested on a Windows 7 with the above procedure to enable XSLT Filters and the file associations seem to be there with LibreOffice 3.5RC2, however the XSLT Filters are still not enable by default...
Comment 11 Rainer Bielefeld Retired 2012-02-02 09:51:28 UTC
Comment 12 Petr Mladek 2012-02-03 04:46:06 UTC
I understand that it is annoying, so it is perfectly fine to mention it in the most annoying bugs.

On the other hand, this is very old bug, workaround is easy => it can't block the 3.5.0 release => lovering severity a bit.

Fridrich, any chance to fix this for 3.5.1?
Comment 13 Fridrich Strba 2012-02-03 08:41:09 UTC
(In reply to comment #12)
> Fridrich, any chance to fix this for 3.5.1?

It is already fixed in 3-5, now the XSLT filter is default component on Windows.
If we need to do another rc, maybe it would be nice to include, but I don't vote for it to be blocker for 3.5.0 if no other stuff pops up.
Comment 14 Petr Mladek 2012-02-06 01:26:30 UTC
I have described the workaround at https://wiki.documentfoundation.org/ReleaseNotes/3.5#Most_annoying_bugs. I agree that it should not block the release => closing as fixed.