Bug 31960

Summary: Strange Graphics.
Product: xorg Reporter: Thomas <taxi>
Component: Driver/intelAssignee: Carl Worth <cworth>
Status: RESOLVED INVALID QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: eugeni
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Screenshot
none
new Screenshot none

Description Thomas 2010-11-28 13:02:58 UTC
Created attachment 40617 [details]
Screenshot

Hi, I'm using a 945GM with the xf86-video-intel driver (version 2.13.0).
The used kernel is 2.6.36 with KMS enabled.
In console mode everything is OK. X with the VESA driver produces normal graphics, too. But X with the intel driver is drawing graphics as seen on the screenshot (why is it possible to take screenshots from graphic glitches?).
Disabling DRI (Option "DRI" "false" in xorg.conf) doesn't change anything.
Comment 1 Thomas 2010-11-28 13:40:35 UTC
With
Option "Shadow" "true"
the graphic works with the intel driver, but I think it's not the best workaround.
Comment 2 Thomas 2010-11-28 17:41:37 UTC
Created attachment 40623 [details]
new Screenshot

For testing I updated to the newest git source of libdrm and xf86-video-intel-2.13.901 couse of hardware accelerated 3D.
Now (with Option "Shadow" "true") the "strange pixels" are only in 3D apps (see new Screenshot)

(Accelerated) videos or composited effects (like the panel) are working as they should (but only with Option "Shadow" "true" - without this option even videos have the problem (with 2.13.901 and 2.13.0)).
Maybe this helps identifing the problem.
Comment 3 Thomas 2010-11-28 18:42:44 UTC
I made a little video showing the problem better than the screenshot with 2.13.0: http://home.mnet-online.de/tinka/out.avi
Comment 4 Chris Wilson 2010-11-30 06:54:15 UTC

*** This bug has been marked as a duplicate of bug 31388 ***
Comment 5 Thomas 2010-11-30 08:54:52 UTC
Is this really the same bug?
He has another card, a git version of mesa, another platform and he has this only in one game.
Comment 6 Chris Wilson 2010-11-30 09:16:49 UTC
(In reply to comment #5)
> Is this really the same bug?
Yes.
Comment 7 Thomas 2010-11-30 12:35:49 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Is this really the same bug?
> Yes.
I asked the autor of the other bug if his problem is still there when he downgrades to mesa-7.8.2 (which is the version I'm using) and he sayd _NO_!
So why are you so sure that we have the same bugs?
Comment 8 Thomas 2010-12-04 22:10:20 UTC
The other bug is fixed but the fix doesn't help here.
Comment 9 Thomas 2011-01-12 09:39:57 UTC
I updated to xf86-video-intel-2.14.0.
In 2D graphics it's ok to use "Shadow" "true" but 3D graphics (glxgears for example) have the glitches now (with or without "Shadow" "true")
Comment 10 Thomas 2011-01-12 10:01:54 UTC
Now I tried to run xf86-video-intel-2.14.0 with a 2.6.37-rc8 kernel (my normal kernel is a 2.6.36 one) and the problem still exists.
BUT: When drawing 3d Applications (like glxgears) the windo-decorations are going crazy (I start the window: no decorations, I klick on it: half of the decorations, I klick on another window: no decorations, for example) and sometimes X is just crashing like this (crashed after klicking into the window of glxgears):
...
[   122.471] (II) intel(0): Modeline "1024x576"x0.0   40.00  1024 1072 1104 1124  576 579 584 593 -hsync -vsync (35.6 kHz)
[   152.454] 
Backtrace:
[   152.454] 0: /usr/bin/X (xorg_backtrace+0x38) [0x80ec2f8]
[   152.454] Segmentation fault at address 0xb574582c
[   152.454] 
Fatal server error:
[   152.454] Caught signal 11 (Segmentation fault). Server aborting
[   152.454] 
[   152.454] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   152.454] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   152.454]
...
Comment 11 Eugeni Dodonov 2012-01-13 07:26:18 UTC
Does this still happens with latest versions of the components?
Comment 12 Chris Wilson 2012-10-21 14:30:15 UTC
Timeout. Please do reopen if you can still reproduce the issue and help us diagnose the problem, thanks.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.