Bug 38316

Summary: Hindi Devanagari characters in some fonts with psts encoding are not right
Product: LibreOffice Reporter: Asif Ali Rizvan <fast.rizwaan>
Component: LibreofficeAssignee: Not Assigned <libreoffice-bugs>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: medium CC: khaledhosny
Version: 3.4.0 release   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Attachments: LibreOffice 3.5.0 Beta1, bug persists

Description Asif Ali Rizvan 2011-06-14 14:07:59 UTC
Quick report: I created a unicode compliant hindi font; but it renders incorrectly only in libreoffice and openoffice.

The bug:
1. Some hindi characters in words are not rendered properly; whereas the same words are properly rendered in QT4 and GTK applications

2. Please see the bug in video action: http://www.youtube.com/watch?v=aB9f3CrsNjA

How to reproduce:
3. Download Nithyananda Font which has psts entries for िं, र् x ि, र् x िं (where x is a devanagari consonanat like क प च)

Expected Behavior:
3. Should render text as in qt4 or gtk apps.

Additional information:

Most hindi or devanagari fonts e.g., mangal.ttf or arialunicode.ttf etc. do not have "complete" opentype font substitution table, they use anchors to get these characters without the substitution lookup code. the 3 characters/glyphs are:

िं (devanagari sign I + devanagari sign anusvara/bindu); (किं जिं दिं रिं)
र्ि (devanagari sign I + devanagari sign R halant); (र्कि र्जि र्दि र्रि)
र्िं (devanagari sign I + devanagari sign R halant + bindu); (र्किं र्जिं र्दिं र्रिं)

and Fonts which has the code for the above 3 combinations, the bug triggers, else most common hindi/devanagari fonts do not have the substitution code.
the Fonts which has the code:


It seems to me that Libreoffice 3.4 and Openoffice 3.x do not use the code of "post base substitution" correctly; whereas QT and GTK based applications like kwrite, and gedit, display the above 3 glyphs properly.

Please see a video (3 minutes) of the bug, where kwrite, gedit, and libreoffice writer is shown by typing a few words.


typing or copy pasting the words in libreoffice also causes the bug:

(please notice if a character starts with ि(small i) followed by 2 consonants then a ं (bindu) र्+character (R Halant + character) र्(character)ं (R Halant+consonant+Bindu); then only the bug is visible)


Comment 1 Asif Ali Rizvan 2011-06-16 03:34:01 UTC
I tested this bug with Libreoffice writer 3.3 and 3.4 on Windows XP; this bug is not there in windows, only Linux seems to be affected. I'm using Archlinux.
Comment 2 Björn Michaelsen 2011-12-23 12:23:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Asif Ali Rizvan 2011-12-23 13:56:44 UTC
Created attachment 54759 [details]
LibreOffice 3.5.0 Beta1, bug persists
Comment 4 Asif Ali Rizvan 2011-12-23 14:11:32 UTC
As the previous link for fonts are not working for yogesh and surekh, Please download the fonts from here Bihar Council/Assembly India:


Comment 5 Khaled Hosny 2013-10-30 17:29:22 UTC
This is propably fixed in 4.1.x, but since no reference correct output was presented, I can’t test it myself. Please test and report back.
Comment 6 Asif Ali Rizvan 2013-10-30 17:38:43 UTC
Yes, in 4.1.2 on fedora 20, this bug is  not present. closing! thanks.