Bug 39967

Summary: Graphics fine, boot messages "stairstep", bootlogd saves blank files
Product: plymouth Reporter: yuyu <yuyuyak>
Component: generalAssignee: Ray Strode [halfline] <rstrode>
Status: NEW --- QA Contact:
Severity: minor    
Priority: medium CC: rstrode
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:

Description yuyu 2011-08-09 19:55:16 UTC
This is on Debian Squeeze with 3.0.0 custom kernel (stock kernel does same).  Asus 1000HE with Intel 945 gme, no framebuffers at all installed in this kernel, just the i915 modesetting driver which seems to work great here.  Plymouth version 0.8.3-9.1.  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux".  GRUB_GFXMODE=800x600.  /etc/initramfs-tools/modules contains: intel_agp,drm, i915 modeset=1.  Initially had only the i915 modeset=1 option, same results.
Works fine in every way except the "staircase" boot messages when you hit escape to view them.  Could ignore this, but it somehow also affects bootlogd causing it not to save in /var/log/boot or /var/log/boot.log.
Have fooled with it for many hours over several days, today I removed Plymouth and rebooted, stairstep gone and /var/log/boot is saved.  Boot file is always created, but it is either blank or has the 1st two lines in it, the stairstepping begins "coincidentally" on the 3rd line.  Many lines seem to start in the middle of the screen causing the stairstep effect, each one starting 15 or so spaces further to the left.  Not all lines stairstep, perhaps 8 or 10, then it straightens out somewhat, with the following.  Another 10-15 lines it's the 1st character of the line at the far right of the screen on the line above then the line continues at the left, down 1 space.  Then eventually the last 20 or so messages are just fine.  Too bad I cannot figure out a way to give you a sample.
After proving Plymouth to be the culprit today by removal, I reinstalled and tried several themes, makes no difference.  I have a custom bash script to set theme & update-initramfs, today also tried the "official" updating scripts in /usr/lib/plymouth/plymouth, no help.
1 more thing of interest, this was originally installed using the uvesafb framebuffer.  It's no longer installed at all, but have wondered if Plymouth somehow has a remnant of that in it's memory?  Maybe I should have purged it, went to Synaptic and removed, rebooted, then reinstalled.
For 3 years have I have run Debian, never so much as posted a question, learned alot ;)  But this one's got me licked.  Quite odd that there is little mention of this from others, aside from some ancient bug reports where it was reported fixed.  I love Plymouth, thank you.  But now I have to ask myself "Plymouth?  or boot messages?"  Makes me uncomfortable.
Steps to reproduce:
1.  Start computer
2.  Hit escape to view chaotic boot messages
3.  After boot view empty /var/log/boot file

Comment 1 yuyu 2011-08-10 00:00:32 UTC
This statement: Many lines seem to
start in the middle of the screen causing the stairstep effect, each one
starting 15 or so spaces further to the left

should read "further to the right".


Comment 2 Ray Strode [halfline] 2011-08-10 08:13:29 UTC
Note plymouth does it's own boot logging to /var/log/boot.log

These two commits may help:


It does suggest something is mucking with the tty out from under plymouth, though, which may have other ill effects.

I've been really tardy with getting a 0.8.4 release out.  It's been on my near-term TODO list for months now.
Comment 3 yuyu 2011-08-10 19:49:59 UTC
Yes, I should have mentioned, boot.log comes up empty-handed just as boot does, file created, nothing in it.
Thank you for your quick response and the information.  I shall attempt to install those versions in the next day or two and will report back with my results.
BTW, I don't mind a little foot work here, I am just currently lost.  Starting to study up on that console/tty stuff, maybe I can pinpoint it.  But 1st, the easy route, of course.

Comment 4 Ray Strode [halfline] 2011-08-11 07:49:25 UTC
If you're not getting boot messages to boot.log.

1) make sure plymouthd is started with --attach-to-session
2) make sure bootlogd is disabled
Comment 5 yuyu 2011-08-12 00:53:00 UTC
I am working on it.  You are right, Plymouth is NOT meant to be compiled by end users.  But just about thru that.
Every file I can find with the word plymouthd in it is followed by --attach-to-session.  Not quite clear about it, the plymouth file in /etc/init.d states that it shuts plymouthd down on boot and starts it on shutdown, but after looking at info on the web I checked and it is running even now as I type this.  However, web examples show the --attach-to-session from the ps listing, I do not see that in my listing:
sputnik@sputnik:/$ ps ax|grep plymouthd
 9645 pts/1    S+     0:00 grep plymouthd

One other interesting thing is that after disabling bootlogd the messages are fine in the console screen, no stair stepping.  So in other words, disable either bootlogd or plymouth and the format is normal.  Still, nothing saved in boot.log though, obviously attach-to-session is not happening.
Saved an initramfs.debug log tonight, everything looks fine in there with a quick read.
If nothing else, I am learning about initramfs.