Bug 46885

Summary: LibO crash when creating chart with no cells selected
Product: LibreOffice Reporter: Leif Lodahl <leiflodahl>
Component: ChartAssignee: Markus Mohrhard <markus.mohrhard>
Status: RESOLVED FIXED QA Contact:
Severity: critical    
Priority: medium CC: quest-88
Version: 3.5.1 RC1   
Hardware: x86 (IA32)   
OS: All   
Whiteboard: target:3.6.0 target:3.5.1
i915 platform: i915 features:

Description Leif Lodahl 2012-03-02 03:49:36 UTC
When you start a new chart and have one empty cell selected LibO will crash when you select the Next>> button.
If you select multiple empty cells and then start a new chart LibO will crash immediately.

Ubuntu Linux
Comment 1 Leif Lodahl 2012-03-02 04:10:08 UTC
Same problem on Windows XP. On Windows I see an error message. "Because of an unexpected error..."
Comment 2 Not Assigned 2012-03-04 08:21:51 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":


don't crash for empty input data in charts, fdo#46885
Comment 4 vitriol 2012-03-08 00:26:41 UTC
*** Bug 47088 has been marked as a duplicate of this bug. ***