Bug 51630

Summary: PC hangs after resuming session from hibernation
Product: xorg Reporter: Matias de la Cruz <public>
Component: Driver/savageAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium    
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Matias de la Cruz 2012-07-01 14:32:52 UTC
After upgrading to 2.3.4-2 the laptop simply freezes after resuming from hibernation (slimlock is unlocked fine but resumed session freezes right away).

Downgrading to 2.3.4-1 solved the problem for now.

Build: Archlinux 3.4.4-2
System: IBM Thinkpad T23 laptop
Video Card: S3 SuperSavage IX/C
Video Memory: 16
Video Depth: 16
Driver: savage 2.3.4-1 (downgraded)
Comment 1 Matias de la Cruz 2012-07-02 11:47:31 UTC
Problem persists when upgrading to 2.3.5-1
Comment 2 Matias de la Cruz 2012-07-12 21:15:06 UTC
A look at Xorg.0.log came up with this,

(EE) SAVAGE(0): restarting S3 graphics engine reset  1 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  2 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  3 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  4 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  5 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  6 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  7 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  8 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  9 ...

I have tried to apply the fixes suggested with regard to another bug,

Bug 5569 - savage: glxgears only shows monochrome flicker

and setting 'ShadowStatus' to 'False' does fix my problem. Though I do not know what has changed from 2.3.4-1 to 2.3.5-1 that made me have to enable/change this setting.

Therefore I have changed the status to 'needinfo' in case someone can hint me that change prior to marking it as 'resolved'.
Comment 3 Tormod Volden 2013-02-06 22:53:00 UTC
What is the difference between 2.3.4-1 and 2.3.4-2 ?
Comment 4 Matias de la Cruz 2013-02-09 05:28:41 UTC
(In reply to comment #3)
> What is the difference between 2.3.4-1 and 2.3.4-2 ?

If I had known I presume it would have been easier to report what the source of the problem might have been, similar to this bug/regression I reported

https://bugs.freedesktop.org/show_bug.cgi?id=56550

where the dropping of the XAA module is.

It even seems that due to battling that regression (which include generating new xorg.conf files) I even haven't had used the ShadowStatus 'fix' for quite a while (active driver version is 2.3.6-1) and still hibernation works as it should.

Could the change to Systemd on Arch also have played a role? I honestly don't know.
Comment 5 GitLab Migration User 2018-08-10 20:46:12 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-savage/issues/2.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.