Bug 5471

Summary: 32bit color depth very slow
Product: xorg Reporter: Ron <ginsu.squirrel>
Component: Driver/mgaAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: high    
Version: 7.0.0   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Ron 2006-01-01 21:43:53 UTC
Matrox G450 Dual Head

When I was using 6.8 and the 6.9 cvs snapshots, everything worked fine.  Then
the 7.0 rc's started coming out, and using 32bit depth, programs and colors were
all screwy on one monitor but fine on the other.  Then 7.0 came out, and that
problem went away.

Now the problem is the X server is very laggy with 32bit depth but it's fine for
16bit depth.  As an example, emerging openoffice-bin, which is just extracting
and copying files, took about 2 minutes before switching to 7.0, and it takes
over 15 minutes with 7.0 and 32bit color depth.  On 16bit color depth, it takes
about 2 minutes again.
Comment 1 Ron 2006-04-22 05:51:16 UTC
It seems to be working now with the latest version of everything.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.