Bug 555

Summary: [Solaris-only] Mozilla hangs while printing with Xprint when the code calls XInitThreads()
Product: xprint Reporter: Roland Mainz <roland.mainz>
Component: Client library: XpExtension libraryAssignee: Alan Coopersmith <alan.coopersmith>
Status: RESOLVED NOTOURBUG QA Contact:
Severity: critical    
Priority: high CC: alan.coopersmith, roland.mainz
Version: unspecified   
Hardware: SPARC   
OS: Solaris   
URL: http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=4959553
Whiteboard:
i915 platform: i915 features:

Description Roland Mainz 2004-04-26 07:51:32 UTC
Mozilla 1.7 Beta on Solaris 2.8/SPARC

Mozilla hangs while printing when |XInitThreads()| was called at startup.

Steps to reproduce:
% wget
'http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7rc1/contrib/mozilla-sparc-sun-solaris2.8-1.7rc1.tar.bz2'
% bzcat mozilla-sparc-sun-solaris2.8-1.7rc1.tar.bz2 | tar -xf -
# Teach Mozilla that a Xprint server is available on the remote machine
"meridian", display 35
% export XPSERVERLIST="meridian:35"
# Start Mozilla; the MOZILLA_X11_XINITTHREADS=1 triggers a "secret" option
within Mozilla which causes the code to call XInitThreads() at startup
% (MOZILLA_X11_XINITTHREADS=1 ./mozilla/mozilla)

It seems that http://xprint.mozdev.org/bugs/show_bug.cgi?id=4055 ("Calling
XInitThreads and linking with pthread library causes deadlock in Xprint") was
not fixed for Solaris 2.8 ... ;-(
Comment 1 Alan Coopersmith 2004-04-26 08:28:24 UTC
That bug is recorded in Sun's bug database as 4959553 and has not yet been fixed
in any release of Solaris.  Since Jay Hobson is the engineer the Sun bug is 
assigned to, I'm giving this one to him as well.  (I'm sure he'll love me for
that.8-)
Comment 2 Roland Mainz 2004-04-26 22:40:50 UTC
Alan Coopersmith wrote:
> That bug is recorded in Sun's bug database as 4959553 and has not yet been 
> fixed in any release of Solaris. 

The patch from http://xprint.mozdev.org/bugs/show_bug.cgi?id=4055 ("Calling
XInitThreads and linking with pthread library causes deadlock in Xprint") should
cure the problem.
On demand I can even make a small testcase ... :)

> Since Jay Hobson is the engineer the Sun bug is 
> assigned to, I'm giving this one to him as well. 
> (I'm sure he'll love me for that.8-)

=:-)
Comment 3 Alan Coopersmith 2008-08-04 19:19:06 UTC
This is tracked in Sun's bug db, so doesn't need to be tracked here too,
and should be fixed in the upcoming upgrade of Solaris libXp to current
X.Org sources.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.