Bug 58833

Summary: [945GME DRI] firefox drops core at startup with DRI enabled
Product: Mesa Reporter: MikeW <mrw>
Component: Drivers/DRI/i915Assignee: Ian Romanick <idr>
Status: RESOLVED MOVED QA Contact:
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86 (IA32)   
OS: OpenBSD   
Whiteboard:
i915 platform: i915 features:
Attachments: gdb bt, Xorg log, dmesg, and working xorg.conf

Description MikeW 2012-12-28 17:18:34 UTC
Created attachment 72224 [details]
gdb bt, Xorg log, dmesg, and working xorg.conf

Bug description:
Each time firefox is started it results in a firefox.core file in the home directory. firefox does continue to startup without any more issues. From a gdb backtrace it appears to be a problem in a call to driCreateScreen().  Disabling DRI in an xorg.conf stops firefox creating a core at startup - originally I was not using an xorg.conf so the server configured itself.

System environment:
-- chipset: 82945GME 
-- system architecture: i386
-- xf86-video-intel: 2.12.0
-- xserver: X.Org 7.7 X Server 1.12.2
-- mesa: 7.10.3
-- libdrm: whatever is in OBSD release, sorry.
-- kernel: OpenBSD 5.2 release
-- Linux distribution: OpenBSD
-- Machine or mobo model: Acer Aspire One
-- Display connector:

Reproducing steps:
Start firefox and check home directory when it has finally started.

Additional info:
Use non-root account to reproduce since root does not produce cores by default.

The attachment contains
o a gdb backtrace of a firefox core showing the crash in driCreateScreen()
o The Xorg log for the server which produces a core
o System dmesg
o xorg.conf that stops firefox dumping a core.
Comment 1 Daniel Vetter 2013-01-07 15:31:46 UTC
This smells like something went bust when installing the mesa drivers - we're calling down into a NULL pointer function ... Anyway, this is mesa, not DRI.
Comment 2 Elizabeth 2017-10-27 20:47:34 UTC
Hello, is this still valid with latest SW and after reinstalling Mesa? Otherwise closing soon. Thank you.
Comment 3 GitLab Migration User 2019-09-18 19:35:46 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/724.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.