Bug 6114

Summary: xrandr needs way to set the color bit depth
Product: XStandards Reporter: Joseph Shraibman <freedesktop.org>
Component: ProtocolAssignee: Jim Gettys <jg>
Status: RESOLVED WONTFIX QA Contact:
Severity: enhancement    
Priority: high    
Version: X11R6.6   
Hardware: x86 (IA32)   
OS: Linux (All)   
URL: http://cvs.winehq.org/cvsweb/~checkout~/wine/dlls/x11drv/xrandr.c?content-type=text/plain
Whiteboard:
i915 platform: i915 features:

Description Joseph Shraibman 2006-03-04 07:09:16 UTC
I can't play starcraft under wine because the performance is pretty terrible. 
The problem is that starcraft wants to use 8 bit color, and translating that to
output  on x running under 32 bit color is very cpu intensive.
Comment 1 Jim Gettys 2006-03-04 12:58:10 UTC
We do not plan to add depth changing to RandR along the lines of the original
proposals.

Rather, we intend to support depth changing in compositing managers.  Hardware
compositing support should, on current hardware, be more than fast enough, once
hardware accelerated compositing managers are commonly available.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.