Bug 63392

Summary: [3.8 regression] DP link train failure at 2560x1440 (Thunderbolt)
Product: DRI Reporter: Mathias Fußenegger <freedesktop>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED FIXED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: high    
Version: XOrg git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
log output
none
dmesg with debug=14 none

Description Mathias Fußenegger 2013-04-10 17:29:43 UTC
Created attachment 77760 [details]
log output

Since Kernel 3.8.3 up to including 3.8.6 the system locks up whenever I try to use xrandr --output DP1 --mode 2560x1440 with a monitor connected over thunderbolt.

Last Kernel Version that worked was 3.7.9 although I didn't try anything between 3.7.9 and 3.8.3

Same operation works fine if I'am connected to a older Cinema Display over the mini Display Port.

If the mode is omitted the display works in a low resolution (e.g. xrandr --output DP1 --left-of eDP1 works).
Comment 1 Jani Nikula 2013-04-10 17:41:09 UTC
Please provide full dmesg with drm.debug=0xe module parameter.

Can you be more specific about "lock up"? The small dmesg snippet does not contain anything that should really lock up the system. Could it be the system is alive, but the screen is black?
Comment 2 Mathias Fußenegger 2013-04-16 16:08:39 UTC
Created attachment 78098 [details]
dmesg with debug=14

New dmesg output with drm debug set to 14.
Comment 3 Mathias Fußenegger 2013-04-16 16:10:48 UTC
The thunderbolt display is back, the notebook monitor itself does display the window manager correctly. But I can't move the mouse and it doesn't react to any keyboard input, except the shutdown key.
Comment 4 Chris Wilson 2013-04-16 20:29:06 UTC
Mathias, would you be able to perform a bisect between v3.7.9 and v3.8.3?
Comment 5 Jani Nikula 2013-05-06 13:42:46 UTC
(In reply to comment #4)
> Mathias, would you be able to perform a bisect between v3.7.9 and v3.8.3?

Mathias, any chance for that?
Comment 6 Mathias Fußenegger 2013-07-12 16:00:14 UTC
Hi all,

since there was/is also a Bug around that prevents various kernel versions from booting with efind I wasn't really able to track down which commit introduced the problem. But I've just upgraded to 3.9.9 and now it is working again.
Comment 7 Daniel Vetter 2013-07-12 17:12:16 UTC
Cool, thanks for the update. I'll close this now, please reopen if it breaks again (or file a new bug if something else is amiss).

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.