Bug 65559

Summary: [3.9.y] igt/kms_flip/flip-vs-dpms-off-vs-modeset aborted
Product: DRI Reporter: lu hua <huax.lu>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED FIXED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: xunx.fang, yangweix.shui
Version: unspecified   
Hardware: All   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
dmesg none

Description lu hua 2013-06-09 03:08:08 UTC
Created attachment 80546 [details]
dmesg

System Environment:
--------------------------
Platform: Pineview/Ironlake/Sandybridge/Ivybridge/Haswell
Kernel: (linux-3.9.y)5dd2e9869de2d28fc7e5c274ff9c12af4361ba86
Some additional commit info:
Author: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date:   Fri Jun 7 12:54:00 2013 -0700

    Linux 3.9.5

Bug detailed description:
-------------------------
It aborted on Pineview/Ironlake/Sandybridge/Ivybridge/Haswell with 3.9.5 kernel and latest drm-intel-next-queued kernel. It also happens on Kernel: (linux-3.9.y)4bb08696fab71294c8f1c134a21be9159f82ba08(3.9.3).
It works well on  drm-intel-fixes kernel.
igt/kms_flip/single-buffer-flip-vs-dpms-off-vs-modeset also has this issue.

output:
Using monotonic timestamps
running testcase: flip-vs-dpms-off-vs-modeset
Beginning flip-vs-dpms-off-vs-modeset on crtc 3, connector 9
  1600x1200 60 1600 1664 1856 2160 1200 1201 1204 1250 0x5 0x40 162000
.run_test_step:745 failed, ret=-22, errno=22
Aborted (core dumped)

Reproduce steps:
----------------
1. ./kms_flip --run-subtest flip-vs-dpms-off-vs-modeset
Comment 1 Chris Wilson 2013-06-09 09:09:16 UTC

*** This bug has been marked as a duplicate of bug 65558 ***
Comment 2 Daniel Vetter 2013-06-09 09:20:01 UTC
Just sent a mail to the stable team to backport

commit e3de42b68478a8c95dd27520e9adead2af9477a5
Author: Imre Deak <imre.deak@intel.com>
Date:   Fri May 3 19:44:07 2013 +0200

    drm/i915: force full modeset if the connector is in DPMS OFF mode

As soon as that patch has landed in 3.9.y stable branch it should work.
Comment 3 Daniel Vetter 2013-06-09 09:20:45 UTC
Unmarking duplicate, since this is the bug report for 3.9.y ... (and I've failed to put the cc: stable onto it, so needed to write the backport mail).
Comment 4 lu hua 2013-06-13 07:14:31 UTC
Verified.Fixed.
Comment 5 Jari Tahvanainen 2017-01-12 07:04:52 UTC
Closing verified+fixed.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.