Bug 71369

Summary: xtrans ld error
Product: xorg Reporter: Tobias Klausmann <tobias.johannes.klausmann>
Component: Server/GeneralAssignee: Keith Packard <keithp>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: git   
Hardware: Other   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Tobias Klausmann 2013-11-08 01:11:37 UTC
Build log:
...
[  294s]   CCLD     Xorg
[  295s] ../../os/.libs/libos.a(io.o): In function `ReadFdFromClient':
[  295s] io.c:(.text+0x16a): undefined reference to `_XSERVTransRecvFd'
[  295s] ../../os/.libs/libos.a(io.o): In function `WriteFdToClient':
[  295s] io.c:(.text+0x8ad): undefined reference to `_XSERVTransSendFd'
[  295s] collect2: error: ld returned 1 exit status
...

Addition information:
xserver latest git
xtrans 1.3.1 + commit 6b54b5cf8086f127aa87096e2bdd2263d1c81683
dri3proto-1.0
presentproto-1.0
libxshmfence-1.0

with xtrans 1.3.0 it did build and is running well!

I'm prone to blame commit http://cgit.freedesktop.org/xorg/lib/libxtrans/commit/?id=074614940c570524e1446f55fc12a64415057e1f
where does XTRANS_SEND_FDS get set to 1 at all?

I'm not sure where to report the bug, here or with xtrans, sorry!
Comment 1 Alan Coopersmith 2013-11-08 01:24:42 UTC
http://patchwork.freedesktop.org/patch/15197/
Comment 2 Tobias Klausmann 2013-11-08 01:31:12 UTC
Ah, ok thanks!
I'll leave this open and am ready to test patches, if there are any after the noted one above. Feel free to close it at any time :)
Comment 3 Jos van Wolput 2013-11-12 09:00:53 UTC
(In reply to comment #1)
> http://patchwork.freedesktop.org/patch/15197/

After applying the patch xserver latest git does build and is running well.
Thanks!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.