Bug 72254

Summary: change internal function name: free_pending_restore_data --> free_restore_pending_data
Product: dbus Reporter: Chengwei Yang <chengwei.yang.cn>
Component: coreAssignee: Havoc Pennington <hp>
Status: RESOLVED FIXED QA Contact:
Severity: trivial    
Priority: lowest CC: chengwei.yang.cn
Version: 1.5   
Hardware: All   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments: [PATCH] free_pending_restore_data --> free_restore_pending_data

Description Chengwei Yang 2013-12-03 07:51:16 UTC
In bus/activation.c, all the other places say some kind of resotre_pending, and the struct named RestorePendingData too. So align the function name.
Comment 1 Chengwei Yang 2013-12-03 07:54:26 UTC
Created attachment 90144 [details] [review]
[PATCH] free_pending_restore_data --> free_restore_pending_data
Comment 2 Simon McVittie 2013-12-03 12:16:08 UTC
Comment on attachment 90144 [details] [review]
[PATCH] free_pending_restore_data --> free_restore_pending_data

Review of attachment 90144 [details] [review]:
-----------------------------------------------------------------

I'd have to look at that file in more detail to decide which name is more correct English, and I'm afraid this isn't important enough to do that with any great urgency.

("pending restore data" is grammatically correct - or close enough for programmers - for "data that relates to a restore [operation] that is pending", whereas "restore pending" is only correct if it's an abbreviation for "restore a pending $THING", where $THING might be a signal, or a method invocation, or something like that.)
Comment 3 Simon McVittie 2014-09-09 13:31:55 UTC
Fixed in git for 1.9.0, thanks.

(In reply to comment #2)
> whereas "restore pending" is only correct if it's an abbreviation
> for "restore a pending $THING"

It seems to be that.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.