Bug 79396

Summary: [PATCH] make -j16 fails while installing man page
Product: xorg Reporter: Bernd Kuhls <berndkuhls>
Component: Server/GeneralAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED NOTABUG QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: 7.7 (2012.06)   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
patch to disable parallel make in man/ none

Description Bernd Kuhls 2014-05-29 07:41:55 UTC
Created attachment 100084 [details]
patch to disable parallel make in man/

Hi,

compiling xorg-server-1.15.1 with "make -j16" fails:
http://autobuild.buildroot.net/results/11e/11ece737078ca8da2fee4249432148675b4e630e/build-end.log

Making install in man
 /bin/mkdir -p '/home/test/test/2/output/host/usr/x86_64-buildroot-linux-gnu/sysroot/usr/share/man/man1'
make[2]: Entering directory `/home/test/test/2/output/build/xserver_xorg-server-1.15.1/man'
make[3]: Entering directory `/home/test/test/2/output/build/xserver_xorg-server-1.15.1/man'
make[3]: Nothing to be done for `install-exec-am'.
 /bin/mkdir -p '/home/test/test/2/output/host/usr/x86_64-buildroot-linux-gnu/sysroot/usr/share/man/man1'
 /usr/bin/install -c -m 644 Xserver.1 '/home/test/test/2/output/host/usr/x86_64-buildroot-linux-gnu/sysroot/usr/share/man/man1'
 /usr/bin/install -c -m 644 Xserver.1 '/home/test/test/2/output/host/usr/x86_64-buildroot-linux-gnu/sysroot/usr/share/man/man1'
/usr/bin/install: cannot create regular file `/home/test/test/2/output/host/usr/x86_64-buildroot-linux-gnu/sysroot/usr/share/man/man1/Xserver.1': File exists
make[3]: *** [install-appmanDATA] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/home/test/test/2/output/build/xserver_xorg-server-1.15.1/man'
make[3]: Leaving directory `/home/test/test/2/output/build/xserver_xorg-server-1.15.1/man'
Making install-data in include
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/test/test/2/output/build/xserver_xorg-server-1.15.1/man'
make[1]: *** [install-recursive] Error 1
make[1]: *** Waiting for unfinished jobs....

The attached patch fixes the problem. There maybe other solutions to the problem than disabling parallel make in man/, but I am not an automake expert ;)
Comment 1 Bernd Kuhls 2014-07-19 09:06:25 UTC
The bug occured due to problems with the make system, it´s not a bug in xorg-server, sorry for the noise.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.