Bug 79743

Summary: Hawkey Backend doesn't work with hawkey 0.4.16
Product: PackageKit Reporter: Alfred Neumayer <dev.beidl>
Component: GeneralAssignee: Richard Hughes <richard>
Status: RESOLVED NOTABUG QA Contact:
Severity: major    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Alfred Neumayer 2014-06-06 19:32:59 UTC
Running Fedora 20 with the GNOME 3.12 COPR repository.
PackageKit from this repository (0.9.2-3.fc20) doesn't work right with the hawkey 0.4.16 package from the updates repo.
"pkcon install gimp" results in: 
Fatal error: Failed to find gimp;2:2.8.10-4.fc20;x86_64;updates

After installing gimp via dnf/yum, the same command results in:
Command failed: This tool could not find any available package: No packages were found

Also, listing installed packages as well as installing new packages in GNOME Software fails due to this.

Downgrading hawkey to 0.4.14 (and dnf with it) solves these issues.
Comment 1 Saurav Sengupta 2014-07-05 07:51:35 UTC
Same issue here. However, after I downgraded hawkey, python-hawkey, and dnf, gnome-packagekit-installer always fails to find any packages at all.
Comment 2 Richard Hughes 2018-08-21 15:53:00 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.