Bug 81815

Summary: [hsw] GPU hang while playing Dota 2
Product: Mesa Reporter: Simonas Kazlauskas [:simukis] <simonas+bugs.freedesktop.org>
Component: Drivers/DRI/i965Assignee: Intel 3D Bugs Mailing List <intel-3d-bugs>
Status: RESOLVED MOVED QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: normal    
Priority: medium CC: intel-gfx-bugs
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments: Crash dump

Description Simonas Kazlauskas [:simukis] 2014-07-27 17:54:16 UTC
Created attachment 103553 [details]
Crash dump

> [ 1366.994422] [drm] stuck on render ring
> [ 1366.994426] [drm] GPU crash dump saved to /sys/class/drm/card0/error
> [ 1366.994428] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
> [ 1366.994429] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
> [ 1366.994430] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
> [ 1366.994431] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
> [ 1366.997659] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x961e000 ctx 1) at 0x961fe3c
> [ 1372.980271] [drm] stuck on render ring
> [ 1372.980327] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x3fc2f000 ctx 1) at 0x3fc2f24c
> [ 1372.980330] [drm:i915_context_is_banned] *ERROR* context hanging too fast, declaring banned!

This happens about once or twice each game while playing Dota 2. The game hangs
for a few seconds and then crashes.

Crash happens regardless of texture quality, though on High it subjectively
appears to happen more often than with Low. However I cannot reproduce it
reliably, i.e. it will hang on seemingly random occasions.

gziped contents of /sys/class/drm/card0/error attached.

GPU is Iris™ Pro Graphics 5200 that comes together with Core™ i7-4750HQ.
Comment 1 Matt Turner 2017-03-22 04:41:20 UTC
Sorry no one ever investigated your bug.

Please reopen if you can still reproduce with Mesa 17.0.
Comment 2 GitLab Migration User 2019-09-25 18:51:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1449.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.