Bug 842

Summary: Xserver crash on startup.
Product: xorg Reporter: Johan Bengtsson <johanb>
Component: Driver/intelAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED FIXED QA Contact:
Severity: major    
Priority: high CC: eich
Version: git   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xserver log from crash.
none
Xserver configuration file. none

Description Johan Bengtsson 2004-07-09 01:42:12 UTC
The Xserver crashes on startup, reporting that it failed to allocate hardware
cursor space and set VBE mode. A limitied version of this behavoiur first
appeared in CVS around 20/6 (The first invocation of the Xserver crashed while
the second started OK), but since yesterday the server crashes consequently.

Hardware:
  Dell Latitude D505
  i855GM video controller
  256MB ram.

Software:
  Linux 2.6.7
  Debian unstable
  Gcc 3.3.4
  Xorg CVS-head.
Comment 1 Johan Bengtsson 2004-07-09 01:43:43 UTC
Created attachment 456 [details]
Xserver log from crash.
Comment 2 Johan Bengtsson 2004-07-09 01:53:30 UTC
Created attachment 457 [details]
Xserver configuration file.
Comment 3 Alexander Gottwald 2004-07-09 01:58:56 UTC
*** Bug 841 has been marked as a duplicate of this bug. ***
Comment 4 Johan Bengtsson 2004-07-16 12:38:15 UTC
The problem seems to be related to setting the size of the video memory.
If I use 855patch to patch the BIOS view of the video memory size before
starting the Xserver it does not crash. 

A small note is that according to the documentation regarding Latitude D505 it
should not be necessary to use 855patch.
Comment 5 Johan Bengtsson 2004-07-18 04:57:31 UTC
Some additional comments regarding the 855patch workaround:
The workaround only works if 855patch is invoked before trying to start Xserver. 
I the Xserver is started (and crashes) before invoking 855patch, 855patch will
fail claiming that it can't find the location to patch, meaning that the BIOS
present different views of size the video memory depending on how you check it.
Addning nocheck to 855patch, to make it patch anyway will succeed, however the
Xserver will still crash on startup.
Comment 6 Johan Bengtsson 2004-08-10 12:24:54 UTC
The bug has dissapeared in the CVS version of the driver as of 2004-08-10.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.