Bug 87264

Summary: [i915] Artefacts after reboot
Product: xorg Reporter: Yukari <yukariin>
Component: Driver/intelAssignee: Chris Wilson <chris>
Status: RESOLVED MOVED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
Xorg.0.log
none
Artefacts screenshoot 1
none
Artefacts screenshoot 2
none
dmesg output
none
"xrandr --verbose" output
none
intel_reg_dumper output
none
VBIOS dump
none
Artefacts screenshoot 3
none
Artefacts screenshoot 4
none
Xorg.0.log with --enable-debug=pixmap none

Description Yukari 2014-12-12 13:37:09 UTC
Created attachment 110777 [details]
Xorg.0.log

Bug description:
After update kernel to 3.18.0 I start getting artefacts in my DE (KDE). But restart X-server solve this, until the next reboot.

System environment:
-- chipset: Intel HM55
-- system architecture: 64-bit
-- xf86-video-intel: 2.99.916
-- xserver: 1.16.2.901
-- mesa: 10.3.5
-- libdrm: 2.4.58
-- kernel: 3.18.0 and 3.18.0-gentoo
-- Linux distribution: Gentoo
-- Machine or mobo model: HP G62-b26ER
-- Display connector: standart laptop display (LVDS?)

Reproducing steps:
1. Install 3.18.0 kernel
2. Reboot
3. Login into DE

Additional info:
Comment 1 Yukari 2014-12-12 13:38:12 UTC
Created attachment 110778 [details]
Artefacts screenshoot 1
Comment 2 Yukari 2014-12-12 13:38:34 UTC
Created attachment 110779 [details]
Artefacts screenshoot 2
Comment 3 Yukari 2014-12-12 13:39:18 UTC
Created attachment 110780 [details]
dmesg output
Comment 4 Yukari 2014-12-12 13:40:13 UTC
Created attachment 110781 [details]
"xrandr --verbose" output
Comment 5 Yukari 2014-12-12 13:41:40 UTC
Created attachment 110782 [details]
intel_reg_dumper output
Comment 6 Yukari 2014-12-12 13:44:00 UTC
Created attachment 110783 [details]
VBIOS dump
Comment 7 Chris Wilson 2014-12-12 16:13:23 UTC
You are hitting sw fallback due to a kernel bug, but that shouldn't result in any corruption. :|

Can you describe your KDE setup and if there is an easy way to trigger the corruption (i.e. does it affect any widget/application reliably)?
Comment 8 Yukari 2014-12-12 17:58:11 UTC
I use Gentoo (~amd64) and minimal KDE installation with kde-base/kdebase-meta-4.14.3.
I get those artifacts in window decorations (titles, buttons), main panel, main menu and Konsole. As you can see it on two attached screenshots.
I get they always after first reboot and just login into KDM. Logout (xserver rstart) just solve this.
Comment 9 Yukari 2014-12-13 15:22:32 UTC
Created attachment 110818 [details]
Artefacts screenshoot 3

Also sometimes I get this in firefox.
Scroll or tab switch solve this.
Comment 10 Yukari 2014-12-21 16:41:35 UTC
Created attachment 111116 [details]
Artefacts screenshoot 4

Or this...
Comment 11 Yukari 2015-01-04 15:00:26 UTC
Any progress?
If you need some more info - just say what I should provide and I do it. This issue is very annoying...
Comment 12 Chris Wilson 2015-01-04 20:42:46 UTC
The error was prevented by

commit c211a47c2c28562f8a3fff9e027be1a3ed9e154a
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon Nov 24 11:12:42 2014 +0100

    drm/i915: Disallow pin ioctl completely for kms drivers

However, fixing the actual bug is a lot more tricky and requires reproducing in a debug environment. Perhaps if you recompile xf86-video-intel with ./configure --enable-debug=pixmap that would catch the error?
Comment 13 Yukari 2015-01-06 14:26:41 UTC
(In reply to Chris Wilson from comment #12)
> Perhaps if you recompile xf86-video-intel with
> ./configure --enable-debug=pixmap that would catch the error?
Well, I can try.
Which files you need?
Comment 14 Chris Wilson 2015-01-06 16:39:08 UTC
iirc gentoo have a USE flag for debug and full-debug builds of xf86-video-intel (but not debug=pixmap). If you ask gentoo to do a full-debug of xf86-video-intel that will be enough. If an error is detected, X will quit with a FatalError message, please compress the Xorg.0.log (xz is perfect for the task) and attach. If that proves too big, try

(head -1500 Xorg.0.log; echo ...; tail -1500 Xorg.0.log) | xz -9 > Xorg.0.log.xz
Comment 15 Yukari 2015-01-06 16:48:33 UTC
(In reply to Chris Wilson from comment #14)
> iirc gentoo have a USE flag for debug and full-debug builds of
> xf86-video-intel (but not debug=pixmap). If you ask gentoo to do a
> full-debug of xf86-video-intel that will be enough. If an error is detected,
> X will quit with a FatalError message, please compress the Xorg.0.log (xz is
> perfect for the task) and attach. If that proves too big, try
> 
> (head -1500 Xorg.0.log; echo ...; tail -1500 Xorg.0.log) | xz -9 >
> Xorg.0.log.xz

I can build xf86-video-intel as usual but also add --enable-debug=pixmap.
It's will be enough?
Comment 16 Chris Wilson 2015-01-06 16:55:09 UTC
Yes, that should be enough. It will enable a bunch of sanity checks around operations that may trigger a FatalError if they fail.
Comment 17 Yukari 2015-01-06 17:19:33 UTC
Created attachment 111860 [details]
Xorg.0.log with --enable-debug=pixmap

Well, I'm not see any FatalErrors... Artifacts still here.
Comment 18 Martin Peres 2019-11-27 13:35:15 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel/issues/38.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.