Bug 90164

Summary: segfault when running GStreamer with EGL / GLES2
Product: Mesa Reporter: Lubosz Sarnecki <lubosz>
Component: Drivers/DRI/i965Assignee: Intel 3D Bugs Mailing List <intel-3d-bugs>
Status: RESOLVED MOVED QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: normal    
Priority: medium    
Version: git   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Lubosz Sarnecki 2015-04-24 13:38:43 UTC
Following GStreamer OpenGL code produces a segmentation fault in mesa:
https://gist.github.com/lubosz/d34d73f06c50709e43c1

Backtrace:
https://gist.github.com/lubosz/dfb15646b02d508dfdd7

It only occurs in EGL / GLES2 mode, e.g. GST_GL_API=gles2 GST_GL_PLATFORM=egl

The segfault is reproducible with following EGL apitrace trace:

https://drive.google.com/file/d/0B0bLtNyAhxgoMW4xZ3YzTmFveFk/view

Using Mesa 10.5.3, Linux 4.0
Comment 1 Tapani Pälli 2015-06-08 12:04:27 UTC
Application is calling glDebugMessageControl which is not part of GLES2 API and available only on desktop OpenGL. I've tried to run trace with current Mesa git on i965, it did not segfault but produced GL_INVALID_OPERATION errors on the invalid function calls.
Comment 2 Matt Turner 2016-11-03 22:24:28 UTC
I can reproduce the crash on HSW with current git.
Comment 3 vadym 2018-08-03 10:23:19 UTC
Issue is not reproducible when building from sources.

Setup information:

HW: KBL and HSW
Mesa: Mesa 18.1.2, 18.2.0-devel (git-b5a56a11da).
Comment 4 vadym 2018-08-03 10:24:16 UTC
Hi Lubosz,

Can you please test it again with the latest Mesa ?
Looks like this issue was already fixed at some point.
Comment 5 GitLab Migration User 2019-09-25 18:53:53 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1483.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.