Bug 91565

Summary: [bisected, regression] Assertion `!"Unexpected indexing in ir_set_program_inouts" in GS
Product: Mesa Reporter: Timothy Arceri <t_arceri>
Component: glsl-compilerAssignee: Ian Romanick <idr>
Status: RESOLVED DUPLICATE QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: normal    
Priority: medium    
Version: git   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Timothy Arceri 2015-08-05 11:52:14 UTC
A bunch of GS piglit tests are hitting an assert.

ir_set_program_inouts.cpp:266: bool {anonymous}::ir_set_program_inouts_visitor::try_mark_partial_variable(ir_variable*, ir_rvalue*): Assertion `!"Unexpected indexing in ir_set_program_inouts"' failed.



7ac946e546bba440f87ce95ef022745201744f9c is the first bad commit
commit 7ac946e546bba440f87ce95ef022745201744f9c
Author: Ian Romanick <ian.d.romanick@intel.com>
Date:   Thu Jul 30 06:00:56 2015 -0700

    glsl: Add constuctors for the common cases of glsl_struct_field
    
    Fixes a giant pile of GCC warnings:
    
    builtin_types.cpp:60:1: warning: missing initializer for member 'glsl_struct_field::stream' [-Wmissing-field-initializers]
    
    I had to add a default constructor because a non-default constructor
    was added.  Otherwise the only constructor would be the one with
    parameters, and all the plases like
    
        glsl_struct_field foo;
    
    would fail to compile.
    
    I wanted to do this in two patches.  All of the initializers of
    glsl_struct_field structures had to be converted to use the
    constructor because C++ apparently forces you to do one or the other:
    
    builtin_types.cpp:61:1: error: could not convert '{glsl_type::float_type, "near", -1, 0, 0, 0, GLSL_MATRIX_LAYOUT_INHERITED, 0, -1}' from '<brace-enclosed initializer list>' to 'glsl_struct_field'
    
    Signed-off-by: Ian Romanick <ian.d.romanick@intel.com>
    Reviewed-by: Francisco Jerez <currojerez@riseup.net>
    Reviewed-by: Juha-Pekka Heikkila <juhapekka.heikkila@gmail.com>
Comment 1 Ian Romanick 2015-08-05 15:55:51 UTC
Also, there is a patch on the list.

http://lists.freedesktop.org/archives/mesa-dev/2015-August/090803.html

*** This bug has been marked as a duplicate of bug 91544 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.