Bug 94938

Summary: [BXT] igt gem_reloc_overflow/single-overflow-noprefault is failing
Product: DRI Reporter: Elio <elio.martinez.monroy>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED DUPLICATE QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: minor    
Priority: medium CC: intel-gfx-bugs
Version: DRI git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: BXT i915 features: GEM/Other
Attachments:
Description Flags
Dmesg log none

Description Elio 2016-04-14 19:50:13 UTC
Created attachment 122950 [details]
Dmesg log

The following test is failing:
gem_reloc_overflow/single-overflow-noprefault is failing

Steps to reproduce:
execute ./gem_reloc_overflow --run-subtest single-overflow-noprefault

Spected result:

Test should pass


Actual result:

Test is failing




Configuration:

++ Platform                            : BXT-P
 ++ Motherboard model                   : Broxton P
 ++ Motherboard type                    : NOTEBOOK Hand Held
 ++ Motherboard manufacturer            : Intel Corp.
 ++ CPU family                          : Other
 ++ CPU information                     : 06/5c
 ++ GPU Card                            : Intel Corporation Device 5a84 (rev 03) (prog-if 00 [VGA controller])
 ++ Memory ram                          : 8 GB
 ++ Maximum memory ram allowed          : 16 GB
 ++ Display resolution                  :
 ++ CPU's number                        : 4
 ++ Hard drive capacity                 : 120 GB

 ++ Kernel version                      : 4.6.0-rc3-nightly+
 ++ Linux distribution                  : Ubuntu 15.10
 ++ Architecture                        : 64-bit
 
 ++ xf86-video-intel version            : 2.99.917
 ++ Xorg-Xserver version                : 1.17.2
 ++ DRM version                         : 2.4.64
 
 ++ Cairo version                       : 1.14.2
 ++ Intel GPU Tools version             : Tag [intel-gpu-tools-1.14-133-gc89e8db] / Commit [c89e8db]
 ++ Kernel driver in use                : i915
 ++ Hardware acceleration               :
 ++ Bios revision                       : 131.10
 ++ KSC revision                        : 1.12


Output:
./gem_reloc_overflow --run-subtest single-overflow-noprefault
[sudo] password for gfx:
IGT-Version: 1.14-gc89e8db (x86_64) (Linux: 4.6.0-rc3-nightly+ x86_64)
(gem_reloc_overflow:1224) CRITICAL: Test assertion failure function reloc_tests, file gem_reloc_overflow.c:260:
(gem_reloc_overflow:1224) CRITICAL: Failed assertion: __gem_execbuf(fd, &execbuf) == -14
(gem_reloc_overflow:1224) CRITICAL: error: -22 != -14
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [reloc_tests+0x6ed]
  #2 [<unknown>+0x6ed]
Subtest single-overflow-noprefault failed.
**** DEBUG ****
(gem_reloc_overflow:1224) DEBUG: Test requirement passed: intel_get_avail_ram_mb() > sizeof(struct drm_i915_gem_relocation_entry) * entries / (1024*1024)
(gem_reloc_overflow:1224) DEBUG: relocation_count=4294967295
(gem_reloc_overflow:1224) CRITICAL: Test assertion failure function reloc_tests, file gem_reloc_overflow.c:260:
(gem_reloc_overflow:1224) CRITICAL: Failed assertion: __gem_execbuf(fd, &execbuf) == -14
(gem_reloc_overflow:1224) CRITICAL: error: -22 != -14
****  END  ****
Subtest single-overflow-noprefault: FAIL (1.885s)


Attaching dmesg
Comment 1 Luis Botello 2016-04-28 17:01:17 UTC
The following tests fail on BXT-P with the next configuration 

test cases
================================
gem_reloc_overflow@single-overflow-noprefault



Software information
================================
Kernel version                      : 4.6.0-rc4-drm-intel-nightly-ww17-commit-1e81bac+
Linux distribution                  : Ubuntu 15.10
Architecture                        : 64-bit
Bios revision                       : 129.10
KSC revision                        : 1.6


Hardware information
================================
Platform                            : BXT-P
Motherboard model                   : Broxton P
Motherboard type                    : NOTEBOOK Hand Held
Motherboard manufacturer            : Intel Corp.
CPU family                          : Other
CPU information                     : 06/5c
GPU Card                            : Intel Corporation Device 5a84 (rev 03) (prog-if 00 [VGA controller])
Memory ram                          : 8 GB
Maximum memory ram allowed          : 16 GB


Graphic stack information
================================
 --> Component : drm 
	 url : http://cgit.freedesktop.org/mesa/drm 
	 tag : libdrm-2.4.67-26-g739b888 
	 commit : 739b888 
	 author : Nicolas Dechesne <nicolas.dechesne@linaro.org> 
	 age : 2 weeks ago 
 --> Component : mesa 
	 url : http://cgit.freedesktop.org/mesa/mesa 
	 tag : mesa-11.1.2 
	 commit : 7bcd827 
	 author : Emil Velikov <emil.velikov@collabora.com> 
	 age : 3 months ago 
 --> Component : xf86-video-intel 
	 url : http://cgit.freedesktop.org/xorg/driver/xf86-video-intel 
	 tag : 2.99.917-640-gbca4e0e 
	 commit : bca4e0e 
	 author : Chris Wilson <chris@chris-wilson.co.uk> 
	 age : 2 days ago 
 --> Component : libva 
	 url : http://cgit.freedesktop.org/libva/ 
	 tag : libva-1.7.0-1-g2339d10 
	 commit : 2339d10 
	 author : Xiang Haihao <haihao.xiang@intel.com> 
	 age : 6 weeks ago 
 --> Component : vaapi (intel-driver) 
	 url : http://cgit.freedesktop.org/vaapi/intel-driver 
	 tag : 1.7.0-8-g2c1bec0 
	 commit : 2c1bec0 
	 author : peng.chen <peng.c.chen@intel.com> 
	 age : 3 weeks ago 
 --> Component : cairo 
	 url : http://cgit.freedesktop.org/cairo 
	 tag : 1.15.2 
	 commit : db8a7f1 
	 author : Bryce Harrington <bryce@osg.samsung.com> 
	 age : 5 months ago 
 --> Component : xserver 
	 url :  http://cgit.freedesktop.org/xorg/xserver 
	 tag : xorg-server-1.18.0-291-g16e4bce 
	 commit : 16e4bce 
	 author : Simon Thum <simon.thum@gmx.de> 
	 age : 2 weeks ago 
 --> Component : intel-gpu-tools 
	 url : http://cgit.freedesktop.org/xorg/app/intel-gpu-tools 
	 tag : intel-gpu-tools-1.14-212-g1e9a3ac 
	 commit : 1e9a3ac 
	 author : Chris Wilson <chris@chris-wilson.co.uk> 
	 age : 3 days ago 


kernel information
================================
commit 1e81bacf1f7fdbdf83f46b55389713fa13cb1256
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 24 11:36:51 2016 +0100

    drm-intel-nightly: 2016y-04m-24d-10h-36m-11s UTC integration manifest


Kernel version : 4.6.0-rc4
Architecture : source amd64 all
Homepage : http://www.kernel.org/
Comment 2 yann 2016-04-29 09:13:42 UTC

*** This bug has been marked as a duplicate of bug 94588 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.